aboutsummaryrefslogtreecommitdiff
path: root/audio/csound
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-09-25 08:53:49 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-09-25 08:53:49 +0000
commitfc22f851b1f5281ddb8bc6037d1fadfe69880dff (patch)
tree7d036286fb2d6ad3e952cff884eff32d678114c0 /audio/csound
parent547e367f4ca39f578cc57d26101c8033ab3d6abb (diff)
downloadports-fc22f851b1f5281ddb8bc6037d1fadfe69880dff.tar.gz
ports-fc22f851b1f5281ddb8bc6037d1fadfe69880dff.zip
- When fltk is not installed, scripts/check-fltk-threads.sh misbehaves
due to not checking existence of fltk-config before using it. Fix that by checking existence before using. PR: ports/116623 Submitted by: bgruber <knightbg at yahoo.com> Approved by: Martin Tournoij <carpetsmoker at xs4all.nl> (maintainer)
Notes
Notes: svn path=/head/; revision=200087
Diffstat (limited to 'audio/csound')
-rw-r--r--audio/csound/Makefile3
-rw-r--r--audio/csound/scripts/check-fltk-threads.sh4
2 files changed, 4 insertions, 3 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index 29d05e157df5..f337563c7e3a 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -41,8 +41,9 @@ USE_LDCONFIG= yes
DISTFILES+= ${DISTNAME}-manual.tar.gz:manual
.endif
+FLTKBASE?= ${LOCALBASE}
post-patch: apply-slist
- @/bin/sh ${SCRIPTDIR}/check-fltk-threads.sh
+ @${SETENV} FLTKBASE=${FLTKBASE} ${SH} ${SCRIPTDIR}/check-fltk-threads.sh
@${MV} ${WRKDIR}/custom.py ${WRKSRC}
@${REINPLACE_CMD} -e "s|'unsupported'|'linux'|; \
s|ENV = {'PATH' : os.environ\['PATH'\]}|ENV = os.environ|; \
diff --git a/audio/csound/scripts/check-fltk-threads.sh b/audio/csound/scripts/check-fltk-threads.sh
index 5168db9e1bea..0cd015cf5a37 100644
--- a/audio/csound/scripts/check-fltk-threads.sh
+++ b/audio/csound/scripts/check-fltk-threads.sh
@@ -1,7 +1,7 @@
#!/bin/sh
-if [ -z "$(fltk-config --ldflags | grep pthread)" ]; then
- echo "FLTK does not have threading support enabled.e"
+if [ -x ${FLTKBASE}/bin/fltk-config ] && [ -z "$(fltk-config --ldflags | grep pthread)" ]; then
+ echo "FLTK does not have threading support enabled."
echo "Please remove the x11-toolkits/fltk port first and recompile csound again"
echo "The csound port will automatically install the x11-toolkits/fltk-threads port."
exit 1