aboutsummaryrefslogtreecommitdiff
path: root/audio/cuetools/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-30 12:43:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-30 12:43:23 +0000
commit277046d514bdbe678083361d402340a6c95c2f63 (patch)
treea0cf1c4670b8de54edb915244a3e3a53ed561dee /audio/cuetools/Makefile
parentdd34ea289f8cef54faa15cd9facfacd7b9b1a1d5 (diff)
downloadports-277046d514bdbe678083361d402340a6c95c2f63.tar.gz
ports-277046d514bdbe678083361d402340a6c95c2f63.zip
Add cuetools, a set of utilities for manipulating cue and toc sheets
and converting between them. PR: ports/60714 Submitted by: Vincent Tantardini <vinc@FreeBSD-fr.org>
Notes
Notes: svn path=/head/; revision=96945
Diffstat (limited to 'audio/cuetools/Makefile')
-rw-r--r--audio/cuetools/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/audio/cuetools/Makefile b/audio/cuetools/Makefile
new file mode 100644
index 000000000000..48beb94d5cd4
--- /dev/null
+++ b/audio/cuetools/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cuetools
+# Date created: 30 December 2003
+# Whom: Vincent Tantardini <vinc@FreeBSD-fr.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cuetools
+PORTVERSION= 0.4
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A set of utilities for working with cue files and toc files
+
+USE_REINPLACE= yes
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+.for F in README README.formats ChangeLog
+ ${INSTALL_MAN} ${WRKSRC}/${F} ${DOCSDIR}
+.endfor
+.for E in EXAMPLE.cuerenamerc EXAMPLE.useage
+ ${INSTALL_MAN} ${WRKSRC}/${E} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>