aboutsummaryrefslogtreecommitdiff
path: root/audio/dssi
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-08-13 22:31:58 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-08-13 22:31:58 +0000
commit368f3a8d4276aa061e2b91f5ea3a91a37cac9002 (patch)
treef3b4fd243e462fba3bfc11f1de31622f06e750b1 /audio/dssi
parent30c34a62601adf54882592ad7f6ee03e5b301b0b (diff)
downloadports-368f3a8d4276aa061e2b91f5ea3a91a37cac9002.tar.gz
ports-368f3a8d4276aa061e2b91f5ea3a91a37cac9002.zip
* Add license file
* Cleanup Makefile * Bump PORTREVISION for added USE_XORG depend PR: 221239 Submitted by: Yuri Victorovich Reviewed by: matthew (mentor) Approved by: matthew (mentor) MFH: 2017Q3 Differential Revision: https://reviews.freebsd.org/D11992
Notes
Notes: svn path=/head/; revision=447920
Diffstat (limited to 'audio/dssi')
-rw-r--r--audio/dssi/Makefile37
1 files changed, 12 insertions, 25 deletions
diff --git a/audio/dssi/Makefile b/audio/dssi/Makefile
index 47e523eab9cd..97c7d710b21a 100644
--- a/audio/dssi/Makefile
+++ b/audio/dssi/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dssi
PORTVERSION= 1.1.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= SF
@@ -11,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= API for audio processing plugins
LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:audio/ladspa
LIB_DEPENDS= libdssialsacompat.so:audio/libdssialsacompat \
@@ -20,34 +21,24 @@ LIB_DEPENDS= libdssialsacompat.so:audio/libdssialsacompat \
libjack.so:audio/jack
RUN_DEPENDS= ${LOCALBASE}/include/ladspa.h:audio/ladspa
-USES= gmake pathfix pkgconfig libtool
+USES= gmake pathfix pkgconfig localbase libtool
GNU_CONFIGURE= yes
-
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+USE_XORG= x11
PORTDOCS= ChangeLog README
PORTEXAMPLES= *
-
-EXAMPLESSRCDIR= ${WRKSRC}/examples
-
-EXAMPLES_FILES1= dssi_analyse_plugin dssi_list_plugins \
- dssi_osc_send dssi_osc_update
-
-EXAMPLES_FILES2= LTS_qt trivial_sampler_qt
+EXAMPLESSRCDIR= ${WRKSRC}/examples
+EXAMPLES_FILES1=dssi_analyse_plugin dssi_list_plugins \
+ dssi_osc_send dssi_osc_update
+EXAMPLES_FILES2=LTS_qt trivial_sampler_qt
OPTIONS_DEFINE= DOCS EXAMPLES QT4
-OPTIONS_DEFAULT= QT4
-
+OPTIONS_DEFAULT=QT4
OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MQT4}
-USE_QT4= corelib gui moc_build
+QT4_USE= QT4=corelib,gui,moc_build
QT_NONSTANDARD= yes
-.endif
post-patch:
@${REINPLACE_CMD} -e \
@@ -59,26 +50,22 @@ post-patch:
@${REINPLACE_CMD} -e \
'/alsa >=/s|$$PKG_CONFIG|${FALSE}|' ${WRKSRC}/configure
-.if ! ${PORT_OPTIONS:MQT4}
+post-patch-QT4-off:
@${REINPLACE_CMD} -e \
'/QtCore >=/s|$$PKG_CONFIG|${FALSE}|' ${WRKSRC}/configure
-.endif
post-install:
.for l in trivial_synth less_trivial_synth trivial_sampler karplong
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/dssi/${l}.so
.endfor
-
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_PROGRAM} ${EXAMPLES_FILES1:S|^|${EXAMPLESSRCDIR}/|} \
${STAGEDIR}${EXAMPLESDIR}
-.if ${PORT_OPTIONS:MQT4}
+post-install-QT4-on:
${INSTALL_PROGRAM} ${EXAMPLES_FILES2:S|^|${EXAMPLESSRCDIR}/|} \
${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>