aboutsummaryrefslogtreecommitdiff
path: root/audio/faad
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-08-24 23:33:51 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-08-24 23:33:51 +0000
commitcfb3d4c3ee89044494764dad022b073d5f87fd8f (patch)
tree08026c52a4115e7594c1f46a554980e106daed4a /audio/faad
parentc4bae5559667772cd374a975ab7f97f36f1eb9eb (diff)
downloadports-cfb3d4c3ee89044494764dad022b073d5f87fd8f.tar.gz
ports-cfb3d4c3ee89044494764dad022b073d5f87fd8f.zip
- Update to 2.5
Notes
Notes: svn path=/head/; revision=171348
Diffstat (limited to 'audio/faad')
-rw-r--r--audio/faad/Makefile27
-rw-r--r--audio/faad/distinfo6
-rw-r--r--audio/faad/files/patch-amd64-gcc3447
-rw-r--r--audio/faad/files/patch-configure.in56
-rw-r--r--audio/faad/files/patch-libfaad_common.h20
-rw-r--r--audio/faad/files/patch-structs.h94
-rw-r--r--audio/faad/pkg-plist6
7 files changed, 33 insertions, 223 deletions
diff --git a/audio/faad/Makefile b/audio/faad/Makefile
index bf0605a8cf1d..7d8b35a39604 100644
--- a/audio/faad/Makefile
+++ b/audio/faad/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= faad2
-PORTVERSION= 2.0
-PORTREVISION= 6
+PORTVERSION= 2.5
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -17,45 +16,29 @@ MAINTAINER= multimedia@FreeBSD.org
COMMENT= MPEG-2 and MPEG-4 AAC audio decoder
PATCH_DEPENDS= ${BUILD_DEPENDS}
-LIB_DEPENDS= mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2 \
- sndfile.1:${PORTSDIR}/audio/libsndfile
WRKSRC= ${WRKDIR}/${PORTNAME}
-
NO_CDROM= Restrictive copyright (do not sell for profit)
+USE_DOS2UNIX= yes
USE_AUTOTOOLS= automake:15 autoheader:259 libtool:15
AUTOMAKE_ARGS= --add-missing
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-
+USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-drm
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
-
-INSTALLS_SHLIB= yes
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
post-patch:
-# make sure everything is prepared prior to configure stage
-# pre-configure will not work since *AUTO* tools happen in-between
+ ${MKDIR} ${WRKSRC}/plugins/bmp
@cd ${WRKSRC}; ${ACLOCAL} -I ${ACLOCAL_DIR} -I .; \
${SETENV} ${SCRIPTS_ENV} ${LIBTOOLIZE} --automake
- @${REINPLACE_CMD} -e 's|$$lt_target|$$host|' \
- ${WRKSRC}/aclocal.m4
@${ECHO_CMD} "SUBDIRS = libfaad common frontend" > \
${WRKSRC}/Makefile.am
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|stdint.h|sys/inttypes.h|' \
- ${WRKSRC}/common/mp4ff/mp4ff_int_types.h
-.endif
-# CFLAGS safeness
- @${FIND} ${WRKSRC} -type f -name Makefile.am | \
- ${XARGS} -n 5 -x \
- ${REINPLACE_CMD} -e \
- 's|-O2|${CFLAGS}|'
.include <bsd.port.post.mk>
diff --git a/audio/faad/distinfo b/audio/faad/distinfo
index 764bd7e9aaff..497a4c869340 100644
--- a/audio/faad/distinfo
+++ b/audio/faad/distinfo
@@ -1,3 +1,3 @@
-MD5 (faad2-2.0.tar.gz) = 1a6f79365f2934a4888b210ef47a3a07
-SHA256 (faad2-2.0.tar.gz) = a62a4622862252e53e0dd58c3b0307a138f5100304e07bf50c8aee31a68ab861
-SIZE (faad2-2.0.tar.gz) = 766660
+MD5 (faad2-2.5.tar.gz) = 696490935bf65b2ace4aafaff79e2396
+SHA256 (faad2-2.5.tar.gz) = a75f9642f85030d60c332b02e53fa04e3b4677f73914da2dc1b000689f5f67bb
+SIZE (faad2-2.5.tar.gz) = 751675
diff --git a/audio/faad/files/patch-amd64-gcc34 b/audio/faad/files/patch-amd64-gcc34
deleted file mode 100644
index e1e3ad111364..000000000000
--- a/audio/faad/files/patch-amd64-gcc34
+++ /dev/null
@@ -1,47 +0,0 @@
---- common/mp4v2/mp4property.h.orig Sun Jun 29 17:41:00 2003
-+++ common/mp4v2/mp4property.h Wed Oct 20 19:41:16 2004
-@@ -58,7 +58,7 @@
- return m_name;
- }
-
-- virtual MP4PropertyType GetType() = NULL;
-+ virtual MP4PropertyType GetType() = 0;
-
- bool IsReadOnly() {
- return m_readOnly;
-@@ -74,17 +74,17 @@
- m_implicit = value;
- }
-
-- virtual u_int32_t GetCount() = NULL;
-- virtual void SetCount(u_int32_t count) = NULL;
-+ virtual u_int32_t GetCount() = 0;
-+ virtual void SetCount(u_int32_t count) = 0;
-
- virtual void Generate() { /* default is a no-op */ };
-
-- virtual void Read(MP4File* pFile, u_int32_t index = 0) = NULL;
-+ virtual void Read(MP4File* pFile, u_int32_t index = 0) = 0;
-
-- virtual void Write(MP4File* pFile, u_int32_t index = 0) = NULL;
-+ virtual void Write(MP4File* pFile, u_int32_t index = 0) = 0;
-
- virtual void Dump(FILE* pFile, u_int8_t indent,
-- bool dumpImplicits, u_int32_t index = 0) = NULL;
-+ bool dumpImplicits, u_int32_t index = 0) = 0;
-
- virtual bool FindProperty(const char* name,
- MP4Property** ppProperty, u_int32_t* pIndex = NULL);
---- common/mp4v2/rtphint.h.orig Sun Jun 29 17:41:00 2003
-+++ common/mp4v2/rtphint.h Wed Oct 20 19:41:16 2004
-@@ -35,8 +35,8 @@
- return m_pPacket;
- }
-
-- virtual u_int16_t GetDataSize() = NULL;
-- virtual void GetData(u_int8_t* pDest) = NULL;
-+ virtual u_int16_t GetDataSize() = 0;
-+ virtual void GetData(u_int8_t* pDest) = 0;
-
- MP4Track* FindTrackFromRefIndex(u_int8_t refIndex);
-
diff --git a/audio/faad/files/patch-configure.in b/audio/faad/files/patch-configure.in
index 700ac59cedce..be425fb8f261 100644
--- a/audio/faad/files/patch-configure.in
+++ b/audio/faad/files/patch-configure.in
@@ -1,43 +1,13 @@
---- configure.in.orig Fri Feb 6 17:04:39 2004
-+++ configure.in Wed Jan 19 01:44:24 2005
-@@ -49,6 +49,43 @@
- fi
- ])
-
-+dnl @synopsis AC_C99_FUNC_LRINTF
-+dnl
-+dnl Check whether C99's lrintf function is available.
-+dnl @version 1.3 Feb 12 2002
-+dnl @author Erik de Castro Lopo <erikd AT mega-nerd DOT com>
-+dnl
-+dnl Permission to use, copy, modify, distribute, and sell this file for any
-+dnl purpose is hereby granted without fee, provided that the above copyright
-+dnl and this permission notice appear in all copies. No representations are
-+dnl made about the suitability of this software for any purpose. It is
-+dnl provided "as is" without express or implied warranty.
-+dnl
-+AC_DEFUN([AC_C99_FUNC_LRINTF],
-+[AC_CACHE_CHECK(for lrintf,
-+ ac_cv_c99_lrintf,
-+[
-+lrintf_save_CFLAGS=$CFLAGS
-+CFLAGS="-O -lm"
-+AC_TRY_LINK([
-+#define _ISOC9X_SOURCE 1
-+#define _ISOC99_SOURCE 1
-+#define __USE_ISOC99 1
-+#define __USE_ISOC9X 1
-+
-+#include <math.h>
-+], if (!lrintf(3.14159)) lrintf(2.7183);, ac_cv_c99_lrintf=yes, ac_cv_c99_lrintf=no)
-+
-+CFLAGS=$lrintf_save_CFLAGS
-+
-+])
-+
-+if test "$ac_cv_c99_lrintf" = yes; then
-+ AC_DEFINE(HAVE_LRINTF, 1,
-+ [Define if you have C99's lrintf function.])
-+fi
-+])# AC_C99_FUNC_LRINTF
-+AC_C99_FUNC_LRINTF
+--- configure.in.orig Thu Aug 24 08:55:38 2006
++++ configure.in Thu Aug 24 08:55:58 2006
+@@ -128,10 +128,6 @@
+ AC_CONFIG_FILES(libfaad/Makefile)
+ AC_CONFIG_FILES(common/Makefile)
+ AC_CONFIG_FILES(common/mp4ff/Makefile)
+-AC_CONFIG_FILES(plugins/Makefile)
+-AC_CONFIG_FILES(plugins/xmms/Makefile)
+-AC_CONFIG_FILES(plugins/xmms/src/Makefile)
+-AC_CONFIG_FILES(plugins/mpeg4ip/Makefile)
+ AC_CONFIG_FILES(faad2.spec)
+ AC_CONFIG_FILES(frontend/Makefile)
+ AC_CONFIG_FILES(Makefile)
diff --git a/audio/faad/files/patch-libfaad_common.h b/audio/faad/files/patch-libfaad_common.h
index dfb9a90768c5..8217004ca78b 100644
--- a/audio/faad/files/patch-libfaad_common.h
+++ b/audio/faad/files/patch-libfaad_common.h
@@ -1,16 +1,18 @@
---- libfaad/common.h.orig Fri Feb 6 13:55:24 2004
-+++ libfaad/common.h Wed Jan 19 01:52:32 2005
-@@ -308,6 +308,7 @@
- return i;
- }
- #elif (defined(__i386__) && defined(__GNUC__))
-+ #ifndef HAVE_LRINTF
+--- libfaad/common.h.orig Thu Aug 24 16:50:30 2006
++++ libfaad/common.h Thu Aug 24 16:51:20 2006
+@@ -310,6 +310,7 @@
+
+
+ #if defined(_WIN32) && !defined(__MINGW32__)
++ #ifndef HAVE_LRINTF
#define HAS_LRINTF
- // from http://www.stereopsis.com/FPU.html
static INLINE int lrintf(float f)
-@@ -320,6 +321,7 @@
+ {
+@@ -335,6 +336,7 @@
: "m" (f));
return i;
}
+ #endif /* HAVE_LRINTF */
#endif
+
+
diff --git a/audio/faad/files/patch-structs.h b/audio/faad/files/patch-structs.h
deleted file mode 100644
index 3a0363d9325a..000000000000
--- a/audio/faad/files/patch-structs.h
+++ /dev/null
@@ -1,94 +0,0 @@
---- libfaad/structs.h.orig Thu Jan 29 12:31:11 2004
-+++ libfaad/structs.h Sun May 23 10:52:13 2004
-@@ -307,58 +307,58 @@
- typedef struct mp4AudioSpecificConfig
- {
- /* Audio Specific Info */
-- uint8_t objectTypeIndex;
-- uint8_t samplingFrequencyIndex;
-- uint32_t samplingFrequency;
-- uint8_t channelsConfiguration;
-+ unsigned char objectTypeIndex;
-+ unsigned char samplingFrequencyIndex;
-+ unsigned long samplingFrequency;
-+ unsigned char channelsConfiguration;
-
- /* GA Specific Info */
-- uint8_t frameLengthFlag;
-- uint8_t dependsOnCoreCoder;
-- uint16_t coreCoderDelay;
-- uint8_t extensionFlag;
-- uint8_t aacSectionDataResilienceFlag;
-- uint8_t aacScalefactorDataResilienceFlag;
-- uint8_t aacSpectralDataResilienceFlag;
-- uint8_t epConfig;
-+ unsigned char frameLengthFlag;
-+ unsigned char dependsOnCoreCoder;
-+ unsigned short coreCoderDelay;
-+ unsigned char extensionFlag;
-+ unsigned char aacSectionDataResilienceFlag;
-+ unsigned char aacScalefactorDataResilienceFlag;
-+ unsigned char aacSpectralDataResilienceFlag;
-+ unsigned char epConfig;
-
-- int8_t sbr_present_flag;
-- int8_t forceUpSampling;
-+ char sbr_present_flag;
-+ char forceUpSampling;
- } mp4AudioSpecificConfig;
-
- typedef struct faacDecConfiguration
- {
-- uint8_t defObjectType;
-- uint32_t defSampleRate;
-- uint8_t outputFormat;
-- uint8_t downMatrix;
-- uint8_t useOldADTSFormat;
-- uint8_t dontUpSampleImplicitSBR;
-+ unsigned char defObjectType;
-+ unsigned long defSampleRate;
-+ unsigned char outputFormat;
-+ unsigned char downMatrix;
-+ unsigned char useOldADTSFormat;
-+ unsigned char dontUpSampleImplicitSBR;
- } faacDecConfiguration, *faacDecConfigurationPtr;
-
- typedef struct faacDecFrameInfo
- {
-- uint32_t bytesconsumed;
-- uint32_t samples;
-- uint8_t channels;
-- uint8_t error;
-- uint32_t samplerate;
-+ unsigned long bytesconsumed;
-+ unsigned long samples;
-+ unsigned char channels;
-+ unsigned char error;
-+ unsigned long samplerate;
-
- /* SBR: 0: off, 1: on; normal, 2: on; downsampled */
-- uint8_t sbr;
-+ unsigned char sbr;
-
- /* MPEG-4 ObjectType */
-- uint8_t object_type;
-+ unsigned char object_type;
-
- /* AAC header type; MP4 will be signalled as RAW also */
-- uint8_t header_type;
-+ unsigned char header_type;
-
- /* multichannel configuration */
-- uint8_t num_front_channels;
-- uint8_t num_side_channels;
-- uint8_t num_back_channels;
-- uint8_t num_lfe_channels;
-- uint8_t channel_position[MAX_CHANNELS];
-+ unsigned char num_front_channels;
-+ unsigned char num_side_channels;
-+ unsigned char num_back_channels;
-+ unsigned char num_lfe_channels;
-+ unsigned char channel_position[MAX_CHANNELS];
- } faacDecFrameInfo;
-
- typedef struct
diff --git a/audio/faad/pkg-plist b/audio/faad/pkg-plist
index b347de976f79..f04fded76d42 100644
--- a/audio/faad/pkg-plist
+++ b/audio/faad/pkg-plist
@@ -1,11 +1,7 @@
bin/faad
include/faad.h
-include/mp4ff.h
+include/neaacdec.h
lib/libfaad.a
lib/libfaad.la
lib/libfaad.so
lib/libfaad.so.0
-lib/libmp4ff.a
-lib/libmp4ff.la
-lib/libmp4ff.so
-lib/libmp4ff.so.0