aboutsummaryrefslogtreecommitdiff
path: root/audio/fapg/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-29 10:41:09 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-29 10:41:09 +0000
commit905d669bdd666dd615d1a35d177851ab79d576b1 (patch)
treea96518986b6caac031adc0e39a62cf9a914a1ae0 /audio/fapg/Makefile
parentf9d671cff068987a2930510f4a9ad7866daa100c (diff)
downloadports-905d669bdd666dd615d1a35d177851ab79d576b1.tar.gz
ports-905d669bdd666dd615d1a35d177851ab79d576b1.zip
fapg is a tool to generate list of audio files (Wav, MP3, Ogg, etc) in various
formats (M3U, PLS, HTML, etc). It is very usefull if you have a large amount of audio files and you want to quickly and frequently build a playlist. WWW: http://royale.zerezo.com/fapg/ PR: ports/99300 Submitted by: chinsan <chinsan.tw@gmail.com>
Notes
Notes: svn path=/head/; revision=166575
Diffstat (limited to 'audio/fapg/Makefile')
-rw-r--r--audio/fapg/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/audio/fapg/Makefile b/audio/fapg/Makefile
new file mode 100644
index 000000000000..bc8bd6dc9d4a
--- /dev/null
+++ b/audio/fapg/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: fapg
+# Date created: 2006-06-22
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fapg
+PORTVERSION= 0.35
+CATEGORIES= audio
+MASTER_SITES= http://royale.zerezo.com/${PORTNAME}/
+
+MAINTAINER= chinsan.tw@FreeBSD.org
+COMMENT= Fast Audio Playlist Generator
+
+MAKE_ARGS+= CC=${CC}
+USE_GETOPT_LONG=yes
+
+MAN1= fapg.1
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's,g2,g2 -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib -lgnugetopt,' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '32 s,<,\",; 32 s,>,\",' \
+ ${WRKSRC}/fapg.c
+ @${CP} ${FILESDIR}/getopt.h ${WRKSRC}
+.endif
+
+do-build:
+ @cd ${WRKSRC} && ${MAKE} ${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/fapg.1 ${PREFIX}/man/man1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in COPYING README
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>