aboutsummaryrefslogtreecommitdiff
path: root/audio/festival-freebsoft-utils
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-01-08 08:15:38 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-01-08 08:15:38 +0000
commit10b9bb8657c9976a4a1f131aa137c549c938a667 (patch)
tree0d981f63e3824e2772289ef35aae224efbd5a29d /audio/festival-freebsoft-utils
parent08888413e65b48495652acb6bab10081a8c874ae (diff)
downloadports-10b9bb8657c9976a4a1f131aa137c549c938a667.tar.gz
ports-10b9bb8657c9976a4a1f131aa137c549c938a667.zip
- Add festival-freebsoft-utils
festival-freebsoft-utils is a collection of Festival utilities that enhance Festival with some useful features. They provide all what is needed for interaction with Speech Dispatcher. PR: 142435 Submitted by: Alberto Villa Tested by: myself Approved by: miwi, tabthorpe (mentors iplicit)
Notes
Notes: svn path=/head/; revision=247381
Diffstat (limited to 'audio/festival-freebsoft-utils')
-rw-r--r--audio/festival-freebsoft-utils/Makefile38
-rw-r--r--audio/festival-freebsoft-utils/distinfo3
-rw-r--r--audio/festival-freebsoft-utils/pkg-descr5
-rw-r--r--audio/festival-freebsoft-utils/pkg-plist19
4 files changed, 65 insertions, 0 deletions
diff --git a/audio/festival-freebsoft-utils/Makefile b/audio/festival-freebsoft-utils/Makefile
new file mode 100644
index 000000000000..9b30f0e70cec
--- /dev/null
+++ b/audio/festival-freebsoft-utils/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: festival-freebsoft-utils
+# Date created: 6 January 2010
+# Whom: Alberto Villa <villa.alberto@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= festival-freebsoft-utils
+PORTVERSION= 0.10
+CATEGORIES= audio accessibility
+MASTER_SITES= http://www.freebsoft.org/pub/projects/${PORTNAME}/
+
+MAINTAINER= villa.alberto@gmail.com
+COMMENT= Festival utilities focused on interaction with Speech Dispatcher
+
+RUN_DEPENDS= festival:${PORTSDIR}/audio/festival \
+ sox:${PORTSDIR}/audio/sox
+
+NO_BUILD= yes
+USE_ICONV= yes
+
+PORTDOCS= ANNOUNCE NEWS README
+
+INFO= ${PORTNAME}
+
+do-install:
+ ${MKDIR} ${LOCALBASE}/share/festival/lib
+ cd ${WRKSRC} && ${INSTALL_DATA} *.scm ${LOCALBASE}/share/festival/lib
+ cd ${WRKSRC}/doc && ${INSTALL_MAN} ${PORTNAME}.info ${PREFIX}/${INFO_PATH}
+
+post-install:
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/festival-freebsoft-utils/distinfo b/audio/festival-freebsoft-utils/distinfo
new file mode 100644
index 000000000000..02d1200611a8
--- /dev/null
+++ b/audio/festival-freebsoft-utils/distinfo
@@ -0,0 +1,3 @@
+MD5 (festival-freebsoft-utils-0.10.tar.gz) = 8afc4ef740ce6eb324870102185aa287
+SHA256 (festival-freebsoft-utils-0.10.tar.gz) = c16cbd1d5494b1b058b787ef936fa483ac2f3ce92657372c92b3dbf153750457
+SIZE (festival-freebsoft-utils-0.10.tar.gz) = 73022
diff --git a/audio/festival-freebsoft-utils/pkg-descr b/audio/festival-freebsoft-utils/pkg-descr
new file mode 100644
index 000000000000..8d99cbbe4ff3
--- /dev/null
+++ b/audio/festival-freebsoft-utils/pkg-descr
@@ -0,0 +1,5 @@
+festival-freebsoft-utils is a collection of Festival utilities that
+enhance Festival with some useful features. They provide all what is
+needed for interaction with Speech Dispatcher.
+
+WWW: http://www.freebsoft.org/festival-freebsoft-utils
diff --git a/audio/festival-freebsoft-utils/pkg-plist b/audio/festival-freebsoft-utils/pkg-plist
new file mode 100644
index 000000000000..c9082d1e2750
--- /dev/null
+++ b/audio/festival-freebsoft-utils/pkg-plist
@@ -0,0 +1,19 @@
+share/festival/lib/cap-signalization.scm
+share/festival/lib/events.scm
+share/festival/lib/fileio.scm
+share/festival/lib/multiwave.scm
+share/festival/lib/nopauses.scm
+share/festival/lib/oo.scm
+share/festival/lib/prosody-param.scm
+share/festival/lib/punctuation.scm
+share/festival/lib/recode.scm
+share/festival/lib/speech-dispatcher.scm
+share/festival/lib/spell-mode.scm
+share/festival/lib/ssml-mode.scm
+share/festival/lib/tokenize.scm
+share/festival/lib/util.scm
+share/festival/lib/voice-select.scm
+share/festival/lib/wave.scm
+share/festival/lib/word-mapping.scm
+@dirrmtry share/festival/lib
+@dirrmtry share/festival