aboutsummaryrefslogtreecommitdiff
path: root/audio/firefly
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-12-27 01:43:12 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-12-27 01:43:12 +0000
commit83226e8e67cb99f92690c372f32ca5550dcbffe1 (patch)
tree5fe61dd6d59bdd071cd619d49fb9088fe521ac8e /audio/firefly
parentbb8a67f83f2d48a5af024ec0e701a2b588040b87 (diff)
downloadports-83226e8e67cb99f92690c372f32ca5550dcbffe1.tar.gz
ports-83226e8e67cb99f92690c372f32ca5550dcbffe1.zip
- Depend on sqlite3, which is more likely to be already installed than sqlite2
- Fix a warning when no firefly_enable var is set in rc.conf PR: ports/129617 Submitted by: Ulrich Spoerlein <uspoerlein@gmail.com> Approved by: Mark Foster <mark@foster.cc> (maintainer)
Notes
Notes: svn path=/head/; revision=224841
Diffstat (limited to 'audio/firefly')
-rw-r--r--audio/firefly/Makefile5
-rw-r--r--audio/firefly/files/mt-daapd.in4
2 files changed, 6 insertions, 3 deletions
diff --git a/audio/firefly/Makefile b/audio/firefly/Makefile
index d433707a7374..96f58e57b533 100644
--- a/audio/firefly/Makefile
+++ b/audio/firefly/Makefile
@@ -6,6 +6,7 @@
PORTNAME= firefly
PORTVERSION= 1696
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://nightlies.fireflymediaserver.org/nightlies/svn-${PORTVERSION}/ \
http://www.magnesium.net/~mdf/distfiles/
@@ -19,7 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/vorbis/codec.h:${PORTSDIR}/audio/libvorbis \
RUN_DEPENDS= oggdec:${PORTSDIR}/audio/vorbis-tools \
flac:${PORTSDIR}/audio/flac
LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg \
- sqlite:${PORTSDIR}/databases/sqlite2 \
+ sqlite3.8:${PORTSDIR}/databases/sqlite3 \
id3tag.0:${PORTSDIR}/audio/libid3tag
CONFLICTS= mt-daapd-0.2.*
@@ -30,7 +31,7 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --prefix=${LOCALBASE} --with-id3tag=${PREFIX} --enable-sqlite --enable-oggvorbis --enable-flac
+CONFIGURE_ARGS= --prefix=${LOCALBASE} --with-id3tag=${PREFIX} --enable-sqlite3 --enable-oggvorbis --enable-flac
#USE_AUTOTOOLS= autoheader:261 autoconf:261:env
diff --git a/audio/firefly/files/mt-daapd.in b/audio/firefly/files/mt-daapd.in
index d11ec7d8e6dc..4d081ff7f12a 100644
--- a/audio/firefly/files/mt-daapd.in
+++ b/audio/firefly/files/mt-daapd.in
@@ -6,8 +6,10 @@
. %%RC_SUBR%%
+: ${firefly_enable=NO}
+
name="firefly"
-rcvar="firefly_enable"
+rcvar="`set_rcvar`"
command="%%PREFIX%%/sbin/mt-daapd"
command_args="-c %%PREFIX%%/etc/mt-daapd.conf"