aboutsummaryrefslogtreecommitdiff
path: root/audio/flac/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2023-06-26 20:23:31 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2023-06-26 20:26:21 +0000
commit7a00365c6911b28d5cd5567cda82b086e21423ef (patch)
treed501bcfc97d5298a31c12eb81df1dad4ea076dfd /audio/flac/Makefile
parent2f0d75fa81a4e3632e261968eae7b456b210ce04 (diff)
downloadports-7a00365c6911b28d5cd5567cda82b086e21423ef.tar.gz
ports-7a00365c6911b28d5cd5567cda82b086e21423ef.zip
audio/flac: update to 1.4.3
Improve the flac tool's handling of foreign metadata on decoding a file (i.e. restoring the foreign metadata) and add a few features to the metaflac tool. Both tools have been vetted with fuzzing, resulting in numerous small fixes. All PowerPC-specific code has been removed. PR: 272185
Diffstat (limited to 'audio/flac/Makefile')
-rw-r--r--audio/flac/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/audio/flac/Makefile b/audio/flac/Makefile
index cd6f20679d9b..bb34c9f9d336 100644
--- a/audio/flac/Makefile
+++ b/audio/flac/Makefile
@@ -1,8 +1,9 @@
PORTNAME= flac
-PORTVERSION= 1.4.2
+DISTVERSION= 1.4.3
PORTEPOCH= 1
CATEGORIES= audio
-MASTER_SITES= https://downloads.xiph.org/releases/flac/
+MASTER_SITES= https://downloads.xiph.org/releases/flac/ \
+ https://github.com/xiph/flac/releases/download/${DISTVERSION}/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Free lossless audio codec
@@ -28,8 +29,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static \
--with-ogg="${LOCALBASE}" \
--disable-doxygen-docs \
- --disable-thorough-tests \
- --disable-xmms-plugin
+ --disable-thorough-tests
INSTALL_TARGET= install-strip
TEST_TARGET= check
@@ -37,10 +37,6 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
-.if ${ARCH} != powerpc64le
-CONFIGURE_ARGS+=--disable-vsx
-.endif
-
# test_libFLAC:
# "iterator claims file is writable when tester thinks it should not be"
.if ${UID} == 0