aboutsummaryrefslogtreecommitdiff
path: root/audio/foo-yc20
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-11-01 22:59:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-11-01 22:59:24 +0000
commit9d3cb15a8937500f4d37e888f4227987c2318618 (patch)
treee1974fea7be2b5e010113e6807679395708470eb /audio/foo-yc20
parent6ff36ddc18a5fadb8372b41a2c51c6d41f4b2948 (diff)
downloadports-9d3cb15a8937500f4d37e888f4227987c2318618.tar.gz
ports-9d3cb15a8937500f4d37e888f4227987c2318618.zip
New port: audio/foo-yc20: Faust implementation of a 1969-designed Yamaha combo organ, the YC-20
PR: 221598 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D12894
Notes
Notes: svn path=/head/; revision=453324
Diffstat (limited to 'audio/foo-yc20')
-rw-r--r--audio/foo-yc20/Makefile31
-rw-r--r--audio/foo-yc20/distinfo3
-rw-r--r--audio/foo-yc20/pkg-descr11
-rw-r--r--audio/foo-yc20/pkg-message16
-rw-r--r--audio/foo-yc20/pkg-plist24
5 files changed, 85 insertions, 0 deletions
diff --git a/audio/foo-yc20/Makefile b/audio/foo-yc20/Makefile
new file mode 100644
index 000000000000..839b8e33873d
--- /dev/null
+++ b/audio/foo-yc20/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= foo-yc20
+DISTVERSION= 1.3.0
+CATEGORIES= audio
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Faust implementation of a 1969-designed Yamaha combo organ, the YC-20
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+LIB_DEPENDS= libjack.so:audio/jack \
+ libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
+
+USES= gmake localbase pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= sampov2
+USE_GNOME= gtk20 gdkpixbuf2 cairo
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|install -Dm|install -m|' ${WRKSRC}/Makefile
+
+post-install:
+ @${STRIP_CMD} \
+ ${STAGEDIR}${PREFIX}/bin/* \
+ ${STAGEDIR}${PREFIX}/lib/lv2/foo-yc20.lv2/*.so
+
+.include <bsd.port.mk>
diff --git a/audio/foo-yc20/distinfo b/audio/foo-yc20/distinfo
new file mode 100644
index 000000000000..d20b4f64fd78
--- /dev/null
+++ b/audio/foo-yc20/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1503026073
+SHA256 (sampov2-foo-yc20-1.3.0_GH0.tar.gz) = 6eddf5d60ebe3f6c33476a27be4f1ebd8f262a5787f3ac35068087a24e3a48f7
+SIZE (sampov2-foo-yc20-1.3.0_GH0.tar.gz) = 363123
diff --git a/audio/foo-yc20/pkg-descr b/audio/foo-yc20/pkg-descr
new file mode 100644
index 000000000000..9ad9326befeb
--- /dev/null
+++ b/audio/foo-yc20/pkg-descr
@@ -0,0 +1,11 @@
+This is a Faust implementation of a 1969-designed Yamaha combo organ, the
+YC-20. In addition to the Faust code, it has a Gtkmm UI with Jack audio
+and midi support.
+
+Original YC-20 organs have a touch vibrato control, which is vibrato induced by
+horizontal movement of the keys. As there very few (almost none) midi keyboards
+which produce such information, this feature has been left out of the emulation.
+Instead of the touch vibrato control, the control panel hosts a "realism"
+switch.
+
+WWW: https://github.com/sampov2/foo-yc20
diff --git a/audio/foo-yc20/pkg-message b/audio/foo-yc20/pkg-message
new file mode 100644
index 000000000000..4660e731d3e3
--- /dev/null
+++ b/audio/foo-yc20/pkg-message
@@ -0,0 +1,16 @@
+======================================================================
+You installed foo-yc20: an implementation of 1969 designed Yamaha
+combo organ, the YC-20.
+
+It works through the Jack sound server, and works as a soft-MIDI device.
+
+In order to use it, please:
+* Have Jack server running.
+* Have jack-keyboard (audio/jack-keyboard) running.
+* Have QjackCtl (audio/qjackctl) running.
+* Run the UI command foo-yc20.
+* In QjackCtl, connect:
+ * the MIDI input of foo-yc20 to the output of jack-keyboard.
+ * the foo-yc20 audio output to speakers through the Jack's 'system'.
+* Play the jack-keyboard.
+======================================================================
diff --git a/audio/foo-yc20/pkg-plist b/audio/foo-yc20/pkg-plist
new file mode 100644
index 000000000000..41eb359facfb
--- /dev/null
+++ b/audio/foo-yc20/pkg-plist
@@ -0,0 +1,24 @@
+bin/foo-yc20
+bin/foo-yc20-cli
+lib/lv2/foo-yc20.lv2/foo-yc20-lv2ui.so
+lib/lv2/foo-yc20.lv2/foo-yc20.so
+lib/lv2/foo-yc20.lv2/foo-yc20.ttl
+lib/lv2/foo-yc20.lv2/manifest.ttl
+share/applications/foo-yc20.desktop
+%%DATADIR%%/graphics/background.png
+%%DATADIR%%/graphics/black_0.png
+%%DATADIR%%/graphics/black_1.png
+%%DATADIR%%/graphics/black_2.png
+%%DATADIR%%/graphics/black_3.png
+%%DATADIR%%/graphics/green_0.png
+%%DATADIR%%/graphics/green_1.png
+%%DATADIR%%/graphics/green_2.png
+%%DATADIR%%/graphics/green_3.png
+%%DATADIR%%/graphics/icon.png
+%%DATADIR%%/graphics/potentiometer.png
+%%DATADIR%%/graphics/screenshot-800.png
+%%DATADIR%%/graphics/screenshot.png
+%%DATADIR%%/graphics/white_0.png
+%%DATADIR%%/graphics/white_1.png
+%%DATADIR%%/graphics/white_2.png
+%%DATADIR%%/graphics/white_3.png