aboutsummaryrefslogtreecommitdiff
path: root/audio/ghostess/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-01-28 19:10:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-01-28 19:10:59 +0000
commite1bf900d78877aae0f464d421a41da1b55057026 (patch)
tree62aa25a4382b7d46e5df5914ebc5644a23698a14 /audio/ghostess/Makefile
parent9567288a2e3cafc941e16f950113ce63163fd069 (diff)
downloadports-e1bf900d78877aae0f464d421a41da1b55057026.tar.gz
ports-e1bf900d78877aae0f464d421a41da1b55057026.zip
- Update to version 20120105
PR: 164149 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=289977
Diffstat (limited to 'audio/ghostess/Makefile')
-rw-r--r--audio/ghostess/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/audio/ghostess/Makefile b/audio/ghostess/Makefile
index 34a0a83af58e..4d24e19e4477 100644
--- a/audio/ghostess/Makefile
+++ b/audio/ghostess/Makefile
@@ -6,13 +6,16 @@
#
PORTNAME= ghostess
-PORTVERSION= 20100923
+PORTVERSION= 20120105
CATEGORIES= audio
MASTER_SITES= http://www.smbolton.com/linux/
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphical DSSI host with JACK MIDI support
+LICENSE= GPLv2 BSD
+LICENSE_COMB= multi
+
BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi \
${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa \
jackit>=0.109.2:${PORTSDIR}/audio/jack
@@ -23,14 +26,12 @@ LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
lo.7:${PORTSDIR}/audio/liblo \
jack.0:${PORTSDIR}/audio/jack
-LICENSE= GPLv2 BSD
-LICENSE_COMB= multi
-
USE_BZIP2= yes
USE_GNOME= gtk20
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-jackmidi
+MAKE_JOBS_SAFE= yes
MAN1= ghostess.1
PLIST_FILES= bin/ghostess bin/ghostess_universal_gui
@@ -38,4 +39,8 @@ PLIST_FILES= bin/ghostess bin/ghostess_universal_gui
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/LDADD/s| -ldl | |' ${WRKSRC}/src/Makefile.in
+
.include <bsd.port.mk>