aboutsummaryrefslogtreecommitdiff
path: root/audio/ghostess/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-24 20:39:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-24 20:39:06 +0000
commite9f205222ad644e2ee8148e9c1c57c414d14f8c3 (patch)
treec756bf9bc8f15a1ed85677502327ca9567637499 /audio/ghostess/Makefile
parentd56155d47cd7288475e19a7644cedc23b1b4f7ea (diff)
downloadports-e9f205222ad644e2ee8148e9c1c57c414d14f8c3.tar.gz
ports-e9f205222ad644e2ee8148e9c1c57c414d14f8c3.zip
Ghostess is a a graphical DSSI host, based on jack-dssi-host, but
capable of saving and restoring plugin configuration, as well as specifying MIDI channels and layering synths. ghostess includes three MIDI drivers: an ALSA sequencer MIDI driver, a (clumsy but functional) CoreMIDI driver (which allows ghostess to be used on Mac OS X), and a JACK MIDI driver for use with the MIDI transport in recent versions (>=0.102.27) of JACK. ghostess also comes with a universal DSSI GUI, which attempts to provide GUI services for any DSSI or LADSPA plugin, and may be used with any DSSI host. WWW: http://home.jps.net/~musound/ PR: ports/108131 Submitted by: trasz <trasz at pin.if.uz.zgora.pl>
Notes
Notes: svn path=/head/; revision=183188
Diffstat (limited to 'audio/ghostess/Makefile')
-rw-r--r--audio/ghostess/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/audio/ghostess/Makefile b/audio/ghostess/Makefile
new file mode 100644
index 000000000000..24e4330ddd2c
--- /dev/null
+++ b/audio/ghostess/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ghostess
+# Date created: 2007-01-13
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ghostess
+PORTVERSION= 20061127
+CATEGORIES= audio
+MASTER_SITES= http://home.jps.net/~musound/
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Graphical DSSI host with JACK MIDI support
+
+LIB_DEPENDS= dssialsacompat.0:${PORTSDIR}/audio/libdssialsacompat \
+ lo.6:${PORTSDIR}/audio/liblo \
+ jack.0:${PORTSDIR}/audio/jack
+BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-jackmidi
+USE_GMAKE= yes
+USE_GNOME= gtk20
+
+PLIST_FILES= bin/ghostess bin/ghostess_universal_gui
+
+.include <bsd.port.mk>