aboutsummaryrefslogtreecommitdiff
path: root/audio/gmpc-mserver/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-25 17:57:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-25 17:57:53 +0000
commit80686e7d9b732d4900fa3147c4d7327642c8c168 (patch)
tree6e74e6438bd985df11cf1ec94ce3fd0d2966cacb /audio/gmpc-mserver/Makefile
parent8bcf2c113706c2cd50f0f8f931f698390d81cfc6 (diff)
downloadports-80686e7d9b732d4900fa3147c4d7327642c8c168.tar.gz
ports-80686e7d9b732d4900fa3147c4d7327642c8c168.zip
- Update to 0.19.0
Changelog: http://gmpc.wikia.com/wiki/GMPC_0.19.0 Approved by: portmgr (pav, erwin) Feature safe: yes
Notes
Notes: svn path=/head/; revision=242082
Diffstat (limited to 'audio/gmpc-mserver/Makefile')
-rw-r--r--audio/gmpc-mserver/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/audio/gmpc-mserver/Makefile b/audio/gmpc-mserver/Makefile
index db637697f01a..98bfdaa4dc00 100644
--- a/audio/gmpc-mserver/Makefile
+++ b/audio/gmpc-mserver/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gmpc-mserver
-PORTVERSION= 0.15.5.0
-PORTREVISION= 3
+PORTVERSION= 0.19.0
CATEGORIES= audio
MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION:C/\.0$//}/ \
http://freebsd.unixfreunde.de/sources/
@@ -16,15 +15,20 @@ MAINTAINER= miwi@FreeBSD.org
COMMENT= A plugin for gmpc that serves music.
LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
- curl.5:${PORTSDIR}/ftp/curl
+ curl.5:${PORTSDIR}/ftp/curl \
+ tag.6:${PORTSDIR}/audio/taglib \
+ microhttpd:${PORTSDIR}/www/libmicrohttpd
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+BROKEN= fails to build
+
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
USE_XORG= x11
USE_GNOME= gnomehack
USE_LDCONFIG= yes
-
-IGNORE= does not work with new gmpc
+USE_GMAKE= yes
.include <bsd.port.mk>