aboutsummaryrefslogtreecommitdiff
path: root/audio/gnupod
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /audio/gnupod
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'audio/gnupod')
-rw-r--r--audio/gnupod/Makefile7
-rw-r--r--audio/gnupod/pkg-plist18
2 files changed, 15 insertions, 10 deletions
diff --git a/audio/gnupod/Makefile b/audio/gnupod/Makefile
index 0ae41653de40..98d38b411b1a 100644
--- a/audio/gnupod/Makefile
+++ b/audio/gnupod/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnupod
PORTVERSION= 0.99.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio perl5
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
http://www.blinkenlights.ch/gnupod-dist/stable/
@@ -42,5 +42,10 @@ post-install:
gnupod.texi fdl.texi version.texi ipod.svg
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${STAGEDIR}${DOCSDIR}
.endfor
+ # It tries to guess where it should install it's Perl modules, gets it
+ # wrong, and put them in BSDPAN, so move stuff at the right place.
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
+ ${MV} ${STAGEDIR}${PREFIX}/lib/perl5/${PERL_VER}/BSDPAN/GNUpod ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
+ @${RMDIR} -p ${STAGEDIR}${PREFIX}/lib/perl5/${PERL_VER}/BSDPAN 2>/dev/null || :
.include <bsd.port.mk>
diff --git a/audio/gnupod/pkg-plist b/audio/gnupod/pkg-plist
index fddbb52f9428..e10ffe5982fc 100644
--- a/audio/gnupod/pkg-plist
+++ b/audio/gnupod/pkg-plist
@@ -10,15 +10,15 @@ bin/gnupod_otgsync.pl
bin/gnupod_search.pl
bin/mktunes.pl
bin/tunes2pod.pl
-lib/perl5/%%PERL_VER%%/BSDPAN/GNUpod/ArtworkDB.pm.gz
-lib/perl5/%%PERL_VER%%/BSDPAN/GNUpod/FileMagic.pm.gz
-lib/perl5/%%PERL_VER%%/BSDPAN/GNUpod/FooBar.pm.gz
-lib/perl5/%%PERL_VER%%/BSDPAN/GNUpod/Hash58.pm.gz
-lib/perl5/%%PERL_VER%%/BSDPAN/GNUpod/Mktunes.pm.gz
-lib/perl5/%%PERL_VER%%/BSDPAN/GNUpod/iTunesDB.pm.gz
-lib/perl5/%%PERL_VER%%/BSDPAN/GNUpod/QTfile.pm.gz
-lib/perl5/%%PERL_VER%%/BSDPAN/GNUpod/SysInfo.pm.gz
-lib/perl5/%%PERL_VER%%/BSDPAN/GNUpod/XMLhelper.pm.gz
+%%SITE_PERL%%/GNUpod/ArtworkDB.pm
+%%SITE_PERL%%/GNUpod/FileMagic.pm
+%%SITE_PERL%%/GNUpod/FooBar.pm
+%%SITE_PERL%%/GNUpod/Hash58.pm
+%%SITE_PERL%%/GNUpod/Mktunes.pm
+%%SITE_PERL%%/GNUpod/iTunesDB.pm
+%%SITE_PERL%%/GNUpod/QTfile.pm
+%%SITE_PERL%%/GNUpod/SysInfo.pm
+%%SITE_PERL%%/GNUpod/XMLhelper.pm
man/man1/gnupod_INIT.pl.1.gz
man/man1/gnupod_addsong.pl.1.gz
man/man1/gnupod_check.pl.1.gz