aboutsummaryrefslogtreecommitdiff
path: root/audio/gnupod
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 06:57:16 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 06:57:16 +0000
commitfa8e7fc56e3710cf9058bd0f55bac1a8759f2de5 (patch)
tree196a01f73ca23735228b9062dc8386cb18c0ba09 /audio/gnupod
parentf137a485dc1bf6a0351b5d8d063b9eacfefa15a8 (diff)
downloadports-fa8e7fc56e3710cf9058bd0f55bac1a8759f2de5.tar.gz
ports-fa8e7fc56e3710cf9058bd0f55bac1a8759f2de5.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=297923
Diffstat (limited to 'audio/gnupod')
-rw-r--r--audio/gnupod/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/audio/gnupod/Makefile b/audio/gnupod/Makefile
index da08ba2f24fe..0ecfa5f857b6 100644
--- a/audio/gnupod/Makefile
+++ b/audio/gnupod/Makefile
@@ -37,21 +37,20 @@ NO_BUILD= yes
CONFIGURE_ARGS= --prefix=${PREFIX}
CONFIGURE_ENV= ac_cv_path_PERL=${PERL}
-OPTIONS= FLAC "Enable FLAC support" off \
- VORBIS "Enable Ogg Vorbis support" off
+OPTIONS_DEFINE= FLAC VORBIS DOCS
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_FLAC) || exists(${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm)
+.if ${PORT_OPTIONS:MFLAC} || exists(${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm)
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Audio/FLAC/Header.pm:${PORTSDIR}/audio/p5-Audio-FLAC-Header
.endif
-.if defined(WITH_VORBIS) || exists(${SITE_PERL}/Ogg/Vorbis/Header/PurePerl.pm)
+.if ${PORT_OPTIONS:MVORBIS} || exists(${SITE_PERL}/Ogg/Vorbis/Header/PurePerl.pm)
BUILD_DEPENDS+= ${SITE_PERL}/Ogg/Vorbis/Header/PurePerl.pm:${PORTSDIR}/audio/p5-Ogg-Vorbis-Header-PurePerl
BUILD_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
.endif
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}
@@ -65,4 +64,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/doc/ipod.svg ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>