aboutsummaryrefslogtreecommitdiff
path: root/audio/gogglesmm
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-05-02 18:34:54 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-05-03 03:29:50 +0000
commitaf126b7f5ab438373b1b66656859870f6958036a (patch)
treecd2d5692f4aeb45c70b69e7610cfa9bb5ab126a4 /audio/gogglesmm
parentde4530640445aa72ae5c3b7af102ab04220edb8a (diff)
downloadports-af126b7f5ab438373b1b66656859870f6958036a.tar.gz
ports-af126b7f5ab438373b1b66656859870f6958036a.zip
audio/gogglesmm: Update to 1.2.3
Diffstat (limited to 'audio/gogglesmm')
-rw-r--r--audio/gogglesmm/Makefile5
-rw-r--r--audio/gogglesmm/distinfo6
-rw-r--r--audio/gogglesmm/files/patch-CMakeLists.txt32
-rw-r--r--audio/gogglesmm/files/patch-gap_fox.h43
-rw-r--r--audio/gogglesmm/files/patch-src_CMakeLists.txt6
-rw-r--r--audio/gogglesmm/files/patch-src_GMFilename.cpp40
-rw-r--r--audio/gogglesmm/files/patch-src_GMIconTheme.cpp16
-rw-r--r--audio/gogglesmm/files/patch-src_GMIconTheme.h16
-rw-r--r--audio/gogglesmm/files/patch-src_gmdefs.h32
-rw-r--r--audio/gogglesmm/pkg-plist2
10 files changed, 11 insertions, 187 deletions
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
index e3b6791dd871..88660ce99a18 100644
--- a/audio/gogglesmm/Makefile
+++ b/audio/gogglesmm/Makefile
@@ -1,6 +1,5 @@
PORTNAME= gogglesmm
-PORTVERSION= 1.2.2
-PORTREVISION= 11
+PORTVERSION= 1.2.3
CATEGORIES= audio
MAINTAINER= jhale@FreeBSD.org
@@ -21,7 +20,7 @@ USES= cmake compiler:c++11-lib desktop-file-utils gnome \
USE_GITHUB= yes
USE_XORG= ice sm x11
-CMAKE_OFF= WITH_CFOX WITH_IMPORT
+CMAKE_OFF= WITH_CFOX
PORTDOCS= AUTHORS ChangeLog README
diff --git a/audio/gogglesmm/distinfo b/audio/gogglesmm/distinfo
index 538fbbadc3e9..e2dca47e86ab 100644
--- a/audio/gogglesmm/distinfo
+++ b/audio/gogglesmm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1610461380
-SHA256 (gogglesmm-gogglesmm-1.2.2_GH0.tar.gz) = e9d576584ea48346cd3b577967ccb40bf67113b91e8252d62052be3725b9d9fa
-SIZE (gogglesmm-gogglesmm-1.2.2_GH0.tar.gz) = 3120591
+TIMESTAMP = 1683051500
+SHA256 (gogglesmm-gogglesmm-1.2.3_GH0.tar.gz) = 4315ea4d9894fa2c7f160c73e5464b91b7a00f22964910adb77e1e9b94273006
+SIZE (gogglesmm-gogglesmm-1.2.3_GH0.tar.gz) = 3153723
diff --git a/audio/gogglesmm/files/patch-CMakeLists.txt b/audio/gogglesmm/files/patch-CMakeLists.txt
index 73376258ab1c..6ca5cb382909 100644
--- a/audio/gogglesmm/files/patch-CMakeLists.txt
+++ b/audio/gogglesmm/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2020-12-27 21:40:54 UTC
+--- CMakeLists.txt.orig 2023-04-23 15:13:49 UTC
+++ CMakeLists.txt
-@@ -67,6 +67,11 @@ endif()
+@@ -69,6 +69,11 @@ endif()
add_compile_options(-Og)
endif()
@@ -12,31 +12,3 @@
# FIXME Doesn't work on all platforms.
#CHECK_CXX_COMPILER_FLAG(-flto HAS_CXX_OPTIMIZE_LINKTIME)
if(HAS_CXX_OPTIMIZE_LINKTIME AND NOT CMAKE_BUILD_TYPE MATCHES Debug)
-@@ -100,11 +105,13 @@ add_subdirectory(src)
- #-------------------------------------------------------------------------------
-
- # Extra Installation Files
--install(PROGRAMS extra/import_banshee_stats.py
-- extra/import_gogglesmm12.py
-- extra/import_gogglesmm12_stats.py
-- DESTINATION
-- share/gogglesmm)
-+if(WITH_IMPORT)
-+ install(PROGRAMS extra/import_banshee_stats.py
-+ extra/import_gogglesmm12.py
-+ extra/import_gogglesmm12_stats.py
-+ DESTINATION
-+ share/gogglesmm)
-+endif()
-
- install(FILES icons/gogglesmm_16.png DESTINATION share/icons/hicolor/16x16/apps RENAME gogglesmm.png)
- install(FILES extra/gogglesmm_22.png DESTINATION share/icons/hicolor/22x22/apps RENAME gogglesmm.png)
-@@ -115,7 +122,7 @@ install(FILES extra/gogglesmm.desktop DESTINATION shar
- install(FILES extra/gogglesmm.svg DESTINATION share/icons/hicolor/scalable/apps RENAME gogglesmm.svg)
- install(FILES extra/gogglesmm.appdata.xml DESTINATION share/metainfo)
- install(FILES extra/gogglesmm.desktop DESTINATION share/applications)
--install(FILES extra/gogglesmm.1 DESTINATION share/man/man1)
-+install(FILES extra/gogglesmm.1 DESTINATION man/man1)
-
- # Install translations when native language support has been enabled
- if(WITH_NLS)
diff --git a/audio/gogglesmm/files/patch-gap_fox.h b/audio/gogglesmm/files/patch-gap_fox.h
deleted file mode 100644
index 70dcf116e1c6..000000000000
--- a/audio/gogglesmm/files/patch-gap_fox.h
+++ /dev/null
@@ -1,43 +0,0 @@
-Fix build with FOX >= 1.7.80
-
---- gap/fox.h.orig 2020-12-27 21:40:54 UTC
-+++ gap/fox.h
-@@ -35,6 +35,12 @@
- #define FXVERSION(major,minor,release) ((release)+(minor*1000)+(major*100000))
-
- #include <fxdefs.h>
-+#if FOXVERSION >= FXVERSION(1, 7, 80)
-+#include <fxchar.h>
-+#endif
-+#if FOXVERSION >= FXVERSION(1, 7, 81)
-+#include <fxmath.h>
-+#endif
- #include <fxendian.h>
- #include <fxascii.h>
- #include <fxunicode.h>
-@@ -121,6 +127,25 @@ constexpr FXTime operator"" _ms(unsigned long long int
- {
- return value * NANOSECONDS_PER_MILLISECOND;
- }
-+
-+#if FOXVERSION >= FXVERSION(1, 7, 80)
-+#include <utility>
-+#define FX_ALIAS_SPEC(SPECS, NEW_NAME, ...) \
-+ template <typename... Args> \
-+ SPECS auto NEW_NAME(Args &&... args) \
-+ noexcept(noexcept(__VA_ARGS__(std::forward<Args>(args)...))) \
-+ -> decltype(__VA_ARGS__(std::forward<Args>(args)...)) { \
-+ return __VA_ARGS__(std::forward<Args>(args)...); \
-+ }
-+
-+#define FX_ALIAS(NEW_NAME, ...) \
-+ FX_ALIAS_SPEC(inline, NEW_NAME, __VA_ARGS__)
-+
-+FX_ALIAS(compare, FXString::compare)
-+FX_ALIAS(comparecase, FXString::comparecase)
-+FX_ALIAS(compareversion, FXString::comparenatural)
-+#define FXISFOLLOWUTF8 followUTF8
-+#endif
-
- #endif
-
diff --git a/audio/gogglesmm/files/patch-src_CMakeLists.txt b/audio/gogglesmm/files/patch-src_CMakeLists.txt
index 1ee1f638832f..4cbca02111dd 100644
--- a/audio/gogglesmm/files/patch-src_CMakeLists.txt
+++ b/audio/gogglesmm/files/patch-src_CMakeLists.txt
@@ -1,6 +1,6 @@
---- src/CMakeLists.txt.orig 2018-07-03 11:39:26 UTC
+--- src/CMakeLists.txt.orig 2023-04-23 15:13:49 UTC
+++ src/CMakeLists.txt
-@@ -71,7 +71,7 @@ if(WITH_CFOX)
+@@ -71,7 +71,7 @@ else()
set(RESWRAP_CPP ${RESWRAP} --keep-ext --source --extern)
set(RESWRAP_TEXT ${RESWRAP} --keep-ext -t)
else()
@@ -9,7 +9,7 @@
if(RESWRAP)
message(STATUS "Found reswrap: ${RESWRAP}")
execute_process(COMMAND ${RESWRAP} -v OUTPUT_VARIABLE RESWRAP_OUTPUT)
-@@ -345,4 +345,4 @@ target_link_libraries(gogglesmm PRIVATE gap ${CFOX}
+@@ -362,4 +362,4 @@ target_link_libraries(gogglesmm PRIVATE gap ${CFOX}
${ICE_LIBRARIES}
${Intl_LIBRARIES})
diff --git a/audio/gogglesmm/files/patch-src_GMFilename.cpp b/audio/gogglesmm/files/patch-src_GMFilename.cpp
deleted file mode 100644
index 96f978ded968..000000000000
--- a/audio/gogglesmm/files/patch-src_GMFilename.cpp
+++ /dev/null
@@ -1,40 +0,0 @@
-Fix build with FOX 1.7.80
-
---- src/GMFilename.cpp.orig 2022-10-28 03:22:22 UTC
-+++ src/GMFilename.cpp
-@@ -102,7 +102,11 @@ FXString TextConverter::apply_filters(const FXString &
- else if (modifiers&UPPERCASE)
- n+=wc2utf(Unicode::toUpper(src.wc(i)));
- else
-+#if FOXVERSION >= FXVERSION(1,7, 80)
-+ n+=lenUTF8(src[i]);
-+#else
- n+=src.extent(i);
-+#endif
- }
- }
-
-@@ -167,7 +171,11 @@ FXString TextConverter::apply_codec(const FXString & s
- else if (Unicode::isPrint(src.wc(i))) {
- if (codec->wc2mb(&c,1,src.wc(i))==1) {
- if (c==undefined_character) {
-+#if FOXVERSION >= FXVERSION(1,7,80)
-+ FXString dcm = FXString::decompose(src.mid(i,lenUTF8(src[i])),false);
-+#else
- FXString dcm = FXString::decompose(src.mid(i,src.extent(i)),false);
-+#endif
- for (FXint j=0;j<dcm.length();j+=dcm.inc(j)) {
- if (Unicode::isPrint(dcm.wc(j)) && codec->wc2mb(&c,1,dcm.wc(j)) && c!=0x1a) {
- n++;
-@@ -190,7 +198,11 @@ FXString TextConverter::apply_codec(const FXString & s
- if (c==undefined_character) {
- /* If codec didn't contain a mapping to the required character,
- do a compatibility decomposition and try mapping those */
-+#if FOXVERSION >= FXVERSION(1,7,80)
-+ FXString dcm = FXString::decompose(src.mid(i,lenUTF8(src[i])),false);
-+#else
- FXString dcm = FXString::decompose(src.mid(i,src.extent(i)),false);
-+#endif
- for (FXint j=0;j<dcm.length();j+=dcm.inc(j)) {
- if (Unicode::isPrint(dcm.wc(j)) && codec->wc2mb(&c,1,dcm.wc(j)) && c!=undefined_character) {
- dst[n++]=c;
diff --git a/audio/gogglesmm/files/patch-src_GMIconTheme.cpp b/audio/gogglesmm/files/patch-src_GMIconTheme.cpp
deleted file mode 100644
index 72d2d976b545..000000000000
--- a/audio/gogglesmm/files/patch-src_GMIconTheme.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix build with FOX 1.7.80
-
---- src/GMIconTheme.cpp.orig 2022-10-28 03:25:41 UTC
-+++ src/GMIconTheme.cpp
-@@ -569,7 +569,11 @@ void GMIconTheme::loadLarge(FXIconPtr & icon,const FXc
- loadIcon(icon,FXString::null,largesize,value,blendcolor);
- }
-
-+#if FOXVERSION >= FXVERSION(1, 7, 80)
-+void GMIconTheme::loadResource(FXIconPtr & icon,const FXuchar * data,const FXColor blendcolor,const char * type) {
-+#else
- void GMIconTheme::loadResource(FXIconPtr & icon,const void * data,const FXColor blendcolor,const char * type) {
-+#endif
- FXIconSource source;
- FXIcon * newicon = source.loadIconData(app,data,type);
- FXASSERT(newicon);
diff --git a/audio/gogglesmm/files/patch-src_GMIconTheme.h b/audio/gogglesmm/files/patch-src_GMIconTheme.h
deleted file mode 100644
index 09f947bb85f3..000000000000
--- a/audio/gogglesmm/files/patch-src_GMIconTheme.h
+++ /dev/null
@@ -1,16 +0,0 @@
-Fix build with FOX 1.7.80
-
---- src/GMIconTheme.h.orig 2022-10-28 03:25:54 UTC
-+++ src/GMIconTheme.h
-@@ -47,7 +47,11 @@ class GMIconTheme { (protected)
- FXImage * loadImage(const FXString & filename);
- protected:
- void loadIcon(FXIconPtr & icon,const FXString &pathlist,FXint size,const char * value,const FXColor blend);
-+#if FOXVERSION >= FXVERSION(1, 7, 80)
-+ void loadResource(FXIconPtr & icon,const FXuchar * data,const FXColor blend,const char * type="png");
-+#else
- void loadResource(FXIconPtr & icon,const void * data,const FXColor blend,const char * type="png");
-+#endif
- protected:
- FXbool load_cache();
- void save_cache();
diff --git a/audio/gogglesmm/files/patch-src_gmdefs.h b/audio/gogglesmm/files/patch-src_gmdefs.h
deleted file mode 100644
index 20e946110452..000000000000
--- a/audio/gogglesmm/files/patch-src_gmdefs.h
+++ /dev/null
@@ -1,32 +0,0 @@
-Fix build with FOX 1.7.80
-
---- src/gmdefs.h.orig 2020-12-27 21:40:54 UTC
-+++ src/gmdefs.h
-@@ -93,5 +93,27 @@ extern const FXchar * fxtr(const FXchar *) FX_FORMAT(1
- // Best Image Scaler in FXImage
- #define FOX_SCALE_BEST 2
-
-+#if FOXVERSION >= FXVERSION(1, 7, 80)
-+#include <utility>
-+#define FX_ALIAS_SPEC(SPECS, NEW_NAME, ...) \
-+ template <typename... Args> \
-+ SPECS auto NEW_NAME(Args &&... args) \
-+ noexcept(noexcept(__VA_ARGS__(std::forward<Args>(args)...))) \
-+ -> decltype(__VA_ARGS__(std::forward<Args>(args)...)) { \
-+ return __VA_ARGS__(std::forward<Args>(args)...); \
-+ }
-+
-+#define FX_ALIAS(NEW_NAME, ...) \
-+ FX_ALIAS_SPEC(inline, NEW_NAME, __VA_ARGS__)
-+
-+FX_ALIAS(compare, FXString::compare)
-+FX_ALIAS(comparecase, FXString::comparecase)
-+FX_ALIAS(compareversion, FXString::comparenatural)
-+#define FXISFOLLOWUTF8 followUTF8
-+#define FXISLEADUTF16 leadUTF16
-+#define FXISFOLLOWUTF16 followUTF16
-+#define FXISSEQUTF16 seqUTF16
-+#endif
-+
- #endif
-
diff --git a/audio/gogglesmm/pkg-plist b/audio/gogglesmm/pkg-plist
index b1264a8c01f0..e36b78048d68 100644
--- a/audio/gogglesmm/pkg-plist
+++ b/audio/gogglesmm/pkg-plist
@@ -4,7 +4,6 @@ lib/gogglesmm/libgap_oss.so
%%PULSEAUDIO%%lib/gogglesmm/libgap_pulse.so
%%SNDIO%%lib/gogglesmm/libgap_sndio.so
lib/gogglesmm/libgap_wav.so
-man/man1/gogglesmm.1.gz
share/applications/gogglesmm.desktop
share/icons/hicolor/16x16/apps/gogglesmm.png
share/icons/hicolor/22x22/apps/gogglesmm.png
@@ -20,4 +19,5 @@ share/icons/hicolor/scalable/apps/gogglesmm.svg
%%NLS%%share/locale/ko/LC_MESSAGES/gogglesmm.mo
%%NLS%%share/locale/pt/LC_MESSAGES/gogglesmm.mo
%%NLS%%share/locale/ru/LC_MESSAGES/gogglesmm.mo
+share/man/man1/gogglesmm.1.gz
share/metainfo/gogglesmm.appdata.xml