aboutsummaryrefslogtreecommitdiff
path: root/audio/gogo/Makefile
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-19 13:55:25 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-19 13:55:25 +0000
commit038f73a9e1e9ec9fbe8cd3c95a3707f3d4bcc8ac (patch)
tree755909b0d0f2772e11824c4029e2397822156c73 /audio/gogo/Makefile
parent9b918cd056ea6bc2526b413d4009c14b5bd75edf (diff)
downloadports-038f73a9e1e9ec9fbe8cd3c95a3707f3d4bcc8ac.tar.gz
ports-038f73a9e1e9ec9fbe8cd3c95a3707f3d4bcc8ac.zip
- Use OPTIONS
- Nuke pkg-plist - Minimize Makefile-patch
Notes
Notes: svn path=/head/; revision=133667
Diffstat (limited to 'audio/gogo/Makefile')
-rw-r--r--audio/gogo/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/audio/gogo/Makefile b/audio/gogo/Makefile
index 0182422a070f..e16debe54bc0 100644
--- a/audio/gogo/Makefile
+++ b/audio/gogo/Makefile
@@ -16,28 +16,31 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Very fast MP3 encoder using recent x86 processors' features
+OPTIONS= THREADS "Use linuxthreads for increased SMP performance" off
+
# More than version 0.98
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_GMAKE= yes
ALL_TARGET= gogo
+MAKE_ARGS= CC="${CC}" LD="${CC}"
RESTRICTED= Condition is not clear
ONLY_FOR_ARCHS= i386
+PLIST_FILES= bin/cdda2mp3.gogo bin/gogo
+PORTDOCS= cdda2mp3.gogo.en cdda2mp3.gogo.ja
+
# A sample of heavily optimized CFLAGS(typically used with pgcc).
# Recommended ONLY for benchmarks.
# CFLAGS=-march=pentiumpro -O6 -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -foptimize-register-move -ffast-math -fdefer-pop -mfancy-math-387
.include <bsd.port.pre.mk>
-pre-fetch:
-.if !defined(WITH_THREADS)
- @${ECHO_MSG} "set WITH_THREADS to compile with linuxthreads."
- @${ECHO_MSG} "It would increase performance in SMP environment."
-MAKE_ENV+= "USE_MT=no"
+.if defined(WITHOUT_THREADS)
+MAKE_ARGS+= "USE_MT=no"
.else
-MAKE_ENV+= "USE_MT=yes"
+MAKE_ARGS+= "USE_MT=yes"
.if ${OSVERSION} >= 500035
LIB_DEPENDS= lthread.3:${PORTSDIR}/devel/linuxthreads
.else