aboutsummaryrefslogtreecommitdiff
path: root/audio/gsi
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-10 22:49:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-10 22:49:20 +0000
commit41df7de0d288c3cd6f98669a13d7311113492cd8 (patch)
tree9ee0b6d10c2f38ae4afe03cfbd456effba0be0a6 /audio/gsi
parent25c606a18dd9cf59f6dd6335a88fb3d818fdf67f (diff)
downloadports-41df7de0d288c3cd6f98669a13d7311113492cd8.tar.gz
ports-41df7de0d288c3cd6f98669a13d7311113492cd8.zip
- Fix build with gcc 4.2
- Pass maintainership to submitter PR: 118466 Submitted by: Pietro Cerutti <gahr@gahr.ch> Approved by: portmgr (erwin)
Notes
Notes: svn path=/head/; revision=202937
Diffstat (limited to 'audio/gsi')
-rw-r--r--audio/gsi/Makefile18
-rw-r--r--audio/gsi/files/patch-lib-gsif-sample_convert_block.c44
2 files changed, 50 insertions, 12 deletions
diff --git a/audio/gsi/Makefile b/audio/gsi/Makefile
index 5d1281ead975..638c0b657b1a 100644
--- a/audio/gsi/Makefile
+++ b/audio/gsi/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@gahr.ch
COMMENT= General sound interface
USE_BZIP2= yes
@@ -28,24 +28,18 @@ MAN5= gsi.conf.5
MAN7= gsi_overview.7
MAN8= gsi_server.8
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-extract:
@${RM} -f ${WRKSRC}/lib/include/gsi/gsisynth.h
post-patch:
-.for file in lib/device/gsimixer/api/mixer_fbsd.c \
+.for f in lib/device/gsimixer/api/mixer_fbsd.c \
lib/device/gsipcm/api/pcm_fbsd.c
@${REINPLACE_CMD} -e \
- 's|machine/soundcard.h|sys/soundcard.h|g' ${WRKSRC}/${file}
+ 's|machine/soundcard.h|sys/soundcard.h|g' ${WRKSRC}/${f}
.endfor
-.for file in server/FINISH_host_allow.c server/client.c server/conf.c
+.for f in server/FINISH_host_allow.c server/client.c server/conf.c
@${REINPLACE_CMD} -e \
- 's|"/etc/|"${PREFIX}/etc/|g' ${WRKSRC}/${file}
+ 's|"/etc/|"${PREFIX}/etc/|g' ${WRKSRC}/${f}
.endfor
do-configure:
@@ -63,4 +57,4 @@ post-install:
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/gsi/files/patch-lib-gsif-sample_convert_block.c b/audio/gsi/files/patch-lib-gsif-sample_convert_block.c
new file mode 100644
index 000000000000..54b78b13e4cb
--- /dev/null
+++ b/audio/gsi/files/patch-lib-gsif-sample_convert_block.c
@@ -0,0 +1,44 @@
+--- lib/gsif/sample/convert_block.c.orig 2001-01-30 13:28:09.000000000 +0100
++++ lib/gsif/sample/convert_block.c 2007-12-06 17:04:45.000000000 +0100
+@@ -122,9 +122,9 @@
+ break;
+ case GSI_16BIT:
+ #ifdef SYSCONFIG_LITTLE_ENDIAN_MACHINE
+- input_val = (int) (int16) ( ((*input++) << 8) | (*input++) );
++ input_val = (int) (int16) ( (*input++ << 8) | *input++ );
+ #else
+- input_val = *((int16 *)input)++;
++ input_val = *input++;
+ #endif
+ break;
+ case GSI_8BIT_SIGNED:
+@@ -132,9 +132,9 @@
+ break;
+ case GSI_16BIT_LE:
+ #ifdef SYSCONFIG_LITTLE_ENDIAN_MACHINE
+- input_val = *((int16 *)input)++;
++ input_val = *input++;
+ #else
+- input_val = (int) (int16) (*input++ | ((*input++) << 8) );
++ input_val = (int) (int16) (*(input++) | ((*input++) << 8) );
+ #endif
+ break;
+ case GSI_24BIT:
+@@ -170,7 +170,7 @@
+ *output++ = (input_val >> 8) & 255;
+ *output++ = (input_val & 255);
+ #else
+- *((int16 *) output)++ = input_val;
++ *output++ = input_val;
+ #endif
+ break;
+ case GSI_8BIT_SIGNED:
+@@ -178,7 +178,7 @@
+ break;
+ case GSI_16BIT_LE:
+ #ifdef SYSCONFIG_LITTLE_ENDIAN_MACHINE
+- *((int16 *) output)++ = input_val;
++ *output++ = input_val;
+ #else
+ *output++ = (input_val >> 8) & 255;
+ *output++ = (input_val & 255);