aboutsummaryrefslogtreecommitdiff
path: root/audio/gtkpod/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-03-15 15:13:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-03-15 15:13:21 +0000
commit04c6e4614820c0415965b557b480b693167c9462 (patch)
tree389addbf25da76adee85a033879f0d7b53ad07f7 /audio/gtkpod/Makefile
parentefef80a00d7028a8d9641d1cf74ce67e30ed687c (diff)
downloadports-04c6e4614820c0415965b557b480b693167c9462.tar.gz
ports-04c6e4614820c0415965b557b480b693167c9462.zip
- Update to version 1.0.0
- Drop gratuitous run dependencies: they are only used in external auxiliary scripts and do not directly affect main program functionality. Users are advised to install them manually if they need them (lame, faad, etc.) - Now that configure script supports disabling of optional features, drop make(1)'s exists()-based heuristics to ensure no hidden dependencies are recorded; user's choice of OPTIONS should now match the reality - Remove now unsupported HAL and GNOME VFS2 options - Remove dependency on external AAC/MP4 library (mp4v2); gtkpod now tries to load it via dlopen(3) and if it fails, will dig for the atom props manually. It probably can be turned into rdep, but first I need to make sure our libmp4v2 ABI matches what gtkpod expects - Add LICENSE (GPLv2)
Notes
Notes: svn path=/head/; revision=270947
Diffstat (limited to 'audio/gtkpod/Makefile')
-rw-r--r--audio/gtkpod/Makefile71
1 files changed, 24 insertions, 47 deletions
diff --git a/audio/gtkpod/Makefile b/audio/gtkpod/Makefile
index e40d9e45d544..64a8889793fc 100644
--- a/audio/gtkpod/Makefile
+++ b/audio/gtkpod/Makefile
@@ -6,18 +6,17 @@
#
PORTNAME= gtkpod
-PORTVERSION= 0.99.14
-PORTREVISION= 7
+PORTVERSION= 1.0.0
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= danfe@FreeBSD.org
COMMENT= GUI for Apple iPod using GTK2
+LICENSE= GPLv2
+
LIB_DEPENDS= id3tag.0:${PORTSDIR}/audio/libid3tag \
- gpod.5:${PORTSDIR}/audio/libgpod
-RUN_DEPENDS= mp3gain:${PORTSDIR}/audio/mp3gain \
- iconv:${PORTSDIR}/converters/libiconv
+ gpod.7:${PORTSDIR}/audio/libgpod
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -25,65 +24,43 @@ USE_GNOME= gtk20 libglade2
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_ICONS= yes
-WANT_GNOME= yes
MAN1= gtkpod.1
-PORTDOCS= ChangeLog README TODOandBUGS.txt TROUBLESHOOTING
+PORTDOCS= ChangeLog NEWS README TODOandBUGS.txt TROUBLESHOOTING
-OPTIONS= MPEG4IP "Enable AAC and H.264 support with MPEG4IP" off \
- VORBIS "Enable Ogg/Vorbis support (decoding)" on \
- FLAC "Enable FLAC support (decoding)" on \
- LAME "Enable encoding to MP3 format" on \
- GNOMEVFS "Enable iPod autodetection support" off \
- HAL "Enable HAL support" off \
- CURL "Build with coverart download support" on
+OPTIONS= VORBIS "Enable Ogg/Vorbis support" on \
+ FLAC "Enable FLAC support" on \
+ CURL "Enable coverart download support" on
.include <bsd.port.pre.mk>
-.if defined(WITH_MPEG4IP) && !defined(WITHOUT_MPEG4IP)
-LIB_DEPENDS+= mp4v2.10:${PORTSDIR}/multimedia/mp4v2
-CONFIGURE_ARGS+= --with-mp4v2
-# Define HAVE_GTK to unbreak the build with libmp4v2.so (it is built
-# without Gtk support by default, which can result in gtkpod breakage)
-MAKE_ARGS+= CPPFLAGS="-DHAVE_GTK"
+.if defined(WITH_VORBIS)
+LIB_DEPENDS+= vorbisfile.6:${PORTSDIR}/audio/libvorbis
.else
-CONFIGURE_ARGS+= --without-mp4v2
-.endif
-.for x in faac faad
-. if exists(${LOCALBASE}/bin/${x})
-RUN_DEPENDS+= ${x}:${PORTSDIR}/audio/${x}
-. endif
-.endfor
-
-.if defined(WITH_VORBIS) || exists(${LOCALBASE}/lib/libvorbis.so)
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
-RUN_DEPENDS+= oggdec:${PORTSDIR}/audio/vorbis-tools
+CONFIGURE_ARGS+= --without-ogg
.endif
-.if defined(WITH_FLAC) || exists(${LOCALBASE}/lib/libFLAC.so)
+.if defined(WITH_FLAC)
LIB_DEPENDS+= FLAC.10:${PORTSDIR}/audio/flac
+.else
+CONFIGURE_ARGS+= --without-flac
.endif
-.if defined(WITH_LAME) || exists(${LOCALBASE}/bin/lame)
-RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
-.endif
-
-.if defined(WITH_GNOMEVFS) || ${HAVE_GNOME:Mgnomevfs2}
-USE_GNOME+= gnomevfs2
-.endif
-
-.if defined(WITH_HAL) || exists(${LOCALBASE}/lib/libhal.so)
-LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
-.endif
-
-.if defined(WITH_CURL) || exists(${LOCALBASE}/lib/libcurl.so)
+.if defined(WITH_CURL)
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+.else
+CONFIGURE_ARGS+= --without-curl
.endif
-pre-configure: .SILENT
+post-patch:
# Install locale files correctly (to share dir instead of lib dir)
- ${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' \
+ @${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' \
${WRKSRC}/configure
+# FreeBSD does not have libdl
+ @${REINPLACE_CMD} -e 's| -ldl||' ${WRKSRC}/src/Makefile.in
+# Adjust location of <endian.h> header
+ @${REINPLACE_CMD} -e 's|endian\.h|sys/&|' ${WRKSRC}/configure \
+ ${WRKSRC}/src/mp4file.c
post-install:
.if !defined(NOPORTDOCS)