aboutsummaryrefslogtreecommitdiff
path: root/audio/gtkpod/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-08-28 02:39:38 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-08-28 02:39:38 +0000
commit9ed27dded0771b57e68b5fc3b4f1d74f5ced629b (patch)
treef22e367579498b1cf0fbb91b148e32c44d5b43f6 /audio/gtkpod/Makefile
parentd5cdb69eb7a51b226689310f5424b195256e67e2 (diff)
downloadports-9ed27dded0771b57e68b5fc3b4f1d74f5ced629b.tar.gz
ports-9ed27dded0771b57e68b5fc3b4f1d74f5ced629b.zip
Unbreak the build with -fno-common (Clang 11, GCC 10).
Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=546699
Diffstat (limited to 'audio/gtkpod/Makefile')
-rw-r--r--audio/gtkpod/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/audio/gtkpod/Makefile b/audio/gtkpod/Makefile
index f4c672b73175..fb38f3e73636 100644
--- a/audio/gtkpod/Makefile
+++ b/audio/gtkpod/Makefile
@@ -51,6 +51,12 @@ post-patch:
# Fix location of the <endian.h> header
@${REINPLACE_CMD} -e 's|endian\.h|sys/&|' ${WRKSRC}/configure \
${WRKSRC}/src/mp4file.c
+# Fix the build with -fno-common (for Clang 11 and GCC 10)
+ @${REINPLACE_CMD} -e '/main_window_xml/s|^|extern |' \
+ ${WRKSRC}/src/display.h
+ @${REINPLACE_CMD} -e '51s|^|GladeXML *main_window_xml;|' \
+ ${WRKSRC}/src/display.c
+ @${REINPLACE_CMD} -e 's|} CONF_ID|}|' ${WRKSRC}/src/confirmation.h
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}