aboutsummaryrefslogtreecommitdiff
path: root/audio/gtkpod
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-21 10:14:47 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-01-21 10:14:47 +0000
commit9a92b2582278415a2a696e3fe0a7461e084daa8e (patch)
tree7958f4b47bcfc9efbda7e9ed26c3fa792e3cd9a4 /audio/gtkpod
parent27985fe3f2f58ace6d98db0b4cbe2d33dd539b25 (diff)
downloadports-9a92b2582278415a2a696e3fe0a7461e084daa8e.tar.gz
ports-9a92b2582278415a2a696e3fe0a7461e084daa8e.zip
Stagify, utilize OPTIONS helpers, reword comments slightly.
Notes
Notes: svn path=/head/; revision=340590
Diffstat (limited to 'audio/gtkpod')
-rw-r--r--audio/gtkpod/Makefile40
-rw-r--r--audio/gtkpod/pkg-plist1
2 files changed, 14 insertions, 27 deletions
diff --git a/audio/gtkpod/Makefile b/audio/gtkpod/Makefile
index 76ac125585fe..3df8c7203f50 100644
--- a/audio/gtkpod/Makefile
+++ b/audio/gtkpod/Makefile
@@ -16,14 +16,13 @@ LIB_DEPENDS= libid3tag.so:${PORTSDIR}/audio/libid3tag \
libgpod.so:${PORTSDIR}/audio/libgpod
USES= gettext gmake pkgconfig
-NO_STAGE= yes
USE_GNOME= gtk20 libglade2
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-INSTALLS_ICONS= yes
-MAN1= ${PORTNAME}.1
PORTDOCS= ChangeLog NEWS README TODOandBUGS.txt TROUBLESHOOTING
OPTIONS_DEFINE= VORBIS FLAC CURL
@@ -31,40 +30,27 @@ OPTIONS_DEFAULT= VORBIS FLAC CURL
CURL_DESC= Cover art download support via libcurl
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
-.else
-CONFIGURE_ARGS+= --without-ogg
-.endif
+VORBIS_LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
+VORBIS_CONFIGURE_OFF= --without-ogg
-.if ${PORT_OPTIONS:MFLAC}
-LIB_DEPENDS+= libFLAC.so:${PORTSDIR}/audio/flac
-.else
-CONFIGURE_ARGS+= --without-flac
-.endif
+FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
+FLAC_CONFIGURE_ARGS= --without-flac
-.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
-.else
-CONFIGURE_ARGS+= --without-curl
-.endif
+CURL_LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+CURL_CONFIGURE_ARGS= --without-curl
post-patch:
# Install locale files correctly (to share dir instead of lib dir)
@${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' \
${WRKSRC}/configure
-# FreeBSD does not have libdl
+# FreeBSD does not have separate libdl.so
@${REINPLACE_CMD} -e 's| -ldl||' ${WRKSRC}/src/Makefile.in
-# Adjust location of <endian.h> header
+# Fix location of the <endian.h> header
@${REINPLACE_CMD} -e 's|endian\.h|sys/&|' ${WRKSRC}/configure \
${WRKSRC}/src/mp4file.c
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/gtkpod/pkg-plist b/audio/gtkpod/pkg-plist
index 135becf58983..d6cad710df76 100644
--- a/audio/gtkpod/pkg-plist
+++ b/audio/gtkpod/pkg-plist
@@ -1,4 +1,5 @@
bin/gtkpod
+man/man1/gtkpod.1.gz
%%DATADIR%%/data/default-cover.png
%%DATADIR%%/data/gtkpod-add-dirs.png
%%DATADIR%%/data/gtkpod-add-files.png