aboutsummaryrefslogtreecommitdiff
path: root/audio/headsetcontrol
diff options
context:
space:
mode:
authorHans Petter Selasky <hselasky@FreeBSD.org>2021-11-13 12:36:32 +0000
committerHans Petter Selasky <hselasky@FreeBSD.org>2021-11-13 12:37:11 +0000
commite201631cf3368c4ecf6359719689107c7e908633 (patch)
tree62d432f62b175a65488214e38d5ac86fb16838ab /audio/headsetcontrol
parentb07ef27e5ce8c2028f9e017db292944d0b9c3dc3 (diff)
downloadports-e201631cf3368c4ecf6359719689107c7e908633.tar.gz
ports-e201631cf3368c4ecf6359719689107c7e908633.zip
audio/headsetcontrol: Update to 2.6
PR: 259815 Approved by: pi (implicit) and maintainer
Diffstat (limited to 'audio/headsetcontrol')
-rw-r--r--audio/headsetcontrol/Makefile2
-rw-r--r--audio/headsetcontrol/distinfo6
-rw-r--r--audio/headsetcontrol/files/patch-CMakeLists.txt32
3 files changed, 19 insertions, 21 deletions
diff --git a/audio/headsetcontrol/Makefile b/audio/headsetcontrol/Makefile
index beba1e26de23..8425cff96f5e 100644
--- a/audio/headsetcontrol/Makefile
+++ b/audio/headsetcontrol/Makefile
@@ -1,7 +1,7 @@
# Created by: Alexander Vereeken <Alexander88207@protonmail.com>
PORTNAME= headsetcontrol
-PORTVERSION= 2.4
+PORTVERSION= 2.6
CATEGORIES= audio
MAINTAINER= Alexander88207@protonmail.com
diff --git a/audio/headsetcontrol/distinfo b/audio/headsetcontrol/distinfo
index 56fe1e059248..c1e3bec6b60d 100644
--- a/audio/headsetcontrol/distinfo
+++ b/audio/headsetcontrol/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1621151184
-SHA256 (Sapd-HeadsetControl-2.4_GH0.tar.gz) = 1978dd8939da3c846457040416eda1896f3f0aea7eb9b4d74efac30ed5c0cacb
-SIZE (Sapd-HeadsetControl-2.4_GH0.tar.gz) = 33648
+TIMESTAMP = 1636804595
+SHA256 (Sapd-HeadsetControl-2.6_GH0.tar.gz) = 4f785af09cbf3dffe7050029f310b77943d68612a4e7544118cddb8f682eadc6
+SIZE (Sapd-HeadsetControl-2.6_GH0.tar.gz) = 39694
diff --git a/audio/headsetcontrol/files/patch-CMakeLists.txt b/audio/headsetcontrol/files/patch-CMakeLists.txt
index 16b6491898a3..c8f2cdeba868 100644
--- a/audio/headsetcontrol/files/patch-CMakeLists.txt
+++ b/audio/headsetcontrol/files/patch-CMakeLists.txt
@@ -1,26 +1,24 @@
---- CMakeLists.txt.orig 2021-05-13 11:07:31 UTC
+--- CMakeLists.txt.orig 2021-11-13 11:33:58 UTC
+++ CMakeLists.txt
-@@ -112,23 +112,6 @@ add_executable(headsetcontrol ${SOURCE_FILES})
- target_link_libraries(headsetcontrol m ${HIDAPI_LIBRARIES})
+@@ -118,21 +118,6 @@ target_link_libraries(headsetcontrol m ${HIDAPI_LIBRAR
install(TARGETS headsetcontrol DESTINATION bin)
--
+
-# install udev files on linux
-if(UNIX AND NOT APPLE)
-- set (program_cmd headsetcontrol)
-- set (program_arg "-u")
-- set (program_output "/etc/udev/rules.d/70-headsets.rules")
-- install( CODE
-- "
-- execute_process(COMMAND ${program_cmd} ${program_arg}
-- OUTPUT_FILE ${program_output})
--
-- message(STATUS \"Installed udev rules to ${program_output}\")
-- "
-- )
+- set(rules_file 70-headsets.rules)
+- set(udev_rules_dir lib/udev/rules.d/
+- CACHE PATH "Path to the directory where udev rules should be installed")
+- add_custom_command(
+- OUTPUT ${rules_file}
+- COMMAND headsetcontrol -u > ${rules_file}
+- DEPENDS headsetcontrol)
+- add_custom_target(udevrules ALL DEPENDS ${rules_file})
+- install(
+- FILES ${CMAKE_CURRENT_BINARY_DIR}/${rules_file}
+- DESTINATION ${udev_rules_dir})
-endif()
-
--
+
# ------------------------------------------------------------------------------
# Testing
- # ------------------------------------------------------------------------------