aboutsummaryrefslogtreecommitdiff
path: root/audio/hexter/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2013-11-08 00:50:32 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2013-11-08 00:50:32 +0000
commitfc1061a7b7db5326939c4e47689578a30646259d (patch)
tree403a804aa52045415c0cce0e075c03802f88294a /audio/hexter/Makefile
parent1ba17a9e0e6e49498a1b8742388456fed0d7bbc8 (diff)
downloadports-fc1061a7b7db5326939c4e47689578a30646259d.tar.gz
ports-fc1061a7b7db5326939c4e47689578a30646259d.zip
- Change maintainer email to @FreeBSD.org
- Use the new format for LIB_DEPENDS - Support STAGEDIR - Add DOCS Option Approved by: pawel / wg (mentors, implicit)
Notes
Notes: svn path=/head/; revision=333167
Diffstat (limited to 'audio/hexter/Makefile')
-rw-r--r--audio/hexter/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/audio/hexter/Makefile b/audio/hexter/Makefile
index 3e301de1bcf9..f0dbc66878ed 100644
--- a/audio/hexter/Makefile
+++ b/audio/hexter/Makefile
@@ -7,29 +7,26 @@ PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/dssi/${PORTNAME}/${PORTVERSION}
-MAINTAINER= nemysis@gmx.ch
+MAINTAINER= nemysis@FreeBSD.org
COMMENT= DSSI softsynth that models the sound generation of a Yamaha DX7
LICENSE= GPLv2
-LIB_DEPENDS= dssialsacompat:${PORTSDIR}/audio/libdssialsacompat \
- lo:${PORTSDIR}/audio/liblo \
- jack:${PORTSDIR}/audio/jack
+LIB_DEPENDS= libdssialsacompat.so:${PORTSDIR}/audio/libdssialsacompat \
+ liblo.so:${PORTSDIR}/audio/liblo \
+ libjack.so:${PORTSDIR}/audio/jack
BUILD_DEPENDS= ${LOCALBASE}/include/dssi.h:${PORTSDIR}/audio/dssi
-GNU_CONFIGURE= yes
USES= gmake pkgconfig
-NO_STAGE= yes
+GNU_CONFIGURE= yes
USE_GNOME= gtk20
PORTDOCS= AUTHORS ChangeLog README TODO
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>