aboutsummaryrefslogtreecommitdiff
path: root/audio/hydrogen/Makefile
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-10-22 07:46:16 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-10-22 07:46:20 +0000
commit7a20f9d5b476ca2cb41f79f34f5de6fe86f15995 (patch)
treeb688bebda07b56bf790e3450e941350623ec2157 /audio/hydrogen/Makefile
parentb5a3895ad28278663f063604fa5c58eff9af7173 (diff)
downloadports-7a20f9d5b476ca2cb41f79f34f5de6fe86f15995.tar.gz
ports-7a20f9d5b476ca2cb41f79f34f5de6fe86f15995.zip
audio/hydrogen: Use upstream release archive
- Use upstream release archive as recommended by Porters Handbook (USE_GITHUB section) - Update compiler requirements to c++17-lang - Adjust manpage install dir PR: 267186 Reviewed by: Shane <FreeBSD@ShaneWare.Biz> (maintainer)
Diffstat (limited to 'audio/hydrogen/Makefile')
-rw-r--r--audio/hydrogen/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/audio/hydrogen/Makefile b/audio/hydrogen/Makefile
index cc261cbdc3eb..3229bcf77789 100644
--- a/audio/hydrogen/Makefile
+++ b/audio/hydrogen/Makefile
@@ -1,6 +1,8 @@
PORTNAME= hydrogen
DISTVERSION= 1.1.1
CATEGORIES= audio
+MASTER_SITES= https://github.com/hydrogen-music/${PORTNAME}/releases/download/${DISTVERSION}/ \
+ SF/hydrogen/Hydrogen/${DISTVERSION}%20Sources/
MAINTAINER= FreeBSD@ShaneWare.Biz
COMMENT= Advanced drum machine
@@ -12,15 +14,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libsndfile.so:audio/libsndfile \
liblo.so:audio/liblo
-USES= cmake compiler:c++11-lang desktop-file-utils pkgconfig \
+USES= cmake compiler:c++17-lang desktop-file-utils pkgconfig \
localbase qt:5
USE_QT= core gui network widgets xml xmlpatterns buildtools:build \
linguisttools:build qmake:build testlib:build
USE_LDCONFIG= yes
-CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR=${LOCALBASE}/share/man
-USE_GITHUB= yes
-GH_ACCOUNT= hydrogen-music
+CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=${LOCALBASE}/man
OPTIONS_SINGLE= EXPORT
OPTIONS_SINGLE_EXPORT= LIBARCHIVE LIBTAR