aboutsummaryrefslogtreecommitdiff
path: root/audio/id3mtag
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-03 13:25:04 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-03 13:25:04 +0000
commit95f1dbb4c5b5c705854f648552f8a2f941d8237d (patch)
tree7706f7eaec46cced9aeff9362dbcc52a5d8f192f /audio/id3mtag
parentf8bf0f0520e9a7a1ef95873a7bee418e6a09fcfe (diff)
downloadports-95f1dbb4c5b5c705854f648552f8a2f941d8237d.tar.gz
ports-95f1dbb4c5b5c705854f648552f8a2f941d8237d.zip
New port
Port of id3 mass tagger, a tool for manipulating id3 and id3v2 tags in multiple files. It can generate tag fields from the filename and other variables, and/or rename files, using an intuitive syntax. PR: 84462 Submitted by: Marc Schoolderman <squell@alumina.nl> Approved by: pav (mentor)
Notes
Notes: svn path=/head/; revision=144058
Diffstat (limited to 'audio/id3mtag')
-rw-r--r--audio/id3mtag/Makefile38
-rw-r--r--audio/id3mtag/distinfo2
-rw-r--r--audio/id3mtag/pkg-descr6
3 files changed, 46 insertions, 0 deletions
diff --git a/audio/id3mtag/Makefile b/audio/id3mtag/Makefile
new file mode 100644
index 000000000000..c64918af25de
--- /dev/null
+++ b/audio/id3mtag/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: id3mtag
+# Date created: 9 February 2005
+# Whom: squell@alumina.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= id3mtag
+PORTVERSION= 0.76
+CATEGORIES= audio
+MASTER_SITES= http://home.wanadoo.nl/squell/files/
+DISTNAME= id3-${PORTVERSION}
+
+MAINTAINER= squell@alumina.nl
+COMMENT= Mass tagging utility for audio files
+
+MAN1= id3.1
+PLIST_FILES= bin/id3
+
+MAKEFILE= makefile
+ALL_TARGET= build
+MAKE_ARGS= CC=${CC} CFLAGS="${CFLAGS}" \
+ CXX=${CXX} CXXFLAGS="${CXXFLAGS}"
+
+PORTDOCS= *
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/id3 ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/id3.man ${MANPREFIX}/man/man1/id3.1
+. if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/CHANGES ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}
+. endif
+
+.include <bsd.port.mk>
diff --git a/audio/id3mtag/distinfo b/audio/id3mtag/distinfo
new file mode 100644
index 000000000000..23bb5e52c6fc
--- /dev/null
+++ b/audio/id3mtag/distinfo
@@ -0,0 +1,2 @@
+MD5 (id3-0.76.tar.gz) = c0174e5d2c26dc4f4c9a4c1f79639a3e
+SIZE (id3-0.76.tar.gz) = 50366
diff --git a/audio/id3mtag/pkg-descr b/audio/id3mtag/pkg-descr
new file mode 100644
index 000000000000..f90b31d48c3f
--- /dev/null
+++ b/audio/id3mtag/pkg-descr
@@ -0,0 +1,6 @@
+Port of id3 mass tagger, a tool for manipulating id3 and id3v2 tags in
+multiple files. It can generate tag fields from the filename and other
+variables, and/or rename files, using an intuitive syntax.
+
+WWW: http://home.wanadoo.nl/squell/id3.html
+Author: squell <squell@alumina.nl>