aboutsummaryrefslogtreecommitdiff
path: root/audio/id3ren/files
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-01-15 14:22:31 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-01-15 14:22:31 +0000
commit386ea862c8981feea63ee94c6ce7e8e9857728a3 (patch)
treea2203fe28ddb0a778f19ec039e444bd08559bee8 /audio/id3ren/files
parent6419e3f061c8842c6e0e838decad81d61d2fbc14 (diff)
downloadports-386ea862c8981feea63ee94c6ce7e8e9857728a3.tar.gz
ports-386ea862c8981feea63ee94c6ce7e8e9857728a3.zip
Update id3ren to 1.1b0, which adds the all-important %n 'Track name'
template identifier. Also, take over maintainership and install a manual page and some more documentation. Approved by: Joao Carlos Mendes Luis <jonny@jonny.eng.br> (former maintainer)
Notes
Notes: svn path=/head/; revision=126504
Diffstat (limited to 'audio/id3ren/files')
-rw-r--r--audio/id3ren/files/patch-Makefile18
-rw-r--r--audio/id3ren/files/patch-aa39
-rw-r--r--audio/id3ren/files/patch-ab20
-rw-r--r--audio/id3ren/files/patch-man::Makefile12
4 files changed, 60 insertions, 29 deletions
diff --git a/audio/id3ren/files/patch-Makefile b/audio/id3ren/files/patch-Makefile
new file mode 100644
index 000000000000..951d41b7ace6
--- /dev/null
+++ b/audio/id3ren/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig Tue Mar 6 02:59:34 2001
++++ Makefile Fri Jan 7 09:56:53 2005
+@@ -1,12 +1,12 @@
+ all:
+- make -C src all
++ cd src && ${MAKE} all
+
+ debug:
+ make -C src debug
+
+ install:
+- make -C src install
+- make -C man install
++ cd src && ${MAKE} install
++ cd man && ${MAKE} install
+
+ clean:
+ make -C src clean
diff --git a/audio/id3ren/files/patch-aa b/audio/id3ren/files/patch-aa
index 951974bdf03d..759ef05df597 100644
--- a/audio/id3ren/files/patch-aa
+++ b/audio/id3ren/files/patch-aa
@@ -1,26 +1,27 @@
---- Makefile.old Wed Mar 18 04:28:44 1998
-+++ Makefile Sun Feb 28 16:04:16 1999
-@@ -1,16 +1,17 @@
--CFLAGS = -O2 -s -Wall
-+CFLAGS += -s -Wall
+--- src/Makefile.orig Fri Jan 7 10:08:02 2005
++++ src/Makefile Fri Jan 7 10:08:30 2005
+@@ -1,9 +1,10 @@
+ CFLAGSDEBUG = -g -O2 -Wall -DDEBUG
+-CFLAGS = -s -O2 -Wall
-CC = gcc
- RM = rm -f
+-RM = rm -f
-INSTALL = install -s -m 755
--INSTALL_DIR = ..
-+INSTALL = install -cs -m 755 -o root -g wheel
+-INSTALL_DIR = /usr/bin
++CFLAGS ?= -O2 -Wall
++STRIP ?= -s
++CC ?= gcc
++RM ?= rm -f
++INSTALL = ${BSD_INSTALL_PROGRAM}
+INSTALL_DIR = ${PREFIX}/bin
INSTALL_NAME = id3ren
- SOURCES = id3ren.c id3tag.c file.c misc.c
+ SOURCES = id3ren.c id3tag.c id3file.c id3misc.c
+@@ -12,7 +13,7 @@
+ all: ${INSTALL_NAME}
--all:
-+all: ${INSTALL_NAME}
-+
-+${INSTALL_NAME}:
- ${CC} ${CFLAGS} -o ${INSTALL_NAME} ${SOURCES}
+ ${INSTALL_NAME}: ${SOURCES} ${INCLUDES}
+- ${CC} ${CFLAGS} -o ${INSTALL_NAME} ${SOURCES}
++ ${CC} ${CFLAGS} ${STRIP} -o ${INSTALL_NAME} ${SOURCES}
--install: all
-+install: ${INSTALL_NAME}
- ${INSTALL} ${INSTALL_NAME} ${INSTALL_DIR}/${INSTALL_NAME}
-
- clean:
+ debug:
+ ${CC} ${CFLAGSDEBUG} -o ${INSTALL_NAME} ${SOURCES}
diff --git a/audio/id3ren/files/patch-ab b/audio/id3ren/files/patch-ab
index 5cdd47156820..961ae28dbda6 100644
--- a/audio/id3ren/files/patch-ab
+++ b/audio/id3ren/files/patch-ab
@@ -1,10 +1,10 @@
---- id3tag.c.orig Wed Mar 18 17:18:34 1998
-+++ id3tag.c Sun Dec 26 15:11:42 1999
-@@ -365,6 +365,7 @@
- return TRUE;
- }
-
-+ memset(string, 0, size);
- fgets(string, size, stdin);
-
- if (string[strlen(string)-1] == '\n')
+--- src/id3tag.c.orig Fri Jan 7 09:32:59 2005
++++ src/id3tag.c Fri Jan 7 09:33:14 2005
+@@ -369,6 +369,7 @@
+ return TRUE;
+ }
+
++ memset(string, 0, size);
+ fgets(string, size, stdin);
+
+ if (string[strlen(string)-1] == '\n')
diff --git a/audio/id3ren/files/patch-man::Makefile b/audio/id3ren/files/patch-man::Makefile
new file mode 100644
index 000000000000..bb347724c046
--- /dev/null
+++ b/audio/id3ren/files/patch-man::Makefile
@@ -0,0 +1,12 @@
+--- man/Makefile.orig Fri Jan 7 09:53:38 2005
++++ man/Makefile Fri Jan 7 09:53:54 2005
+@@ -1,6 +1,6 @@
+-RM = rm -f
+-INSTALL = install -m 755
+-INSTALL_DIR = /usr/man/man1
++RM ?= rm -f
++INSTALL = ${BSD_INSTALL_PROGRAM}
++INSTALL_DIR = ${PREFIX}/man/man1
+ INSTALL_NAME = id3ren.1.gz
+
+ all: