aboutsummaryrefslogtreecommitdiff
path: root/audio/jack-keyboard/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-06-23 12:14:17 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-06-23 12:14:17 +0000
commit1627fe7c3bb2b236420ee34bc0638df46ad8cf1d (patch)
tree6381a7e5810f9684397ae6d6b82e30b26c9544dd /audio/jack-keyboard/Makefile
parentd3664668491e41b84b42a0f57eb1ed45a7647f1e (diff)
downloadports-1627fe7c3bb2b236420ee34bc0638df46ad8cf1d.tar.gz
ports-1627fe7c3bb2b236420ee34bc0638df46ad8cf1d.zip
Update to 2.6.
Submitted by: kselasky@ Approved by: trasz@
Notes
Notes: svn path=/head/; revision=276122
Diffstat (limited to 'audio/jack-keyboard/Makefile')
-rw-r--r--audio/jack-keyboard/Makefile26
1 files changed, 20 insertions, 6 deletions
diff --git a/audio/jack-keyboard/Makefile b/audio/jack-keyboard/Makefile
index 33069219fff3..53bf45425d3c 100644
--- a/audio/jack-keyboard/Makefile
+++ b/audio/jack-keyboard/Makefile
@@ -6,21 +6,35 @@
#
PORTNAME= jack-keyboard
-DISTVERSION= 2.5
-PORTREVISION= 4
+DISTVERSION= 2.6
CATEGORIES= audio
-MASTER_SITES= SF
+MASTER_SITES= SF \
+ http://hselasky.homeunix.org:8192/distfiles/
MAINTAINER= trasz@FreeBSD.org
COMMENT= Virtual keyboard for JACK MIDI
-LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
- lash.2:${PORTSDIR}/audio/lash
+LICENSE= BSD
+
+LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack
MAN1= jack-keyboard.1
-GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+USE_GZIP= yes
USE_GNOME= gtk20
+USE_CMAKE= yes
INSTALLS_ICONS= yes
+OPTIONS= LASH "Build with lash support" on
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_LASH)
+LIB_DEPENDS+= lash.2:${PORTSDIR}/audio/lash
+CMAKE_ARGS+= -DLashEnable:BOOL=On
+.else
+CMAKE_ARGS+= -DLashEnable:BOOL=Off
+.endif
+
.include <bsd.port.mk>