aboutsummaryrefslogtreecommitdiff
path: root/audio/jacktrip/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-08-31 03:30:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-08-31 03:31:41 +0000
commitac258c95ec6eb1a6d57ac5eaafd3029949853da6 (patch)
tree040ae2f9b46df5f72a81ddd034445d2c51035dea /audio/jacktrip/Makefile
parent9263318fd2cce6e185f721d0e1f50c2818ada19f (diff)
downloadports-ac258c95ec6eb1a6d57ac5eaafd3029949853da6.tar.gz
ports-ac258c95ec6eb1a6d57ac5eaafd3029949853da6.zip
audio/jacktrip: update 2.0.0-beta1 → 2.0.0
Reported by: portscout
Diffstat (limited to 'audio/jacktrip/Makefile')
-rw-r--r--audio/jacktrip/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/audio/jacktrip/Makefile b/audio/jacktrip/Makefile
index 5c5d09603eab..f9e1ba41110c 100644
--- a/audio/jacktrip/Makefile
+++ b/audio/jacktrip/Makefile
@@ -1,7 +1,6 @@
PORTNAME= jacktrip
DISTVERSIONPREFIX= v
-DISTVERSION= 2.0.0-beta1
-PORTREVISION= 2
+DISTVERSION= 2.0.0
CATEGORIES= audio
MAINTAINER= yuri@FreeBSD.org
@@ -16,14 +15,13 @@ LIB_DEPENDS= libjack.so:audio/jack \
librtaudio.so:audio/rtaudio
USES= meson compiler:c++17-lang gl pkgconfig qt:6
-USE_QT= base declarative svg webengine websockets
+USE_QT= base declarative svg webchannel webengine websockets
USE_GL= gl
USE_GITHUB= yes
GH_TUPLE= jacktrip:Simple-FFT:06f237780364879337750d1ac9f3b000b4b7a160:jacktrip_Simple_FFT/externals/Simple-FFT \
x42:weakjack:cddbeec0953d68048d164c472c9b30a5d96778db:x42_weakjack/externals/weakjack
-
#CXXFLAGS+= `pkg-config --cflags rtaudio`
#LDFLAGS+= `pkg-config --libs rtaudio`
@@ -31,4 +29,6 @@ QMAKE_SOURCE_PATH= ${PORTNAME}.pro
PLIST_FILES= bin/${PORTNAME}
+BINARY_ALIAS= git=false
+
.include <bsd.port.mk>