aboutsummaryrefslogtreecommitdiff
path: root/audio/kaudiocreator
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-01-12 20:51:06 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-01-12 20:51:06 +0000
commit65b5d20c8fee2aa7bfe81a0cfb680802b5f9ea85 (patch)
treeaa3ccd7b3dbf933488c8f69d3ff2f62ec932e02e /audio/kaudiocreator
parent2e458a6e729ad7565da75086078479262a5c652f (diff)
downloadports-65b5d20c8fee2aa7bfe81a0cfb680802b5f9ea85.tar.gz
ports-65b5d20c8fee2aa7bfe81a0cfb680802b5f9ea85.zip
Add new port audio/kaudiocreator:
KAudioCreator is an audio CD ripper, which uses cdparanoia as a backend to extract the tracks and later it encodes them to mp3 or ogg files (or many other formats supported). WWW: http://www.kde.org/applications/multimedia/kaudiocreator/ PR: ports/153621 Submitted by: David Naylor <naylor.b.david at gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=267714
Diffstat (limited to 'audio/kaudiocreator')
-rw-r--r--audio/kaudiocreator/Makefile36
-rw-r--r--audio/kaudiocreator/distinfo2
-rw-r--r--audio/kaudiocreator/pkg-descr10
-rw-r--r--audio/kaudiocreator/pkg-plist13
4 files changed, 61 insertions, 0 deletions
diff --git a/audio/kaudiocreator/Makefile b/audio/kaudiocreator/Makefile
new file mode 100644
index 000000000000..df3e6d19e614
--- /dev/null
+++ b/audio/kaudiocreator/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: kaudiocreator
+# Date created: 2011/01/01
+# Whom: David Naylor <naylor.b.david@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= kaudiocreator
+PORTVERSION= 1.2.90
+CATEGORIES= audio kde
+MASTER_SITES= http://kde-look.org/CONTENT/content-files/
+DISTNAME= 107645-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= naylor.b.david@gmail.com
+COMMENT= An audio-cd ripper and encoder for KDE4
+
+LIB_DEPENDS= discid:${PORTSDIR}/audio/libdiscid \
+ tag:${PORTSDIR}/audio/taglib \
+ kcddb:${PORTSDIR}/multimedia/kdemultimedia4
+RUN_DEPENDS= flac:${PORTSDIR}/audio/flac \
+ oggenc:${PORTSDIR}/audio/vorbis-tools
+.if !defined(PACKAGE_BUILDING)
+RUN_DEPENDS+= lame:${PORTSDIR}/audio/lame
+.endif
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build rcc_build uic_build
+USE_KDE4= automoc4 kdehier kdeprefix
+
+LICENSE= GPLv2
+MAKE_JOBS_SAFE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/audio/kaudiocreator/distinfo b/audio/kaudiocreator/distinfo
new file mode 100644
index 000000000000..4bad860a75d8
--- /dev/null
+++ b/audio/kaudiocreator/distinfo
@@ -0,0 +1,2 @@
+SHA256 (107645-kaudiocreator-1.2.90.tar.bz2) = 140953cf31bff7e8e27937ae5a4f42934a4552c09d45a6a8bbd35323f6e71953
+SIZE (107645-kaudiocreator-1.2.90.tar.bz2) = 62888
diff --git a/audio/kaudiocreator/pkg-descr b/audio/kaudiocreator/pkg-descr
new file mode 100644
index 000000000000..426ed3dabe83
--- /dev/null
+++ b/audio/kaudiocreator/pkg-descr
@@ -0,0 +1,10 @@
+KAudioCreator is an audio CD ripper, which uses cdparanoia as a
+backend to extract the tracks and later it encodes them to mp3 or
+ogg files (or many other formats supported).
+
+Features:
+ - CDDB lookup to extract the album and track information
+ - Different encoding formats supported (ogg, mp3, flac)
+ - Different filename formats using tags
+
+WWW: http://www.kde.org/applications/multimedia/kaudiocreator/
diff --git a/audio/kaudiocreator/pkg-plist b/audio/kaudiocreator/pkg-plist
new file mode 100644
index 000000000000..4d23266ff34e
--- /dev/null
+++ b/audio/kaudiocreator/pkg-plist
@@ -0,0 +1,13 @@
+bin/kaudiocreator
+share/applications/kde4/kaudiocreator.desktop
+share/apps/kaudiocreator/kaudiocreator.notifyrc
+share/apps/kaudiocreator/kaudiocreatorui.rc
+share/apps/kconf_update/kaudiocreator-libkcddb.upd
+share/apps/kconf_update/kaudiocreator-meta.upd
+share/apps/kconf_update/upgrade-kaudiocreator-metadata.sh
+share/config.kcfg/kaudiocreator.kcfg
+share/config.kcfg/kaudiocreator_encoders.kcfg
+share/icons/hicolor/16x16/apps/kaudiocreator.png
+share/icons/hicolor/32x32/apps/kaudiocreator.png
+share/kde4/services/ServiceMenus/audiocd_extract.desktop
+@dirrm share/apps/kaudiocreator