aboutsummaryrefslogtreecommitdiff
path: root/audio/ksmp3play
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-18 10:14:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-18 10:14:12 +0000
commitefbbb0e6651ef77e7d8dfe4fd681311b9a9fe076 (patch)
tree045f138166ebac507b1d2f254f652b61831837c1 /audio/ksmp3play
parent6f1b2777afce5f2087ebd8669f9ca2dc74272029 (diff)
downloadports-efbbb0e6651ef77e7d8dfe4fd681311b9a9fe076.tar.gz
ports-efbbb0e6651ef77e7d8dfe4fd681311b9a9fe076.zip
- Add LICENSE
- Switch to options helpers - Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=401855
Diffstat (limited to 'audio/ksmp3play')
-rw-r--r--audio/ksmp3play/Makefile5
-rw-r--r--audio/ksmp3play/files/patch-configure6
-rw-r--r--audio/ksmp3play/files/patch-ksmp3play.c6
-rw-r--r--audio/ksmp3play/files/patch-ksmp3play.h6
-rw-r--r--audio/ksmp3play/files/patch-windows.c6
5 files changed, 16 insertions, 13 deletions
diff --git a/audio/ksmp3play/Makefile b/audio/ksmp3play/Makefile
index 760d61dc561b..4b858c9587e3 100644
--- a/audio/ksmp3play/Makefile
+++ b/audio/ksmp3play/Makefile
@@ -10,6 +10,9 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTVERSION:R}
MAINTAINER= ports@FreeBSD.org
COMMENT= Curses-based MP3 player
+LICENSE= GPLv2 # or later
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libsmpeg.so:${PORTSDIR}/multimedia/smpeg
GNU_CONFIGURE= yes
@@ -23,7 +26,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
diff --git a/audio/ksmp3play/files/patch-configure b/audio/ksmp3play/files/patch-configure
index 71557bb669d4..a14ac99671c6 100644
--- a/audio/ksmp3play/files/patch-configure
+++ b/audio/ksmp3play/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Mon Aug 20 04:22:22 2001
-+++ configure Thu Oct 23 12:10:52 2003
-@@ -1258,15 +1258,15 @@
+--- configure.orig 2008-06-15 10:23:18 UTC
++++ configure
+@@ -1258,15 +1258,15 @@ int main (int argc, char *argv[])
}
else
{
diff --git a/audio/ksmp3play/files/patch-ksmp3play.c b/audio/ksmp3play/files/patch-ksmp3play.c
index 0f7efd9da3a4..7e0d7ec4bcbf 100644
--- a/audio/ksmp3play/files/patch-ksmp3play.c
+++ b/audio/ksmp3play/files/patch-ksmp3play.c
@@ -1,6 +1,6 @@
---- ksmp3play.c.orig Mon Aug 20 04:43:37 2001
-+++ ksmp3play.c Sun Dec 29 11:01:56 2002
-@@ -22,6 +22,7 @@
+--- ksmp3play.c.orig 2008-06-17 05:57:56 UTC
++++ ksmp3play.c
+@@ -42,6 +42,7 @@
#include "ksmp3play.h"
#include <smpeg/smpeg.h>
#include <curses.h>
diff --git a/audio/ksmp3play/files/patch-ksmp3play.h b/audio/ksmp3play/files/patch-ksmp3play.h
index f66e30496479..b7717bc71fbe 100644
--- a/audio/ksmp3play/files/patch-ksmp3play.h
+++ b/audio/ksmp3play/files/patch-ksmp3play.h
@@ -1,5 +1,5 @@
---- ksmp3play.h.orig Sun Nov 4 20:25:57 2001
-+++ ksmp3play.h Sun Nov 4 20:26:42 2001
+--- ksmp3play.h.orig 2008-04-14 00:22:27 UTC
++++ ksmp3play.h
@@ -29,8 +29,9 @@
#include <errno.h>
#include <time.h>
@@ -11,7 +11,7 @@
#else
struct option
{
-@@ -43,6 +44,7 @@
+@@ -43,6 +44,7 @@ struct option
# define required_argument 1
# define optional_argument 2
#endif
diff --git a/audio/ksmp3play/files/patch-windows.c b/audio/ksmp3play/files/patch-windows.c
index 6a89ca129d13..4a9b59f197af 100644
--- a/audio/ksmp3play/files/patch-windows.c
+++ b/audio/ksmp3play/files/patch-windows.c
@@ -1,6 +1,6 @@
---- windows.c.orig Mon Aug 20 02:43:24 2001
-+++ windows.c Sun Dec 29 12:45:25 2002
-@@ -22,7 +22,7 @@
+--- windows.c.orig 2008-06-17 05:57:56 UTC
++++ windows.c
+@@ -30,7 +30,7 @@
#include "ksmp3play.h"
#include <sys/types.h>