aboutsummaryrefslogtreecommitdiff
path: root/audio/libcanberra
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-08-10 19:24:30 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-08-10 19:24:30 +0000
commit7ebb5510d782b501f7e18849e0c98ccfdead0b77 (patch)
tree9e5773737a88a6350d44ac88b9e9a64a7a463292 /audio/libcanberra
parent25de6012539804e428400e332f6b6fbf28bdc5f4 (diff)
downloadports-7ebb5510d782b501f7e18849e0c98ccfdead0b77.tar.gz
ports-7ebb5510d782b501f7e18849e0c98ccfdead0b77.zip
Don't use included libltdl.
Notes
Notes: svn path=/head/; revision=218353
Diffstat (limited to 'audio/libcanberra')
-rw-r--r--audio/libcanberra/Makefile4
-rw-r--r--audio/libcanberra/files/patch-Makefile.in11
-rw-r--r--audio/libcanberra/files/patch-configure417
3 files changed, 302 insertions, 130 deletions
diff --git a/audio/libcanberra/Makefile b/audio/libcanberra/Makefile
index 2100caaafe80..4b27cafe4c83 100644
--- a/audio/libcanberra/Makefile
+++ b/audio/libcanberra/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libcanberra
PORTVERSION= 0.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio devel
MASTER_SITES= http://0pointer.de/public/
@@ -19,7 +19,7 @@ LIB_DEPENDS= vorbisfile.5:${PORTSDIR}/audio/libvorbis
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gtk20 ltverhack
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15 libltdl:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/audio/libcanberra/files/patch-Makefile.in b/audio/libcanberra/files/patch-Makefile.in
new file mode 100644
index 000000000000..860803c710d8
--- /dev/null
+++ b/audio/libcanberra/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2008-08-10 15:20:38.000000000 -0400
++++ Makefile.in 2008-08-10 15:20:44.000000000 -0400
+@@ -248,7 +248,7 @@ top_build_prefix = @top_build_prefix@
+ top_builddir = @top_builddir@
+ top_srcdir = @top_srcdir@
+ EXTRA_DIST = bootstrap.sh autogen.sh LGPL README
+-SUBDIRS = src doc libltdl
++SUBDIRS = src doc
+ MAINTAINERCLEANFILES =
+ noinst_DATA =
+ pkgconfigdir = $(prefix)/libdata/pkgconfig
diff --git a/audio/libcanberra/files/patch-configure b/audio/libcanberra/files/patch-configure
index 130b110aced1..b6d61bca2e26 100644
--- a/audio/libcanberra/files/patch-configure
+++ b/audio/libcanberra/files/patch-configure
@@ -1,6 +1,22 @@
---- configure.orig 2008-08-09 15:27:31.000000000 -0400
-+++ configure 2008-08-09 15:28:04.000000000 -0400
-@@ -935,15 +935,19 @@ VORBIS_LIBS
+--- configure.orig 2008-08-10 15:18:38.000000000 -0400
++++ configure 2008-08-10 15:19:32.000000000 -0400
+@@ -791,7 +791,6 @@ ac_includes_default="\
+ # include <unistd.h>
+ #endif"
+
+-enable_option_checking=no
+ ac_subst_vars='SHELL
+ PATH_SEPARATOR
+ PACKAGE_NAME
+@@ -909,7 +908,6 @@ ac_ct_F77
+ LIBTOOL
+ LTDLINCL
+ LIBLTDL
+-subdirs
+ OS_IS_WIN32_TRUE
+ OS_IS_WIN32_FALSE
+ acx_pthread_config
+@@ -935,15 +933,19 @@ VORBIS_LIBS
HAVE_DSO
HAVE_PULSE
HAVE_ALSA
@@ -20,7 +36,7 @@
HAVE_NULL_TRUE
HAVE_NULL_FALSE
BUILTIN_DSO_TRUE
-@@ -952,6 +956,8 @@ BUILTIN_PULSE_TRUE
+@@ -952,6 +954,8 @@ BUILTIN_PULSE_TRUE
BUILTIN_PULSE_FALSE
BUILTIN_ALSA_TRUE
BUILTIN_ALSA_FALSE
@@ -29,7 +45,7 @@
BUILTIN_NULL_TRUE
BUILTIN_NULL_FALSE
HTML_DIR
-@@ -978,6 +984,7 @@ enable_largefile
+@@ -978,6 +982,7 @@ enable_largefile
enable_rpath
with_libiconv_prefix
enable_alsa
@@ -37,7 +53,16 @@
enable_pulse
enable_null
enable_gtk
-@@ -1650,6 +1657,7 @@ Optional Features:
+@@ -1009,7 +1014,7 @@ GTK_CFLAGS
+ GTK_LIBS
+ VORBIS_CFLAGS
+ VORBIS_LIBS'
+-ac_subdirs_all='libltdl'
++
+
+ # Initialize some variables set by options.
+ ac_init_help=
+@@ -1650,6 +1655,7 @@ Optional Features:
--disable-largefile omit support for large files
--disable-rpath do not hardcode runtime library paths
--disable-alsa Disable optional ALSA support
@@ -45,174 +70,185 @@
--disable-pulse Disable optional PulseAudio support
--disable-null Disable optional null output
--disable-gtk Disable optional GTK+ support
-@@ -6080,7 +6088,7 @@ ia64-*-hpux*)
+@@ -6080,7 +6086,7 @@ ia64-*-hpux*)
;;
*-*-irix6*)
# Find out which ABI we are using.
- echo '#line 6083 "configure"' > conftest.$ac_ext
-+ echo '#line 6091 "configure"' > conftest.$ac_ext
++ echo '#line 6089 "configure"' > conftest.$ac_ext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
(eval $ac_compile) 2>&5
ac_status=$?
-@@ -8509,11 +8517,11 @@ else
+@@ -8509,11 +8515,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:8512: $lt_compile\"" >&5)
-+ (eval echo "\"\$as_me:8520: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:8518: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:8516: \$? = $ac_status" >&5
-+ echo "$as_me:8524: \$? = $ac_status" >&5
++ echo "$as_me:8522: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
-@@ -8799,11 +8807,11 @@ else
+@@ -8799,11 +8805,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:8802: $lt_compile\"" >&5)
-+ (eval echo "\"\$as_me:8810: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:8808: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:8806: \$? = $ac_status" >&5
-+ echo "$as_me:8814: \$? = $ac_status" >&5
++ echo "$as_me:8812: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
-@@ -8903,11 +8911,11 @@ else
+@@ -8903,11 +8909,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:8906: $lt_compile\"" >&5)
-+ (eval echo "\"\$as_me:8914: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:8912: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:8910: \$? = $ac_status" >&5
-+ echo "$as_me:8918: \$? = $ac_status" >&5
++ echo "$as_me:8916: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
-@@ -11305,7 +11313,7 @@ else
+@@ -11305,7 +11311,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 11308 "configure"
-+#line 11316 "configure"
++#line 11314 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -11405,7 +11413,7 @@ else
+@@ -11405,7 +11411,7 @@ else
lt_dlunknown=0; lt_dlno_uscore=1; lt_dlneed_uscore=2
lt_status=$lt_dlunknown
cat > conftest.$ac_ext <<EOF
-#line 11408 "configure"
-+#line 11416 "configure"
++#line 11414 "configure"
#include "confdefs.h"
#if HAVE_DLFCN_H
-@@ -13814,11 +13822,11 @@ else
+@@ -13814,11 +13820,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:13817: $lt_compile\"" >&5)
-+ (eval echo "\"\$as_me:13825: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:13823: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:13821: \$? = $ac_status" >&5
-+ echo "$as_me:13829: \$? = $ac_status" >&5
++ echo "$as_me:13827: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
-@@ -13918,11 +13926,11 @@ else
+@@ -13918,11 +13924,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:13921: $lt_compile\"" >&5)
-+ (eval echo "\"\$as_me:13929: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:13927: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:13925: \$? = $ac_status" >&5
-+ echo "$as_me:13933: \$? = $ac_status" >&5
++ echo "$as_me:13931: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
-@@ -15503,11 +15511,11 @@ else
+@@ -15503,11 +15509,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:15506: $lt_compile\"" >&5)
-+ (eval echo "\"\$as_me:15514: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:15512: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:15510: \$? = $ac_status" >&5
-+ echo "$as_me:15518: \$? = $ac_status" >&5
++ echo "$as_me:15516: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
-@@ -15607,11 +15615,11 @@ else
+@@ -15607,11 +15613,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:15610: $lt_compile\"" >&5)
-+ (eval echo "\"\$as_me:15618: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:15616: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:15614: \$? = $ac_status" >&5
-+ echo "$as_me:15622: \$? = $ac_status" >&5
++ echo "$as_me:15620: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
-@@ -17824,11 +17832,11 @@ else
+@@ -17824,11 +17830,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:17827: $lt_compile\"" >&5)
-+ (eval echo "\"\$as_me:17835: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:17833: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:17831: \$? = $ac_status" >&5
-+ echo "$as_me:17839: \$? = $ac_status" >&5
++ echo "$as_me:17837: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
-@@ -18114,11 +18122,11 @@ else
+@@ -18114,11 +18120,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:18117: $lt_compile\"" >&5)
-+ (eval echo "\"\$as_me:18125: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:18123: $lt_compile\"" >&5)
(eval "$lt_compile" 2>conftest.err)
ac_status=$?
cat conftest.err >&5
- echo "$as_me:18121: \$? = $ac_status" >&5
-+ echo "$as_me:18129: \$? = $ac_status" >&5
++ echo "$as_me:18127: \$? = $ac_status" >&5
if (exit $ac_status) && test -s "$ac_outfile"; then
# The compiler can only warn and ignore the option if not recognized
# So say no if there are warnings other than the usual output.
-@@ -18218,11 +18226,11 @@ else
+@@ -18218,11 +18224,11 @@ else
-e 's:.*FLAGS}\{0,1\} :&$lt_compiler_flag :; t' \
-e 's: [^ ]*conftest\.: $lt_compiler_flag&:; t' \
-e 's:$: $lt_compiler_flag:'`
- (eval echo "\"\$as_me:18221: $lt_compile\"" >&5)
-+ (eval echo "\"\$as_me:18229: $lt_compile\"" >&5)
++ (eval echo "\"\$as_me:18227: $lt_compile\"" >&5)
(eval "$lt_compile" 2>out/conftest.err)
ac_status=$?
cat out/conftest.err >&5
- echo "$as_me:18225: \$? = $ac_status" >&5
-+ echo "$as_me:18233: \$? = $ac_status" >&5
++ echo "$as_me:18231: \$? = $ac_status" >&5
if (exit $ac_status) && test -s out/conftest2.$ac_objext
then
# The compiler can only warn and ignore the option if not recognized
-@@ -21692,6 +21700,46 @@ if test "${ac_cv_c_bigendian+set}" = set
+@@ -20908,10 +20914,6 @@ LIBTOOL='$(SHELL) $(top_builddir)/libtoo
+
+
+
+-
+-subdirs="$subdirs libltdl"
+-
+-
+ #### Determine build environment ####
+
+ os_is_win32=0
+@@ -21692,6 +21694,46 @@ if test "${ac_cv_c_bigendian+set}" = set
$as_echo_n "(cached) " >&6
else
ac_cv_c_bigendian=unknown
@@ -259,76 +295,7 @@
if test $ac_cv_c_bigendian = unknown; then
# See if sys/param.h defines the BYTE_ORDER macro.
cat >conftest.$ac_ext <<_ACEOF
-@@ -23490,7 +23538,7 @@ fi
-
- # We must check for the threads library under a number of different
- # names; the ordering is very important because some systems
--# (e.g. DEC) have both -pthread and -pthreads, where one of the
-+# (e.g. DEC) have both -lpthread and -lpthreads, where one of the
- # libraries is broken (non-POSIX).
-
- # Create a list of thread flags to try. Items starting with a "-" are
-@@ -23503,7 +23551,7 @@ acx_pthread_flags="pthreads none -Kthrea
- # The ordering *is* (sometimes) important. Some notes on the
- # individual items follow:
-
--# pthreads: AIX (must check this before -pthread)
-+# pthreads: AIX (must check this before -lpthread)
- # none: in case threads are in libc; should be tried before -Kthread and
- # other compiler flags to prevent continual compiler warnings
- # -Kthread: Sequent (threads in libc, but -Kthread needed for pthread.h)
-@@ -23526,10 +23574,10 @@ case "${host_cpu}-${host_os}" in
- # On Solaris (at least, for some versions), libc contains stubbed
- # (non-functional) versions of the pthreads routines, so link-based
- # tests will erroneously succeed. (We need to link with -pthreads/-mt/
-- # -pthread.) (The stubs are missing pthread_cleanup_push, or rather
-+ # -lpthread.) (The stubs are missing pthread_cleanup_push, or rather
- # a function called by this macro, so we could check for that, but
- # who knows whether they'll stub that too in a future libc.) So,
-- # we'll just look for -pthreads and -pthread first:
-+ # we'll just look for -pthreads and -lpthread first:
-
- acx_pthread_flags="-pthreads pthread -mt -pthread $acx_pthread_flags"
- ;;
-@@ -23609,9 +23657,9 @@ $as_echo_n "checking for the pthreads li
- # Check for various functions. We must include pthread.h,
- # since some functions may be macros. (On the Sequent, we
- # need a special flag -Kthread to make this header compile.)
-- # We check for pthread_join because it is in -pthread on IRIX
-+ # We check for pthread_join because it is in -lpthread on IRIX
- # while pthread_create is in libc. We check for pthread_attr_init
-- # due to DEC craziness with -pthreads. We check for
-+ # due to DEC craziness with -lpthreads. We check for
- # pthread_cleanup_push because it is one of the few pthread
- # functions on Solaris that doesn't have a non-functional libc stub.
- # We try pthread_create on general principles.
-@@ -23916,12 +23964,12 @@ $as_echo "no" >&6; }
-
- #
- # Linux gcc on some architectures such as mips/mipsel forgets
-- # about -pthread
-+ # about -lpthread
- #
- if test x"$ok" = xno; then
-- { $as_echo "$as_me:$LINENO: checking whether -pthread fixes that" >&5
--$as_echo_n "checking whether -pthread fixes that... " >&6; }
-- LIBS="-pthread $PTHREAD_LIBS $save_LIBS"
-+ { $as_echo "$as_me:$LINENO: checking whether -lpthread fixes that" >&5
-+$as_echo_n "checking whether -lpthread fixes that... " >&6; }
-+ LIBS="-lpthread $PTHREAD_LIBS $save_LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -23975,7 +24023,7 @@ rm -f core conftest.err conftest.$ac_obj
- if test "x$ok" = xyes; then
- { $as_echo "$as_me:$LINENO: result: yes" >&5
- $as_echo "yes" >&6; }
-- PTHREAD_LIBS="-pthread $PTHREAD_LIBS"
-+ PTHREAD_LIBS="-lpthread $PTHREAD_LIBS"
- else
- { $as_echo "$as_me:$LINENO: result: no" >&5
- $as_echo "no" >&6; }
-@@ -25735,6 +25783,197 @@ fi
+@@ -25735,6 +25777,197 @@ fi
@@ -526,7 +493,7 @@
### PulseAudio (optional) ####
# Check whether --enable-pulse was given.
-@@ -26143,6 +26382,7 @@ HAVE_DSO=0
+@@ -26143,6 +26376,7 @@ HAVE_DSO=0
BUILTIN_DSO=0
BUILTIN_PULSE=0
BUILTIN_ALSA=0
@@ -534,7 +501,7 @@
BUILTIN_NULL=0
case "x$with_builtin" in
-@@ -26155,6 +26395,7 @@ $as_echo "$as_me: error: *** PulseAudio
+@@ -26155,6 +26389,7 @@ $as_echo "$as_me: error: *** PulseAudio
BUILTIN_PULSE=1
HAVE_ALSA=0
@@ -542,7 +509,7 @@
HAVE_NULL=0
;;
-@@ -26166,10 +26407,24 @@ $as_echo "$as_me: error: *** ALSA select
+@@ -26166,10 +26401,24 @@ $as_echo "$as_me: error: *** ALSA select
fi
BUILTIN_ALSA=1
@@ -567,7 +534,7 @@
xnull)
if test "x$HAVE_NULL" != x1 ; then
{ { $as_echo "$as_me:$LINENO: error: *** Null output selected for builtin driver, but not enabled. ***" >&5
-@@ -26180,6 +26435,7 @@ $as_echo "$as_me: error: *** Null output
+@@ -26180,6 +26429,7 @@ $as_echo "$as_me: error: *** Null output
BUILTIN_NULL=1
HAVE_PULSE=0
HAVE_ALSA=0
@@ -575,7 +542,7 @@
;;
xdso)
-@@ -26198,7 +26454,7 @@ $as_echo "$as_me: error: *** Unknown dri
+@@ -26198,7 +26448,7 @@ $as_echo "$as_me: error: *** Unknown dri
{ (exit 1); exit 1; }; }
esac
@@ -584,7 +551,7 @@
{ { $as_echo "$as_me:$LINENO: error: *** No backend enabled. ***" >&5
$as_echo "$as_me: error: *** No backend enabled. ***" >&2;}
{ (exit 1); exit 1; }; }
-@@ -26212,6 +26468,8 @@ fi
+@@ -26212,6 +26462,8 @@ fi
@@ -593,7 +560,7 @@
if test "x$HAVE_PULSE" = x1; then
HAVE_PULSE_TRUE=
HAVE_PULSE_FALSE='#'
-@@ -26228,6 +26486,14 @@ else
+@@ -26228,6 +26480,14 @@ else
HAVE_ALSA_FALSE=
fi
@@ -608,7 +575,7 @@
if test "x$HAVE_NULL" = x1; then
HAVE_NULL_TRUE=
HAVE_NULL_FALSE='#'
-@@ -26260,6 +26526,14 @@ else
+@@ -26260,6 +26520,14 @@ else
BUILTIN_ALSA_FALSE=
fi
@@ -623,7 +590,7 @@
if test "x$BUILTIN_NULL" = x1; then
BUILTIN_NULL_TRUE=
BUILTIN_NULL_FALSE='#'
-@@ -26539,6 +26813,13 @@ $as_echo "$as_me: error: conditional \"H
+@@ -26539,6 +26807,13 @@ $as_echo "$as_me: error: conditional \"H
Usually this means the macro was only invoked conditionally." >&2;}
{ (exit 1); exit 1; }; }
fi
@@ -637,7 +604,7 @@
if test -z "${HAVE_NULL_TRUE}" && test -z "${HAVE_NULL_FALSE}"; then
{ { $as_echo "$as_me:$LINENO: error: conditional \"HAVE_NULL\" was never defined.
Usually this means the macro was only invoked conditionally." >&5
-@@ -26567,6 +26848,13 @@ $as_echo "$as_me: error: conditional \"B
+@@ -26567,6 +26842,13 @@ $as_echo "$as_me: error: conditional \"B
Usually this means the macro was only invoked conditionally." >&2;}
{ (exit 1); exit 1; }; }
fi
@@ -651,7 +618,7 @@
if test -z "${BUILTIN_NULL_TRUE}" && test -z "${BUILTIN_NULL_FALSE}"; then
{ { $as_echo "$as_me:$LINENO: error: conditional \"BUILTIN_NULL\" was never defined.
Usually this means the macro was only invoked conditionally." >&5
-@@ -26926,9 +27214,9 @@ _ACEOF
+@@ -26926,9 +27208,9 @@ _ACEOF
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
# Files that config.status was made for.
@@ -664,7 +631,7 @@
_ACEOF
-@@ -27379,9 +27667,9 @@ cat >>$CONFIG_STATUS <<_ACEOF || ac_writ
+@@ -27379,9 +27661,9 @@ cat >>$CONFIG_STATUS <<_ACEOF || ac_writ
}
split(mac1, mac2, "(") #)
macro = mac2[1]
@@ -675,7 +642,7 @@
print prefix "define", macro P[macro] D[macro]
next
} else {
-@@ -27389,7 +27677,7 @@ cat >>$CONFIG_STATUS <<_ACEOF || ac_writ
+@@ -27389,7 +27671,7 @@ cat >>$CONFIG_STATUS <<_ACEOF || ac_writ
# in the case of _POSIX_SOURCE, which is predefined and required
# on some systems where configure will not decide to define it.
if (defundef == "undef") {
@@ -684,7 +651,201 @@
next
}
}
-@@ -28123,6 +28411,15 @@ if test "x$BUILTIN_ALSA" = "x1" ; then
+@@ -27906,193 +28188,6 @@ if test "$no_create" != yes; then
+ # would make configure fail if this is the last instruction.
+ $ac_cs_success || { (exit 1); exit 1; }
+ fi
+-
+-#
+-# CONFIG_SUBDIRS section.
+-#
+-if test "$no_recursion" != yes; then
+-
+- # Remove --cache-file, --srcdir, and --disable-option-checking arguments
+- # so they do not pile up.
+- ac_sub_configure_args=
+- ac_prev=
+- eval "set x $ac_configure_args"
+- shift
+- for ac_arg
+- do
+- if test -n "$ac_prev"; then
+- ac_prev=
+- continue
+- fi
+- case $ac_arg in
+- -cache-file | --cache-file | --cache-fil | --cache-fi \
+- | --cache-f | --cache- | --cache | --cach | --cac | --ca | --c)
+- ac_prev=cache_file ;;
+- -cache-file=* | --cache-file=* | --cache-fil=* | --cache-fi=* \
+- | --cache-f=* | --cache-=* | --cache=* | --cach=* | --cac=* | --ca=* \
+- | --c=*)
+- ;;
+- --config-cache | -C)
+- ;;
+- -srcdir | --srcdir | --srcdi | --srcd | --src | --sr)
+- ac_prev=srcdir ;;
+- -srcdir=* | --srcdir=* | --srcdi=* | --srcd=* | --src=* | --sr=*)
+- ;;
+- -prefix | --prefix | --prefi | --pref | --pre | --pr | --p)
+- ac_prev=prefix ;;
+- -prefix=* | --prefix=* | --prefi=* | --pref=* | --pre=* | --pr=* | --p=*)
+- ;;
+- --disable-option-checking)
+- ;;
+- *)
+- case $ac_arg in
+- *\'*) ac_arg=`$as_echo "$ac_arg" | sed "s/'/'\\\\\\\\''/g"` ;;
+- esac
+- ac_sub_configure_args="$ac_sub_configure_args '$ac_arg'" ;;
+- esac
+- done
+-
+- # Always prepend --prefix to ensure using the same prefix
+- # in subdir configurations.
+- ac_arg="--prefix=$prefix"
+- case $ac_arg in
+- *\'*) ac_arg=`$as_echo "$ac_arg" | sed "s/'/'\\\\\\\\''/g"` ;;
+- esac
+- ac_sub_configure_args="'$ac_arg' $ac_sub_configure_args"
+-
+- # Pass --silent
+- if test "$silent" = yes; then
+- ac_sub_configure_args="--silent $ac_sub_configure_args"
+- fi
+-
+- # Always prepend --disable-option-checking to silence warnings, since
+- # different subdirs can have different --enable and --with options.
+- ac_sub_configure_args="--disable-option-checking $ac_sub_configure_args"
+-
+- ac_popdir=`pwd`
+- for ac_dir in : $subdirs; do test "x$ac_dir" = x: && continue
+-
+- # Do not complain, so a configure script can configure whichever
+- # parts of a large source tree are present.
+- test -d "$srcdir/$ac_dir" || continue
+-
+- ac_msg="=== configuring in $ac_dir (`pwd`/$ac_dir)"
+- $as_echo "$as_me:$LINENO: $ac_msg" >&5
+- $as_echo "$ac_msg" >&6
+- { as_dir="$ac_dir"
+- case $as_dir in #(
+- -*) as_dir=./$as_dir;;
+- esac
+- test -d "$as_dir" || { $as_mkdir_p && mkdir -p "$as_dir"; } || {
+- as_dirs=
+- while :; do
+- case $as_dir in #(
+- *\'*) as_qdir=`$as_echo "$as_dir" | sed "s/'/'\\\\\\\\''/g"`;; #'(
+- *) as_qdir=$as_dir;;
+- esac
+- as_dirs="'$as_qdir' $as_dirs"
+- as_dir=`$as_dirname -- "$as_dir" ||
+-$as_expr X"$as_dir" : 'X\(.*[^/]\)//*[^/][^/]*/*$' \| \
+- X"$as_dir" : 'X\(//\)[^/]' \| \
+- X"$as_dir" : 'X\(//\)$' \| \
+- X"$as_dir" : 'X\(/\)' \| . 2>/dev/null ||
+-$as_echo X"$as_dir" |
+- sed '/^X\(.*[^/]\)\/\/*[^/][^/]*\/*$/{
+- s//\1/
+- q
+- }
+- /^X\(\/\/\)[^/].*/{
+- s//\1/
+- q
+- }
+- /^X\(\/\/\)$/{
+- s//\1/
+- q
+- }
+- /^X\(\/\).*/{
+- s//\1/
+- q
+- }
+- s/.*/./; q'`
+- test -d "$as_dir" && break
+- done
+- test -z "$as_dirs" || eval "mkdir $as_dirs"
+- } || test -d "$as_dir" || { { $as_echo "$as_me:$LINENO: error: cannot create directory $as_dir" >&5
+-$as_echo "$as_me: error: cannot create directory $as_dir" >&2;}
+- { (exit 1); exit 1; }; }; }
+- ac_builddir=.
+-
+-case "$ac_dir" in
+-.) ac_dir_suffix= ac_top_builddir_sub=. ac_top_build_prefix= ;;
+-*)
+- ac_dir_suffix=/`$as_echo "$ac_dir" | sed 's|^\.[\\/]||'`
+- # A ".." for each directory in $ac_dir_suffix.
+- ac_top_builddir_sub=`$as_echo "$ac_dir_suffix" | sed 's|/[^\\/]*|/..|g;s|/||'`
+- case $ac_top_builddir_sub in
+- "") ac_top_builddir_sub=. ac_top_build_prefix= ;;
+- *) ac_top_build_prefix=$ac_top_builddir_sub/ ;;
+- esac ;;
+-esac
+-ac_abs_top_builddir=$ac_pwd
+-ac_abs_builddir=$ac_pwd$ac_dir_suffix
+-# for backward compatibility:
+-ac_top_builddir=$ac_top_build_prefix
+-
+-case $srcdir in
+- .) # We are building in place.
+- ac_srcdir=.
+- ac_top_srcdir=$ac_top_builddir_sub
+- ac_abs_top_srcdir=$ac_pwd ;;
+- [\\/]* | ?:[\\/]* ) # Absolute name.
+- ac_srcdir=$srcdir$ac_dir_suffix;
+- ac_top_srcdir=$srcdir
+- ac_abs_top_srcdir=$srcdir ;;
+- *) # Relative name.
+- ac_srcdir=$ac_top_build_prefix$srcdir$ac_dir_suffix
+- ac_top_srcdir=$ac_top_build_prefix$srcdir
+- ac_abs_top_srcdir=$ac_pwd/$srcdir ;;
+-esac
+-ac_abs_srcdir=$ac_abs_top_srcdir$ac_dir_suffix
+-
+-
+- cd "$ac_dir"
+-
+- # Check for guested configure; otherwise get Cygnus style configure.
+- if test -f "$ac_srcdir/configure.gnu"; then
+- ac_sub_configure=$ac_srcdir/configure.gnu
+- elif test -f "$ac_srcdir/configure"; then
+- ac_sub_configure=$ac_srcdir/configure
+- elif test -f "$ac_srcdir/configure.in"; then
+- # This should be Cygnus configure.
+- ac_sub_configure=$ac_aux_dir/configure
+- else
+- { $as_echo "$as_me:$LINENO: WARNING: no configuration information is in $ac_dir" >&5
+-$as_echo "$as_me: WARNING: no configuration information is in $ac_dir" >&2;}
+- ac_sub_configure=
+- fi
+-
+- # The recursion is here.
+- if test -n "$ac_sub_configure"; then
+- # Make the cache file name correct relative to the subdirectory.
+- case $cache_file in
+- [\\/]* | ?:[\\/]* ) ac_sub_cache_file=$cache_file ;;
+- *) # Relative name.
+- ac_sub_cache_file=$ac_top_build_prefix$cache_file ;;
+- esac
+-
+- { $as_echo "$as_me:$LINENO: running $SHELL $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_srcdir" >&5
+-$as_echo "$as_me: running $SHELL $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_srcdir" >&6;}
+- # The eval makes quoting arguments work.
+- eval "\$SHELL \"\$ac_sub_configure\" $ac_sub_configure_args \
+- --cache-file=\"\$ac_sub_cache_file\" --srcdir=\"\$ac_srcdir\"" ||
+- { { $as_echo "$as_me:$LINENO: error: $ac_sub_configure failed for $ac_dir" >&5
+-$as_echo "$as_me: error: $ac_sub_configure failed for $ac_dir" >&2;}
+- { (exit 1); exit 1; }; }
+- fi
+-
+- cd "$ac_popdir"
+- done
+-fi
+ if test -n "$ac_unrecognized_opts" && test "$enable_option_checking" != no; then
+ { $as_echo "$as_me:$LINENO: WARNING: Unrecognized options: $ac_unrecognized_opts" >&5
+ $as_echo "$as_me: WARNING: Unrecognized options: $ac_unrecognized_opts" >&2;}
+@@ -28123,6 +28218,15 @@ if test "x$BUILTIN_ALSA" = "x1" ; then
ENABLE_BUILTIN_ALSA=yes
fi
@@ -700,7 +861,7 @@
ENABLE_NULL=no
if test "x$HAVE_NULL" = "x1" ; then
ENABLE_NULL=yes
-@@ -28152,6 +28449,8 @@ echo "
+@@ -28152,6 +28256,8 @@ echo "
Builtin PulseAudio: ${ENABLE_BUILTIN_PULSE}
Enable ALSA: ${ENABLE_ALSA}
Builtin ALSA: ${ENABLE_BUILTIN_ALSA}