aboutsummaryrefslogtreecommitdiff
path: root/audio/libcdaudio
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-06-27 03:29:59 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-06-27 03:29:59 +0000
commit6a78684feaaa5cb959945bcbb2fad88e0af3fbc2 (patch)
treef48cc15dfb05040438607b29c305aa2f2c9a55ad /audio/libcdaudio
parentb3cecf32b46921471944e9e6b15545f79d8cbff1 (diff)
downloadports-6a78684feaaa5cb959945bcbb2fad88e0af3fbc2.tar.gz
ports-6a78684feaaa5cb959945bcbb2fad88e0af3fbc2.zip
Fix bad static buffer bound. Bump PORTREVISION.
Obtained from: OpenBSD
Notes
Notes: svn path=/head/; revision=83698
Diffstat (limited to 'audio/libcdaudio')
-rw-r--r--audio/libcdaudio/Makefile1
-rw-r--r--audio/libcdaudio/files/patch-source_cdindex_c12
2 files changed, 13 insertions, 0 deletions
diff --git a/audio/libcdaudio/Makefile b/audio/libcdaudio/Makefile
index 3c7cc9e974dd..624c8d6c8a7d 100644
--- a/audio/libcdaudio/Makefile
+++ b/audio/libcdaudio/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libcdaudio
PORTVERSION= 0.99.9
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/audio/libcdaudio/files/patch-source_cdindex_c b/audio/libcdaudio/files/patch-source_cdindex_c
new file mode 100644
index 000000000000..c2b3229ed6ab
--- /dev/null
+++ b/audio/libcdaudio/files/patch-source_cdindex_c
@@ -0,0 +1,12 @@
+$OpenBSD: patch-source_cdindex_c,v 1.1 2003/04/14 09:47:46 avsm Exp $
+--- source/cdindex.c.orig Mon Apr 14 10:06:46 2003
++++ source/cdindex.c Mon Apr 14 10:07:43 2003
+@@ -878,7 +878,7 @@ cdindex_http_submit(int cd_desc, struct
+ strncpy(outbuffer, "Content-Type: text/plain\n", 512);
+ write(sock, outbuffer, strlen(outbuffer));
+
+- snprintf(cdindex_file, 512, "%s/.cdindex/%s",
++ snprintf(cdindex_file, sizeof cdindex_file, "%s/.cdindex/%s",
+ getenv("HOME"), entry.entry_cdindex_id);
+ stat(cdindex_file, &st);
+