aboutsummaryrefslogtreecommitdiff
path: root/audio/libgpod-sharp/Makefile
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2016-11-27 17:00:08 +0000
committerDavid Naylor <dbn@FreeBSD.org>2016-11-27 17:00:08 +0000
commit4a9609d5d36869f042a616c2306eede6976e9f19 (patch)
treed47ccdb7a554ac0b8b8399fa8a240b8f4abf36ad /audio/libgpod-sharp/Makefile
parent930c6dac52021bd7e799b5f6eb341575f2f2f087 (diff)
downloadports-4a9609d5d36869f042a616c2306eede6976e9f19.tar.gz
ports-4a9609d5d36869f042a616c2306eede6976e9f19.zip
USES=mono: simplify EXTRACT_ONLY, fix nuget-extract [1]
- Instead of excluding the specific packages added to DISTFILES (but only for FreeBSD 9+), exclude all files with a '.nupkg' extension. - Move the nuget-extract command to be before post-extract, to allow the port's post-extract command to move packages around audio/libgpod-sharp: add port for mono bindings for libgpod - audio/libgpod: [2] - USE_GNOME: add missing dependency - Remove mono files from pkg-plist (now in audio/libgpod-sharp) - Allow relevant variables to be overridden - Fix MONO options - Patch source to allow building with modern mono - Avoid post-install target for slave ports. devel/monodevelop: update to 4.6.2.7 - Update nuget package Fantomas to 2.4.0 (latest at time of monodevelop's release). - Downgrade nuget package FSharp.Compiler.CodeDom (per paket's specification) - LICENSE: Add license of LGPL21 - LICENSE_FILE: Add license file from source - PORTSCOUT: Avoid checking alpha releases (aka x.y.0.z releases) games/openra: simplify post-extract [3] - USES=mono:nuget allow overridding of NUGET_PACKAGEDIR - Set NUGET_PACKAGEDIR to correct location, fix patching accordingly lang/fsharp: update to 4.6.2.7 ChangeLog: - Fix #639: Problems with F# scripts on Mono - Fix FSharp.Compiler.Tools targets for .NET Core usage - Fix FSharp.Compiler.Tools package dependencies lang/mono: update to 4.6.2.7 Mono 4.6.2 is the 1st service release to the 4.6 series. Changes: - LICENSE: Add license of MIT - LICENSE_FILE: Add license file from source - PORTSCOUT: Avoid checking alpha releases (aka x.y.0.z releases) Bug fixes: - #44708 - "TrustFailure (The authentication or decryption has failed.) ... Invalid certificate received from server." with "Error code: 0x5" or "Error code: 0xffffffff800b010f" when attempting to access HTTPS servers on ports other than 443 - #39832 - SIGSEGV when running roslyn multimedia/banshee: bump port revision. - Update missing port dependencies - Convert to use option helpers - OPTIONS: Add APPLEDEV (missing dependency added) - LICENSE: Add MIT license - LICENSE_FILE: Add license file from source - PORTSCOUT: Skip alpha release (2.9.1) x11-toolkits/gnome-sharp20: fix port dependencies - Add missing dependencies - Convert post-patch to shebangfix - LICENSE: add LGPL21 license - LICENSE_FILE: use license file from source - MKAE_JOBS_UNSAFE: remove, does appear to work x11-toolkits/gtk-sharp20: update to 2.12.42. PR: 214680 [2] PR: 214681 Suggested by: jbeich [1] Submitted by: jbeich [3] Approved by: avilla (maintainer; timeout) [2]
Notes
Notes: svn path=/head/; revision=427247
Diffstat (limited to 'audio/libgpod-sharp/Makefile')
-rw-r--r--audio/libgpod-sharp/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/audio/libgpod-sharp/Makefile b/audio/libgpod-sharp/Makefile
new file mode 100644
index 000000000000..45828fc49b8a
--- /dev/null
+++ b/audio/libgpod-sharp/Makefile
@@ -0,0 +1,22 @@
+# Created by: David Naylor <dbn@FreeBSD.org>
+# $FreeBSD$
+
+PKGNAMESUFFIX= -sharp
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= .Net bindings for the libgpod library
+
+RUN_DEPENDS= ${LOCALBASE}/lib/libgpod.so:audio/libgpod
+
+OPTIONS_EXCLUDE=DOCS IMOBILE PYTHON
+OPTIONS_SLAVE= MONO
+
+BUILD_WRKSRC= ${WRKSRC}/bindings/mono
+INSTALL_WRKSRC= ${WRKSRC}/bindings/mono
+
+SLAVE_PORT= yes
+MASTERDIR= ${.CURDIR}/../libgpod
+
+PLIST= ${.CURDIR}/pkg-plist
+
+.include "${MASTERDIR}/Makefile"