aboutsummaryrefslogtreecommitdiff
path: root/audio/liblo/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-12-08 16:48:38 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-12-08 16:48:38 +0000
commit60945f027780c21c987e0c642404a8383407edad (patch)
treefd2d9471767ad6e92fff12ef08f1cb015017f9f8 /audio/liblo/Makefile
parente59096e905f88c35da2fdfb21e14d87a51cc6c9b (diff)
downloadports-60945f027780c21c987e0c642404a8383407edad.tar.gz
ports-60945f027780c21c987e0c642404a8383407edad.zip
Replace USES=libtool:oldver with USES=libtool or USES=libtool:keepla in
the 32 ports that still use it. Bump PORTREVISION on their dependent ports except the ones that depend on these: audio/libogg audio/libvorbis devel/pcre ftp/curl graphics/jpeg graphics/libart_lgpl graphics/tiff textproc/expat2 textproc/libxslt In these cases the same trick as in the recent gettext update is used. The ports install a symlink with the old library version. When enough of their dependent ports have had regular updates the remaining ones can get a PORTREVISION bump and the links can be removed. Also remove the devel/pcre dependency from USE_GNOME=glib20. It causes over 2200 packages to depend on devel/pcre while less than 200 actually link with it. The glib20 package still depends on devel/pcre so this should not make a difference for ports with USE_GNOME=glib20. Also, libdata/pkgconfig/glib-2.0.pc lists pcre as a private library so USE_GNOME=glib20 should not propagate it. PR: 195724 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=374303
Diffstat (limited to 'audio/liblo/Makefile')
-rw-r--r--audio/liblo/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/audio/liblo/Makefile b/audio/liblo/Makefile
index a647e8219456..14d0712c888f 100644
--- a/audio/liblo/Makefile
+++ b/audio/liblo/Makefile
@@ -3,7 +3,7 @@
PORTNAME= liblo
PORTVERSION= 0.28
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= SF
@@ -12,13 +12,11 @@ COMMENT= Lightweight Open Sound Control implementation
LICENSE= LGPL21
-USES= gmake libtool:oldver pathfix
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= gmake libtool pathfix
USE_LDCONFIG= yes
-SHLIB_VER= 9
-PLIST_SUB+= SHLIB_VER="${SHLIB_VER}"
-
PORTDOCS= *
PORTEXAMPLES= example_client example_server \
example_tcp_echo_server nonblocking_server_example
@@ -37,7 +35,6 @@ post-patch:
.endif
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/liblo.so.${SHLIB_VER}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in AUTHORS ChangeLog NEWS README TODO
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}