aboutsummaryrefslogtreecommitdiff
path: root/audio/libnoise
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2009-08-02 19:36:34 +0000
commit789d75c728ef23566a07bf5b9bc2190bf34ff4f1 (patch)
treedc7540d42fa2d5d7c1c74515e3bdbf6ab842cd17 /audio/libnoise
parentd1a9e827c98542eb35619dffa314cba50fb08b58 (diff)
downloadports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.tar.gz
ports-789d75c728ef23566a07bf5b9bc2190bf34ff4f1.zip
-Repocopy devel/libtool15 -> libtool22 and libltdl15 -> libltdl22.
-Update libtool and libltdl to 2.2.6a. -Remove devel/libtool15 and devel/libltdl15. -Fix ports build with libtool22/libltdl22. -Bump ports that depend on libltdl22 due to shared library version change. -Explain what to do update in the UPDATING. It has been tested with GNOME2, XFCE4, KDE3, KDE4 and other many wm/desktop and applications in the runtime. With help: marcus and kwm Pointyhat-exp: a few times by pav Tested by: pgollucci, "Romain Tartière" <romain@blogreen.org>, and a few MarcusCom CVS users. Also, I might have missed a few. Repocopy by: marcus Approved by: portmgr
Notes
Notes: svn path=/head/; revision=238781
Diffstat (limited to 'audio/libnoise')
-rw-r--r--audio/libnoise/Makefile15
-rw-r--r--audio/libnoise/files/patch-src_Makefile19
2 files changed, 30 insertions, 4 deletions
diff --git a/audio/libnoise/Makefile b/audio/libnoise/Makefile
index 100b433462cb..16c18e63cf20 100644
--- a/audio/libnoise/Makefile
+++ b/audio/libnoise/Makefile
@@ -14,19 +14,26 @@ DISTNAME= ${PORTNAME}src-${DISTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Generates three-dimensional coherent noise
-BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool15
-
USE_ZIP= yes
USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:22:env
USE_LDCONFIG= yes
CXXFLAGS+= -O3 -fomit-frame-pointer
WRKSRC= ${WRKDIR}/noise
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e 's|include lib:|include:|g' \
+ ${WRKSRC}/Makefile
+
do-install:
- @${CP} -R ${WRKSRC}/lib/${PORTNAME}.* ${PREFIX}/lib/
+ @${CP} -R ${WRKSRC}/src/${PORTNAME}.* ${PREFIX}/lib/
+ @${CP} -R ${WRKSRC}/src/.libs/${PORTNAME}.so.* ${PREFIX}/lib/
@${INSTALL} -d ${PREFIX}/include/noise
@${CP} -R ${WRKSRC}/include/ ${PREFIX}/include/noise/
@${RM} -f ${PREFIX}/include/noise/Makefile
- @${LN} -sf ${PREFIX}/lib/libnoise.so.0.3 ${PREFIX}/lib/libnoise.so.0
+# This line is here to preserve the old behavior of the port.
+ @${LN} -sf ${PREFIX}/lib/libnoise.so.0 ${PREFIX}/lib/libnoise.so.0.3
.include <bsd.port.mk>
diff --git a/audio/libnoise/files/patch-src_Makefile b/audio/libnoise/files/patch-src_Makefile
new file mode 100644
index 000000000000..6bf567fbb7d4
--- /dev/null
+++ b/audio/libnoise/files/patch-src_Makefile
@@ -0,0 +1,19 @@
+--- src/Makefile.orig 2004-10-24 21:21:12.000000000 +0200
++++ src/Makefile 2009-07-16 11:31:48.000000000 +0200
+@@ -12,12 +12,12 @@
+
+ # hooks for future makefiles being able to make multiple SOs, or older SOs
+ libnoise: libnoise.so libnoise.a libnoise.la
+-libnoise.so: libnoise.so.0
+-libnoise.so.0: libnoise.so.0.3
++#libnoise.so: libnoise.so.0
++#libnoise.so.0: libnoise.so.0.3
+
+ # Real build targets
+-libnoise.so.0.3: $(OBJECTS)
+- $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -shared -Wl,-soname=libnoise.so.0 -o $@ $(OBJECTS:.o=.lo)
++libnoise: $(OBJECTS)
++ $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -shared -o $@.la $(OBJECTS:.o=.lo) -rpath %%LOCALBASE%%/lib
+
+ libnoise.a: $(OBJECTS)
+ $(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -o $@ $(OBJECTS)