aboutsummaryrefslogtreecommitdiff
path: root/audio/libshout2
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-07-09 23:06:36 +0000
committerSteve Wills <swills@FreeBSD.org>2011-07-09 23:06:36 +0000
commit3f622fa6977a76f013c4cd0f94644ad268805f82 (patch)
treeeb0beb14f38795441f3de4dbbc3ad897b8b2e49a /audio/libshout2
parent58ec204205221aab24d9b4be6c649c1f8921c322 (diff)
downloadports-3f622fa6977a76f013c4cd0f94644ad268805f82.tar.gz
ports-3f622fa6977a76f013c4cd0f94644ad268805f82.zip
- Add patch to have dependencies link to libspeex which is needed by
libshout - Add patch to pkgconfig to list libspeex as a dep of libshout2 Obtained from: Debian
Notes
Notes: svn path=/head/; revision=277416
Diffstat (limited to 'audio/libshout2')
-rw-r--r--audio/libshout2/Makefile2
-rw-r--r--audio/libshout2/files/patch-libshout-shout.pc.in10
-rw-r--r--audio/libshout2/files/patch-src-Makefile.am22
3 files changed, 33 insertions, 1 deletions
diff --git a/audio/libshout2/Makefile b/audio/libshout2/Makefile
index 6e0366301b7b..3d6c175b73a0 100644
--- a/audio/libshout2/Makefile
+++ b/audio/libshout2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libshout2
PORTVERSION= 2.2.2
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= audio net
MASTER_SITES= http://downloads.xiph.org/releases/libshout/
diff --git a/audio/libshout2/files/patch-libshout-shout.pc.in b/audio/libshout2/files/patch-libshout-shout.pc.in
new file mode 100644
index 000000000000..2a0eefce8779
--- /dev/null
+++ b/audio/libshout2/files/patch-libshout-shout.pc.in
@@ -0,0 +1,10 @@
+--- shout.pc.in.orig 2007-12-11 14:35:45.000000000 +0100
++++ shout.pc.in 2007-12-11 14:35:56.000000000 +0100
+@@ -10,6 +10,6 @@
+ Name: Shout
+ Description: Audio streaming library for icecast encoders
+ Version: @VERSION@
+-Requires: @SHOUT_REQUIRES@
++Requires.private: @SHOUT_REQUIRES@
+ Libs: -L${libdir} -lshout
+ Cflags: -I${includedir} @PTHREAD_CPPFLAGS@ @SHOUT_CFLAGS@
diff --git a/audio/libshout2/files/patch-src-Makefile.am b/audio/libshout2/files/patch-src-Makefile.am
new file mode 100644
index 000000000000..8d8a6d2612cf
--- /dev/null
+++ b/audio/libshout2/files/patch-src-Makefile.am
@@ -0,0 +1,22 @@
+--- src/Makefile.am.orig 2006-01-03 20:22:17.000000000 +0100
++++ src/Makefile.am 2006-05-28 18:37:22.000000000 +0200
+@@ -26,7 +26,7 @@
+ AM_CFLAGS = @XIPH_CFLAGS@
+
+ libshout_la_LIBADD = net/libicenet.la timing/libicetiming.la avl/libiceavl.la\
+- httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS)
++ httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(SPEEX_LIBS) $(VORBIS_LIBS)
+
+ INCLUDES = -I$(top_builddir)/include
+
+--- src/Makefile.in.orig 2006-01-03 20:24:29.000000000 +0100
++++ src/Makefile.in 2006-05-28 18:37:56.000000000 +0200
+@@ -261,7 +261,7 @@
+ libshout_la_SOURCES = shout.c util.c ogg.c vorbis.c mp3.c $(MAYBE_THEORA) $(MAYBE_SPEEX)
+ AM_CFLAGS = @XIPH_CFLAGS@
+ libshout_la_LIBADD = net/libicenet.la timing/libicetiming.la avl/libiceavl.la\
+- httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(VORBIS_LIBS)
++ httpp/libicehttpp.la $(MAYBE_THREAD_LIB) $(THEORA_LIBS) $(SPEEX_LIBS) $(VORBIS_LIBS)
+
+ INCLUDES = -I$(top_builddir)/include
+ all: all-recursive