aboutsummaryrefslogtreecommitdiff
path: root/audio/libsidplayfp/Makefile
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-11-09 16:33:26 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-11-09 16:33:26 +0000
commitd6dc299ff774df0cd0ed502f20fccddb24212924 (patch)
tree31d9001a4cbe359e46d8e55eeeb791873707d9f1 /audio/libsidplayfp/Makefile
parentb6fb83656db887ae78c72aa69fb599352eb5b4b7 (diff)
downloadports-d6dc299ff774df0cd0ed502f20fccddb24212924.tar.gz
ports-d6dc299ff774df0cd0ed502f20fccddb24212924.zip
Update audio/libsidplayfp to upstream version 1.6.0
Bump PORTREVISION of dependent ports PR: 194626 Submitted by: liangtai.s16@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=372366
Diffstat (limited to 'audio/libsidplayfp/Makefile')
-rw-r--r--audio/libsidplayfp/Makefile55
1 files changed, 48 insertions, 7 deletions
diff --git a/audio/libsidplayfp/Makefile b/audio/libsidplayfp/Makefile
index 6276f8c2d9f4..085e5fde79ef 100644
--- a/audio/libsidplayfp/Makefile
+++ b/audio/libsidplayfp/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= libsidplayfp
-PORTVERSION= 1.5.0
+PORTVERSION= 1.6.0
CATEGORIES= audio
MASTER_SITES= SF/sidplay-residfp/libsidplayfp/${PORTVERSION:R}
@@ -15,12 +15,53 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
-SIDPLAYFP_SHLIB_VER= 3.0.12
-STILVIEW_SHLIB_VER= 0.0.1
+PORTDOCS= NEWS README TODO
+
+OPTIONS_DEFINE= DEBUG DOCS DOXYGEN
+DEBUG_CONFIGURE_ON= --enable-debug=full
+DOXYGEN_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+
+OPTIONS_MULTI= OPTIMIZATION
+OPTIONS_MULTI_OPTIMIZATION= BHINTS INLINE MMX
+OPTIONS_DEFAULT= BHINTS INLINE
+OPTIMIZATION_DESC= Increase performance by optimization
+BHINTS_DESC= Enable branch hints in reSID engine
+BHINTS_CONFIGURE_ENABLE= branch-hints
+INLINE_DESC= Enable inlining in reSID engine at bigger code size
+INLINE_CONFIGURE_ENABLE= inline
+MMX_DESC= Enable MMX code in reSIDfp for old x86 non-SSE2 CPU
+MMX_CONFIGURE_ENABLE= mmx
+
+BUILD_DEPENDS+= xa65:${PORTSDIR}/devel/xa65
+
+.include <bsd.port.options.mk>
+
+SIDPLAYFP_SHLIB_VERSION= 3.1.0
+STILVIEW_SHLIB_VERSION= 0.0.2
PLIST_SUB+= \
- SIDPLAYFP_SHLIB_MVER=${SIDPLAYFP_SHLIB_VER:C/\.[[:digit:].]+//} \
- SIDPLAYFP_SHLIB_VER=${SIDPLAYFP_SHLIB_VER} \
- STILVIEW_SHLIB_MVER=${STILVIEW_SHLIB_VER:C/\.[[:digit:].]+//} \
- STILVIEW_SHLIB_VER=${STILVIEW_SHLIB_VER}
+ SIDPLAYFP_SHLIB_VER=${SIDPLAYFP_SHLIB_VERSION:C/\.[[:digit:].]+//} \
+ SIDPLAYFP_SHLIB_VERSION=${SIDPLAYFP_SHLIB_VERSION} \
+ STILVIEW_SHLIB_VER=${STILVIEW_SHLIB_VERSION:C/\.[[:digit:].]+//} \
+ STILVIEW_SHLIB_VERSION=${STILVIEW_SHLIB_VERSION}
+
+post-build:
+.if ${PORT_OPTIONS:MDOXYGEN}
+ cd ${WRKSRC} && ${MAKE} doc
+.endif
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR} ; \
+ cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+.endif
+.if ${PORT_OPTIONS:MDOXYGEN}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/html ; \
+ ${INSTALL_MAN} ${WRKSRC}/docs/html/* ${STAGEDIR}${DOCSDIR}/html ; \
+ ${RM} -f ${WRKDIR}/PLIST.doc ; \
+ ${FIND} ${STAGEDIR}${DOCSDIR}/html -type f | \
+ ${SED} 's|${STAGEDIR}${PREFIX}/||' \
+ >> ${WRKDIR}/PLIST.doc
+ cd ${WRKDIR} ; ${SED} -i -e '/PLIST.doc/ r PLIST.doc' ${TMPPLIST}
+.endif
.include <bsd.port.mk>