aboutsummaryrefslogtreecommitdiff
path: root/audio/linux-c6-alsa-utils/Makefile
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
commit05317facbedf1ed4566b56f4e09e6e4a49fc3f38 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /audio/linux-c6-alsa-utils/Makefile
parentf287925fdbb7ff7ab55ee8aaa28cf756fe49a296 (diff)
downloadports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.tar.gz
ports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Notes
Notes: svn path=/head/; revision=368845
Diffstat (limited to 'audio/linux-c6-alsa-utils/Makefile')
-rw-r--r--audio/linux-c6-alsa-utils/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/audio/linux-c6-alsa-utils/Makefile b/audio/linux-c6-alsa-utils/Makefile
new file mode 100644
index 000000000000..a2bcc5db49fd
--- /dev/null
+++ b/audio/linux-c6-alsa-utils/Makefile
@@ -0,0 +1,25 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= alsa-utils
+PORTVERSION= 1.0.22
+CATEGORIES= audio linux
+PKGNAMEPREFIX= linux-${USE_LINUX}-
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Advanced Linux Sound Architecture libraries (Linux CentOS ${LINUX_DIST_VER})
+
+LICENSE= GPLv3
+
+CONFLICTS= linux-alsa-lib-[0-9]* linux-f8-alsa-lib-[0-9]* linux-f10-alsa-lib-[0-9]*
+
+BRANDELF_FILES= sbin/alsactl usr/bin/aconnect usr/bin/alsamixer usr/bin/amidi usr/bin/aplay usr/bin/aplaymidi usr/bin/arecord usr/bin/arecordmidi usr/bin/aseqdump usr/bin/aseqnet usr/bin/iecset usr/bin/speaker-test usr/sbin/alsactl
+#EXTRACT_ONLY= ${DISTFILES}
+USE_LINUX_APPS= alsalib alsa-plugins-oss
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= c6
+USE_LINUX_RPM= yes
+RPMVERSION= 5.el6
+
+.include <bsd.port.mk>