aboutsummaryrefslogtreecommitdiff
path: root/audio/linux-c7-openal-soft/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-01-31 16:54:21 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-01-31 16:54:21 +0000
commit6140d3c6aada863a40f9075019eb0f48789cd48f (patch)
tree31bde26cde7c64937193d64587b12c96997aad8c /audio/linux-c7-openal-soft/Makefile
parent0177884e904ff5abe1705efd562133d568e572c4 (diff)
downloadports-6140d3c6aada863a40f9075019eb0f48789cd48f.tar.gz
ports-6140d3c6aada863a40f9075019eb0f48789cd48f.zip
- Autodetect the installed linux_base port and use LINUX_DEFAULT only as
a last resort. - Construct a list of DISTFILES for every architecture (amd64, i386). Select one list for regular make and all lists for make makesum so linux ports can have one combined distinfo file. - Set DIST_SUBDIR?=centos so there's only one copy of common distfiles. - Use MASTER_SITES and DISTFILES groups so make fetch is a bit smarter. - Regenerate all distinfo files. - For linux_base-c6 (just like linux_base-c7 already does) turn bin, lib, lib64 and sbin into symbolic links to the same directory under usr. This fixes the problem where some programs/libraries exist under / on FreeBSD and /usr on Linux or vice versa and then depending on the order of search paths Linux programs may run/load FreeBSD programs/libraries and fail. - Turn usr/share/icons into a symbolic link to LOCALBASE/share/icons so Linux programs can find desktop theme icons. This eliminates the need for x11-themes/linux*-hicolor-icon-theme. - Rename pkg-plist.x86_64 to pkg-plist.amd64. - Regenerate all pkg-plist files. - Add @preexec to linux_base pkg-plist that moves existing files in bin, lib, lib64, sbin and icons to the new destination before the directories are turned into symbolic links. - Remove several empty directories from linux_base ports. - Sweep over all linux ports: use consistent style, remove old CONFLICTS, remove unused pkg-descr files, add NLS option,... - Remove old linux arts, esound and openssl-compat ports.
Notes
Notes: svn path=/head/; revision=432937
Diffstat (limited to 'audio/linux-c7-openal-soft/Makefile')
-rw-r--r--audio/linux-c7-openal-soft/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/audio/linux-c7-openal-soft/Makefile b/audio/linux-c7-openal-soft/Makefile
index 43658d7df7bf..c4a16c069686 100644
--- a/audio/linux-c7-openal-soft/Makefile
+++ b/audio/linux-c7-openal-soft/Makefile
@@ -3,23 +3,21 @@
PORTNAME= openal-soft
PORTVERSION= 1.16.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio linux
MASTER_SITES= EPEL7/o
MAINTAINER= emulation@FreeBSD.org
-COMMENT= A 3D positional spatialized sound library (Linux CentOS ${LINUX_DIST_VER})
+COMMENT= 3D positional spatialized sound library (Linux CentOS ${LINUX_DIST_VER})
CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
ONLY_FOR_ARCHS= amd64
RPMVERSION= 3.el7
USES= linux:c7
USE_LDCONFIG= yes
-USE_LINUX= alsalib esound
+USE_LINUX= alsalib
USE_LINUX_RPM= yes
-PORTDOCS= COPYING
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-
.include <bsd.port.mk>