aboutsummaryrefslogtreecommitdiff
path: root/audio/linux-f10-sdl_mixer/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-04-01 15:25:39 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-04-01 15:25:39 +0000
commit824eda00fccb57b36978b562ecfc6572fa5de766 (patch)
treedddb20be9539275c41e943b4763c0b29ba61151d /audio/linux-f10-sdl_mixer/Makefile
parent8217c4dd1dea5cbe146907f97afb3e458208ec77 (diff)
downloadports-824eda00fccb57b36978b562ecfc6572fa5de766.tar.gz
ports-824eda00fccb57b36978b562ecfc6572fa5de766.zip
Here are new Linux Fedora 8 infrastructure ports.
The recommended version of FreeBSD to use them is 8-CURRENT. FreeBSD-7.x is not fully compatible with compat.linux.osrelease 2.6.16. Some syscalls cannot be MFCed due to native FreeBSD ABI breakage. Usage (and package building): 1. define compat.linux.osrelease=2.6.16; 2. add following variables to /etc/make.conf: . OVERRIDE_LINUX_BASE_PORT=f8; . OVERRIDE_LINUX_NONBASE_PORTS=f8. Approved by: bsam (me) ;-)
Notes
Notes: svn path=/head/; revision=231438
Diffstat (limited to 'audio/linux-f10-sdl_mixer/Makefile')
-rw-r--r--audio/linux-f10-sdl_mixer/Makefile29
1 files changed, 17 insertions, 12 deletions
diff --git a/audio/linux-f10-sdl_mixer/Makefile b/audio/linux-f10-sdl_mixer/Makefile
index 8a21370a5e18..4019dc86798c 100644
--- a/audio/linux-f10-sdl_mixer/Makefile
+++ b/audio/linux-f10-sdl_mixer/Makefile
@@ -1,27 +1,32 @@
-# New ports collection makefile for: linux-sdl_mixer
-# Date created: 25 May 2007
-# Whom: Marcus von Appen <mva@sysfault.org>
+# New ports collection makefile for: audio/linux-f8-sdl_mixer
+# Date created: 2008-04-03
+# Whom: bsam
#
# $FreeBSD$
#
PORTNAME= sdl_mixer
-DISTVERSION= 1.2.6
+PORTVERSION= 1.2.8
CATEGORIES= audio linux
-MASTER_SITE_SUBDIR= ../extras/${LINUX_DIST_VER}/${LINUX_RPM_ARCH}/
-DISTNAME= SDL_mixer-${PORTVERSION}-3.fc${LINUX_DIST_VER}
+PKGNAMEPREFIX= linux-f8-
+DISTNAME= ${LINUX_NAME}-${PORTVERSION}-${RPMVERSION}
-MAINTAINER= mva@FreeBSD.org
-COMMENT= A sample multi-channel audio mixer library (Linux version)
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= A sample multi-channel audio mixer library (Linux Fedora 8)
ONLY_FOR_ARCHS= i386 amd64
USE_LINUX_RPM= yes
USE_LINUX_APPS= sdl12
-LINUX_DIST_VER= 4
+LINUX_NAME= SDL_mixer
+LINUX_DIST_VER= 8
+RPMVERSION= 6.fc8
+BRANDELF_FILES= usr/bin/playmus usr/bin/playwave
USE_LDCONFIG= yes
-AUTOMATIC_PLIST=yes
+
+PLIST_FILES= usr/bin/playmus usr/lib/libSDL_mixer-1.2.so.0 \
+ usr/bin/playwave usr/lib/libSDL_mixer-1.2.so.0.2.6
+DOCSDIR= ${PREFIX}/usr/share/doc/${LINUX_NAME}-${PORTVERSION}
+PORTDOCS= CHANGES COPYING README
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-MASTER_SITE_SRC_SUBDIR= ../extras/${LINUX_DIST_VER}/SRPMS
-BRANDELF_DIRS= usr/bin
.include <bsd.port.mk>