aboutsummaryrefslogtreecommitdiff
path: root/audio/linuxsampler/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /audio/linuxsampler/Makefile
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'audio/linuxsampler/Makefile')
-rw-r--r--audio/linuxsampler/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/audio/linuxsampler/Makefile b/audio/linuxsampler/Makefile
index 375de399104b..6ef8a32fd1ac 100644
--- a/audio/linuxsampler/Makefile
+++ b/audio/linuxsampler/Makefile
@@ -32,19 +32,19 @@ USE_GNOME= gnomehack
USE_SQLITE= 3
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" HAVE_UNIX98=1
+CONFIGURE_ENV= HAVE_UNIX98=1
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
MAN1= linuxsampler.1
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
.if defined(WITHOUT_JACK)
-CONFIGURE_ARGS+=--disable-jack-driver
+CONFIGURE_ARGS+=--disable-jack-driver
.else
LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
.endif
@@ -66,7 +66,7 @@ BUILD_DEPENDS+= dssi>=0:${PORTSDIR}/audio/dssi
RUN_DEPENDS+= dssi>=0:${PORTSDIR}/audio/dssi
PLIST_SUB+= DSSI=""
.else
-CONFIGURE_ENV+= ac_cv_header_dssi_h=no
+CONFIGURE_ENV+= ac_cv_header_dssi_h=no
PLIST_SUB+= DSSI="@comment "
.endif