aboutsummaryrefslogtreecommitdiff
path: root/audio/littlefly-lv2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-08 00:32:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-08 00:32:27 +0000
commitcbdd9d9db1b424522d78c3181dd578b876a3f2ca (patch)
treeedb1034c60b30cfa34e78d8833f9f4c33fd5b61e /audio/littlefly-lv2
parente311dabb4f2a3f556c076f110b82e6c3415f4a16 (diff)
downloadports-cbdd9d9db1b424522d78c3181dd578b876a3f2ca.tar.gz
ports-cbdd9d9db1b424522d78c3181dd578b876a3f2ca.zip
New port: audio/littlefly-lv2: Overdrive/distortion pedal simulation LV2 plugin
Diffstat (limited to 'audio/littlefly-lv2')
-rw-r--r--audio/littlefly-lv2/Makefile30
-rw-r--r--audio/littlefly-lv2/distinfo5
-rw-r--r--audio/littlefly-lv2/files/patch-LittleFly_Makefile19
-rw-r--r--audio/littlefly-lv2/pkg-descr3
4 files changed, 57 insertions, 0 deletions
diff --git a/audio/littlefly-lv2/Makefile b/audio/littlefly-lv2/Makefile
new file mode 100644
index 000000000000..f35eff5713e0
--- /dev/null
+++ b/audio/littlefly-lv2/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= littlefly
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0
+CATEGORIES= audio
+PKGNAMESUFFIX= -lv2
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Overdrive/distortion pedal simulation LV2 plugin
+
+LICENSE= BSD0CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= lv2>0:audio/lv2
+
+USES= gmake gnome localbase pkgconfig xorg
+USE_GNOME= cairo
+USE_XORG= x11
+USE_BINUTILS= yes # linking needs some GNU features, fails on 12 without this, see https://github.com/brummer10/GxPlugins.lv2/issues/9
+
+USE_GITHUB= yes
+GH_ACCOUNT= brummer10
+GH_PROJECT= LittleFly.lv2
+GH_TUPLE= brummer10:libxputty:70c910d:libxputty/libxputty
+
+PLIST_FILES= lib/lv2/LittleFly.lv2/LittleFly.so \
+ lib/lv2/LittleFly.lv2/LittleFly.ttl \
+ lib/lv2/LittleFly.lv2/LittleFly_ui.so \
+ lib/lv2/LittleFly.lv2/manifest.ttl
+
+.include <bsd.port.mk>
diff --git a/audio/littlefly-lv2/distinfo b/audio/littlefly-lv2/distinfo
new file mode 100644
index 000000000000..fd0184e3bc8e
--- /dev/null
+++ b/audio/littlefly-lv2/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1617770944
+SHA256 (brummer10-LittleFly.lv2-v1.0_GH0.tar.gz) = 586b89ff0e18a3700a06d4c53792f5a79e859a22ee7f1db8988220da009b3ea7
+SIZE (brummer10-LittleFly.lv2-v1.0_GH0.tar.gz) = 102121
+SHA256 (brummer10-libxputty-70c910d_GH0.tar.gz) = 34879c6a7a7de9dc48503486b75b90b4db6a42da8d019215dc741425d92a8c51
+SIZE (brummer10-libxputty-70c910d_GH0.tar.gz) = 275065
diff --git a/audio/littlefly-lv2/files/patch-LittleFly_Makefile b/audio/littlefly-lv2/files/patch-LittleFly_Makefile
new file mode 100644
index 000000000000..8a2c445c08fa
--- /dev/null
+++ b/audio/littlefly-lv2/files/patch-LittleFly_Makefile
@@ -0,0 +1,19 @@
+--- LittleFly/Makefile.orig 2021-04-08 00:24:47 UTC
++++ LittleFly/Makefile
+@@ -3,11 +3,11 @@
+ STRIP ?= strip
+ # check if user is root
+ user = $(shell whoami)
+- ifeq ($(user),root)
+- INSTALL_DIR ?= /usr/lib/lv2
+- else
+- INSTALL_DIR ?= ~/.lv2
+- endif
++ #ifeq ($(user),root)
++ INSTALL_DIR ?= $(PREFIX)/lib/lv2
++ #else
++ #INSTALL_DIR ?= ~/.lv2
++ #endif
+
+ # check CPU and supported optimization flags
+ ifeq ($(UNAME), Linux)
diff --git a/audio/littlefly-lv2/pkg-descr b/audio/littlefly-lv2/pkg-descr
new file mode 100644
index 000000000000..2507f26588d6
--- /dev/null
+++ b/audio/littlefly-lv2/pkg-descr
@@ -0,0 +1,3 @@
+LittleFly is an LV2 plugin performing overdrive pedal simulation.
+
+WWW: https://github.com/brummer10/LittleFly.lv2