aboutsummaryrefslogtreecommitdiff
path: root/audio/lollypop/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /audio/lollypop/Makefile
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'audio/lollypop/Makefile')
-rw-r--r--audio/lollypop/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/audio/lollypop/Makefile b/audio/lollypop/Makefile
index cd4255cec761..6d1ac720fd9a 100644
--- a/audio/lollypop/Makefile
+++ b/audio/lollypop/Makefile
@@ -13,14 +13,14 @@ COMMENT= Play and organize your music collection
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7.8:databases/py-sqlite3 \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>=2.7.8:databases/py-sqlite3@${PY_FLAVOR} \
itstool:textproc/itstool \
- ${PYTHON_PKGNAMEPREFIX}dbus>=1.1.1:devel/py3-dbus \
- ${PYTHON_PKGNAMEPREFIX}gstreamer1>=1.4.0:multimedia/py3-gstreamer1
+ ${PYTHON_PKGNAMEPREFIX}dbus>=1.1.1:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gstreamer1>=1.4.0:multimedia/py-gstreamer1@${PY_FLAVOR}
LIB_DEPENDS= libnotify.so:devel/libnotify \
libtotem-plparser.so:multimedia/totem-pl-parser
-USES= shebangfix python:3 pkgconfig gettext gmake sqlite tar:xz
+USES= shebangfix python:3.4+ pkgconfig gettext gmake sqlite tar:xz
GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk30 py3gobject3 introspection:build intltool intlhack
USE_GSTREAMER1= yes mpg123 ogg flac opus libav faad good speex
@@ -36,11 +36,4 @@ PULSEAUDIO_USE= gstreamer1=pulse
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
-
-.if defined(PACKAGE_BUILDING) && !defined(PACKAGE_BUILDING_FLAVORS) && \
- ${PYTHON_VER} != ${PYTHON_DEFAULT}
-IGNORE= you have python ${PYTHON_DEFAULT} set as the default, and this needs ${PYTHON_VER}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>