aboutsummaryrefslogtreecommitdiff
path: root/audio/lv2proc/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-04-20 00:59:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-04-20 00:59:17 +0000
commitd67b5a7e213d3b0cbb690762194510b1cc4a2588 (patch)
tree5fc03eb4b048dcddbc9a1a4e91fdb61c359e34fc /audio/lv2proc/Makefile
parenta6125ada1894f9adb3f562fdc17e48aefcf53ae4 (diff)
downloadports-d67b5a7e213d3b0cbb690762194510b1cc4a2588.tar.gz
ports-d67b5a7e213d3b0cbb690762194510b1cc4a2588.zip
New port: audio/lv2proc: Simple command line effect processor using LV2 plugins
Notes
Notes: svn path=/head/; revision=532170
Diffstat (limited to 'audio/lv2proc/Makefile')
-rw-r--r--audio/lv2proc/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/lv2proc/Makefile b/audio/lv2proc/Makefile
new file mode 100644
index 000000000000..333d4c858a9d
--- /dev/null
+++ b/audio/lv2proc/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= lv2proc
+DISTVERSION= 0.5.1
+CATEGORIES= audio
+MASTER_SITES= SF/naspro/naspro/${DISTVERSION}/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Simple command line effect processor using LV2 plugins
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= liblilv-0.so:audio/lilv \
+ libserd-0.so:devel/serd \
+ libsndfile.so:audio/libsndfile \
+ libsord-0.so:devel/sord \
+ libsratom-0.so:audio/sratom
+
+USES= gmake pkgconfig tar:bz2
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/lv2proc \
+ man/man1/lv2proc.1.gz
+
+.include <bsd.port.mk>