aboutsummaryrefslogtreecommitdiff
path: root/audio/lvtk/Makefile
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-08-13 22:34:00 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-08-13 22:34:00 +0000
commita1453be727eb6e9cff615021bf325635dcd6cd64 (patch)
tree5e72b90fa268ffc23b07837b7f5c256d880ca4c8 /audio/lvtk/Makefile
parent368f3a8d4276aa061e2b91f5ea3a91a37cac9002 (diff)
downloadports-a1453be727eb6e9cff615021bf325635dcd6cd64.tar.gz
ports-a1453be727eb6e9cff615021bf325635dcd6cd64.zip
This toolkit contains libraries that wrap the LV2 C API and extensions into
easy to use C++ classes. The original work for this was mostly done by Lars Luthman in lv2-c++-tools. WWW: https://github.com/lvtk/lvtk PR: 221272 Submitted by: Yuri Victorovich (maintainer) Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D12013
Notes
Notes: svn path=/head/; revision=447921
Diffstat (limited to 'audio/lvtk/Makefile')
-rw-r--r--audio/lvtk/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/audio/lvtk/Makefile b/audio/lvtk/Makefile
new file mode 100644
index 000000000000..5abb7b031141
--- /dev/null
+++ b/audio/lvtk/Makefile
@@ -0,0 +1,21 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= lvtk
+PORTVERSION= 1.2.0
+CATEGORIES= audio
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Wraps the LV2 C API and extensions into easy to use C++ classes
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= lv2>0:audio/lv2 \
+ ${LOCALBASE}/include/gtkmm-2.4/gtkmm.h:x11-toolkits/gtkmm24
+
+USES= waf pkgconfig
+USE_GITHUB= yes
+GH_TAGNAME= 7c0ffdf
+
+.include <bsd.port.mk>