aboutsummaryrefslogtreecommitdiff
path: root/audio/mhwaveedit
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-08 14:12:20 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-08 14:12:20 +0000
commit475424df69e5093be56efd491fbf514ea398a65b (patch)
treef4d54ca067a40191fd2bd3afb7ee0221819c5a53 /audio/mhwaveedit
parentf115f1788bbbe3b76d72e2655ecffa05a1b0ba20 (diff)
downloadports-475424df69e5093be56efd491fbf514ea398a65b.tar.gz
ports-475424df69e5093be56efd491fbf514ea398a65b.zip
- Update to version 1.2.6
PR: ports/62526 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=100386
Diffstat (limited to 'audio/mhwaveedit')
-rw-r--r--audio/mhwaveedit/Makefile12
-rw-r--r--audio/mhwaveedit/distinfo4
-rw-r--r--audio/mhwaveedit/files/patch-src::datasource.c12
3 files changed, 6 insertions, 22 deletions
diff --git a/audio/mhwaveedit/Makefile b/audio/mhwaveedit/Makefile
index eb9142ec0b82..a46b280851bb 100644
--- a/audio/mhwaveedit/Makefile
+++ b/audio/mhwaveedit/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= mhwaveedit
-PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTVERSION= 1.2.6
CATEGORIES= audio
MASTER_SITES= http://www.mtek.chalmers.se/~hjormagn/
@@ -18,17 +17,17 @@ COMMENT= A graphical program for editing sound files
LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
portaudio.0:${PORTSDIR}/audio/portaudio
-USE_REINPLACE= yes
USE_GNOME= gnomehack gnometarget gtk20
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --without-sdl
+CONFIGURE_ARGS= --disable-optimization --without-sdl
+
+PLIST_FILES= bin/mhwaveedit
.if defined(WITH_DOUBLE_SAMPLES)
CONFIGURE_ARGS+= --with-double-samples
.endif
-PLIST_FILES= bin/mhwaveedit
pre-everything::
@${ECHO_MSG} ""
@@ -40,7 +39,4 @@ pre-everything::
@${ECHO_MSG} " quality for 24/32-bit samplerates)"
@${ECHO_MSG} ""
-post-patch:
- @${REINPLACE_CMD} -e 's| -O2||g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/audio/mhwaveedit/distinfo b/audio/mhwaveedit/distinfo
index e98ea3cac2ef..81f7742f78fa 100644
--- a/audio/mhwaveedit/distinfo
+++ b/audio/mhwaveedit/distinfo
@@ -1,2 +1,2 @@
-MD5 (mhwaveedit-1.2.5.tar.gz) = 86559970adc4dca26c7631a135682a11
-SIZE (mhwaveedit-1.2.5.tar.gz) = 220945
+MD5 (mhwaveedit-1.2.6.tar.gz) = 7b824345b21b4f98dbbc487551c6cbf9
+SIZE (mhwaveedit-1.2.6.tar.gz) = 223379
diff --git a/audio/mhwaveedit/files/patch-src::datasource.c b/audio/mhwaveedit/files/patch-src::datasource.c
deleted file mode 100644
index 9213f316e593..000000000000
--- a/audio/mhwaveedit/files/patch-src::datasource.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/datasource.c.orig Tue Dec 23 07:06:26 2003
-+++ src/datasource.c Sat Dec 27 00:59:02 2003
-@@ -212,8 +212,8 @@
-
- Datasource *datasource_byteswap(Datasource *source)
- {
-- if (source == NULL) return NULL;
- Datasource *ds;
-+ if (source == NULL) return NULL;
- ds = gtk_type_new(datasource_get_type());
- ds->type = DATASOURCE_BYTESWAP;
- memcpy(&(ds->format),&(source->format),sizeof(Dataformat));