aboutsummaryrefslogtreecommitdiff
path: root/audio/moc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-02-21 12:25:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-02-21 12:25:26 +0000
commit544f6fab1b066d16671d43794d86d5a6d5371b1c (patch)
tree03b101cbf04b3f76106d674245d7ee4715655727 /audio/moc
parent256b77bdec7d678a4d41f7dd88942d9349649e4d (diff)
downloadports-544f6fab1b066d16671d43794d86d5a6d5371b1c.tar.gz
ports-544f6fab1b066d16671d43794d86d5a6d5371b1c.zip
- Update to 2.4.0
Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=156579
Diffstat (limited to 'audio/moc')
-rw-r--r--audio/moc/Makefile15
-rw-r--r--audio/moc/distinfo6
-rw-r--r--audio/moc/files/patch-audio__conversion.c35
-rw-r--r--audio/moc/files/patch-interface.c20
-rw-r--r--audio/moc/pkg-descr2
-rw-r--r--audio/moc/pkg-plist11
6 files changed, 22 insertions, 67 deletions
diff --git a/audio/moc/Makefile b/audio/moc/Makefile
index 43f1ae7cb797..f84ae1bb9c66 100644
--- a/audio/moc/Makefile
+++ b/audio/moc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= moc
-PORTVERSION= 2.3.3
+PORTVERSION= 2.4.0
CATEGORIES= audio
MASTER_SITES= ftp://ftp.daper.net/pub/soft/moc/stable/
@@ -26,6 +26,7 @@ LDFLAGS= -L${LOCALBASE}/lib
OPTIONS= JACK "JACK support" off \
MP3 "MP3 support" on \
+ FFMPEG "FFMPEG support" off \
MUSEPACK "Musepack (mpc) support" off \
VORBIS "Ogg Vorbis support" on \
FLAC "FLAC support" off \
@@ -36,8 +37,8 @@ OPTIONS= JACK "JACK support" off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 400010
-LIB_DEPENDS+= ncurses.5:${PORTSDIR}/devel/ncurses
+.if ${OSVERSION} < 500000
+IGNORE= requires C99 string functions in libc
.endif
.if defined(WITH_JACK)
@@ -64,7 +65,7 @@ CONFIGURE_ARGS+= --without-musepack
.if defined(WITH_VORBIS)
LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
-PLIST_FILES+= lib/moc/decoder_plugins/libogg_decoder.so
+PLIST_FILES+= lib/moc/decoder_plugins/libvorbis_decoder.so
.else
CONFIGURE_ARGS+= --without-ogg
.endif
@@ -76,6 +77,12 @@ PLIST_FILES+= lib/moc/decoder_plugins/libflac_decoder.so
CONFIGURE_ARGS+= --without-flac
.endif
+.if defined(WITH_FFMPEG)
+LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+.else
+CONFIGURE_ARGS+= --without-ffmpeg
+.endif
+
.if defined(WITH_SNDFILE)
LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
PLIST_FILES+= lib/moc/decoder_plugins/libsndfile_formats_decoder.so
diff --git a/audio/moc/distinfo b/audio/moc/distinfo
index f055d27d8c84..16cbc45eadde 100644
--- a/audio/moc/distinfo
+++ b/audio/moc/distinfo
@@ -1,3 +1,3 @@
-MD5 (moc-2.3.3.tar.bz2) = 6754034097b282b1894b924ba2c8e98d
-SHA256 (moc-2.3.3.tar.bz2) = e6fe30288725df040b03c7e8c6b4553ea6e53908ed534d5c61936e28a268edfc
-SIZE (moc-2.3.3.tar.bz2) = 392019
+MD5 (moc-2.4.0.tar.bz2) = 5b31665390fb0b30d19dadec4e90abb8
+SHA256 (moc-2.4.0.tar.bz2) = 9fffb28f0edb020dffe605b0d69d94f1b3abe3d1e8beffa2ea7809daecaff136
+SIZE (moc-2.4.0.tar.bz2) = 419792
diff --git a/audio/moc/files/patch-audio__conversion.c b/audio/moc/files/patch-audio__conversion.c
deleted file mode 100644
index 608f49b91c9a..000000000000
--- a/audio/moc/files/patch-audio__conversion.c
+++ /dev/null
@@ -1,35 +0,0 @@
---- audio_conversion.c.orig Fri Jul 29 10:46:36 2005
-+++ audio_conversion.c Fri Sep 9 12:50:22 2005
-@@ -52,6 +52,32 @@
- #include "log.h"
- #include "options.h"
-
-+/* FreeBSD 4.x lacks these */
-+
-+#ifndef INT8_MIN
-+#define INT8_MIN CHAR_MIN
-+#endif
-+
-+#ifndef INT8_MAX
-+#define INT8_MAX CHAR_MAX
-+#endif
-+
-+#ifndef INT16_MIN
-+#define INT16_MIN SHRT_MIN
-+#endif
-+
-+#ifndef INT16_MAX
-+#define INT16_MAX SHRT_MAX
-+#endif
-+
-+#ifndef INT32_MIN
-+#define INT32_MIN INT_MIN
-+#endif
-+
-+#ifndef INT32_MAX
-+#define INT32_MAX INT_MAX
-+#endif
-+
- /* Byte order conversion */
- /* TODO: use functions from byteswap.h if available */
- #define SWAP_INT16(l) ((int16_t) \
diff --git a/audio/moc/files/patch-interface.c b/audio/moc/files/patch-interface.c
deleted file mode 100644
index 637dc16cc345..000000000000
--- a/audio/moc/files/patch-interface.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- interface.c.orig Thu Dec 29 15:06:55 2005
-+++ interface.c Tue Jan 10 16:15:06 2006
-@@ -2948,6 +2948,8 @@
-
- enum key_cmd cmd;
-
-+ int selected;
-+
- /* in this entry, we also operate on the menu */
- if ((cmd = get_key_cmd(CON_ENTRY, ch)) == KEY_CMD_WRONG)
- cmd = get_key_cmd(CON_MENU, ch);
-@@ -3003,7 +3005,7 @@
-
- if (ch == '\n' && entry.text[0] && menu_nitems(curr_menu))
- go_file ();
-- int selected = menu_curritem(curr_menu);
-+ selected = menu_curritem(curr_menu);
- if ((selected < 0 && old_curr_menu) ||
- (curr_menu->nitems<=selected && old_curr_menu) ||
- (old_curr_menu && (menu_item_get_type(curr_menu, selected))!=F_DIR))
diff --git a/audio/moc/pkg-descr b/audio/moc/pkg-descr
index 8f0480e74078..720f691737c2 100644
--- a/audio/moc/pkg-descr
+++ b/audio/moc/pkg-descr
@@ -7,6 +7,6 @@ because the next file to be played is pre-cached while playing the current
file.
Supported file formats are: MP3, Ogg Vorbis, FLAC, Musepack (mpc), Speex, WAVE,
-AIFF, AU, SVX, Sphere Nist WAV, IRCAM SF, Creative VOC.
+AIFF, AU, SVX, Sphere Nist WAV, IRCAM SF, Creative VOC, AAC, MP4, Real, WMA.
WWW: http://moc.daper.net/
diff --git a/audio/moc/pkg-plist b/audio/moc/pkg-plist
index 04ec0de20d42..63c9fd87ac4d 100644
--- a/audio/moc/pkg-plist
+++ b/audio/moc/pkg-plist
@@ -1,16 +1,19 @@
bin/mocp
-share/doc/moc/README
-share/doc/moc/THANKS
share/doc/moc/config.example
+share/doc/moc/THANKS
+share/doc/moc/README
share/doc/moc/keymap.example
share/moc/themes/black_theme
+share/moc/themes/darkdot_theme
share/moc/themes/example_theme
share/moc/themes/green_theme
+share/moc/themes/moca_theme
share/moc/themes/nightly_theme
+share/moc/themes/red_theme
share/moc/themes/transparent-background
share/moc/themes/yellow_red_theme
-@dirrm lib/moc/decoder_plugins
-@dirrm lib/moc
@dirrm share/moc/themes
@dirrm share/moc
@dirrm share/doc/moc
+@dirrm lib/moc/decoder_plugins
+@dirrm lib/moc