aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3blaster/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2007-08-02 12:58:00 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2007-08-02 12:58:00 +0000
commit35291d2551604b7cf8538260c517f04b1664d7b7 (patch)
tree33e508c154ebcfb3f96291fdb1a9eb09dae974b1 /audio/mp3blaster/Makefile
parent6031db5ce751cfbae4180d55172078eec406fa6c (diff)
downloadports-35291d2551604b7cf8538260c517f04b1664d7b7.tar.gz
ports-35291d2551604b7cf8538260c517f04b1664d7b7.zip
- Introduce WITH_NAS knob
- Minor style nits
Notes
Notes: svn path=/head/; revision=196959
Diffstat (limited to 'audio/mp3blaster/Makefile')
-rw-r--r--audio/mp3blaster/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/audio/mp3blaster/Makefile b/audio/mp3blaster/Makefile
index 6a06cfa774bc..0f2280b1015f 100644
--- a/audio/mp3blaster/Makefile
+++ b/audio/mp3blaster/Makefile
@@ -38,12 +38,12 @@ PORTDOCS= AUTHORS CREDITS ChangeLog FAQ README TODO
.include <bsd.port.pre.mk>
.if defined(WITH_LIRC)
-LIB_DEPENDS+= lirc_client.1:${PORTSDIR}/comms/lirc
+LIB_DEPENDS+= lirc_client.1:${PORTSDIR}/comms/lirc
CONFIGURE_ARGS+= --with-lirc
.endif
.if !defined(WITHOUT_SIDPLAY)
-LIB_DEPENDS+= sidplay.1:${PORTSDIR}/audio/libsidplay
+LIB_DEPENDS+= sidplay.1:${PORTSDIR}/audio/libsidplay
.else
CONFIGURE_ARGS+= --without-sidplay
.endif
@@ -51,7 +51,7 @@ CONFIGURE_ARGS+= --without-sidplay
.if defined(WITHOUT_VORBIS)
CONFIGURE_ARGS+= --without-oggvorbis
.else
-LIB_DEPENDS+= vorbisfile.5:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbisfile.5:${PORTSDIR}/audio/libvorbis
.endif
.if !defined(WITHOUT_SDL)
@@ -61,6 +61,14 @@ USE_SDL= yes
CONFIGURE_ARGS+= --without-sdl
.endif
+.if defined(WITH_NAS)
+CONFIGURE_ARGS+= --with-nas
+LIB_DEPENDS+= audio.2:${PORTSDIR}/audio/nas
+LDFLAGS+= -laudio
+.else
+CONFIGURE_ARGS+= --without-nas
+.endif
+
.if ${HAVE_GNOME:Mesound} != ""
USE_GNOME+= esound
CONFIGURE_ARGS+= --with-esd