aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3guessenc/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-01 13:28:47 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-01 13:28:47 +0000
commit1b3d2d021c7bb7d659b599f7b4c01190805ad570 (patch)
treea65a9f490bf890bd3776bf55367af933b7736baf /audio/mp3guessenc/Makefile
parent0059228c1dcb764289ae0876ff200df0ec723da3 (diff)
downloadports-1b3d2d021c7bb7d659b599f7b4c01190805ad570.tar.gz
ports-1b3d2d021c7bb7d659b599f7b4c01190805ad570.zip
New port
This is a command-line utility which tries to determine the encoder used to create an mp3 file. Each encoder has unique characteristics fingerprinted into each file. This program analyzes algorithms that are used in any given file and determines which encoder was used. For example the Xing encoder never uses short blocks. PR: 86768 Submitted by: Emanuel Haupt <ehaupt@critical.ch> Approved by: pav (mentor)
Notes
Notes: svn path=/head/; revision=143906
Diffstat (limited to 'audio/mp3guessenc/Makefile')
-rw-r--r--audio/mp3guessenc/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/audio/mp3guessenc/Makefile b/audio/mp3guessenc/Makefile
new file mode 100644
index 000000000000..3c2290f9ea62
--- /dev/null
+++ b/audio/mp3guessenc/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: mp3guessenc
+# Date created: 1 Oct 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3guessenc
+PORTVERSION= 0.21
+CATEGORIES= audio
+MASTER_SITES= http://shibatch.sourceforge.net/download/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Utility for guessing which encoder was used to encode an mp3 file
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}
+
+PLIST_FILES= bin/mp3guessenc
+
+post-extract:
+ @${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
+ ${WRKSRC}/${PORTNAME}.c \
+ ${WRKSRC}/VbrTag.h
+
+do-build:
+ ${CC} ${CFLAGS} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>