aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3lint/Makefile
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-08-20 13:48:23 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-08-20 13:48:23 +0000
commit11cbcdc5678841c8835e9e3b625d6b39fc05a5c7 (patch)
tree11503f626721274f9a832343c80fd44937218812 /audio/mp3lint/Makefile
parent782f0099c5ca5daaa2099d28d16084efd36a07b4 (diff)
downloadports-11cbcdc5678841c8835e9e3b625d6b39fc05a5c7.tar.gz
ports-11cbcdc5678841c8835e9e3b625d6b39fc05a5c7.zip
- mp3lint is a tool to check collections of audio files for various problems. It is highly configurable, allowing you to specify your preferred format for filenames, minimum bitrate, tests to ignore, etc.
Formats checked are currently mp3, ogg, wav, flac, au, and m3u playlists. mp3lint is implemented as separate tools (perl modules), each of which implements a set of testes. There are a total of 32 different tests. WWW: http://erislabs.net/ianb/projects/mp3lint/ PR: ports/148899 Submitted by: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
Notes
Notes: svn path=/head/; revision=259632
Diffstat (limited to 'audio/mp3lint/Makefile')
-rw-r--r--audio/mp3lint/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/audio/mp3lint/Makefile b/audio/mp3lint/Makefile
new file mode 100644
index 000000000000..8c29f73d4897
--- /dev/null
+++ b/audio/mp3lint/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: mp3lint
+# Date created: 2010-07-06
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3lint
+PORTVERSION= 0.9
+CATEGORIES= audio perl5
+MASTER_SITES= http://erislabs.net/ianb/projects/${PORTNAME}/ \
+ http://sunpoet.net/distfiles/
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= A configurable tool to check collections of audio files
+
+BUILD_DEPENDS= ${SITE_PERL}/MP3/Archive.pm:${PORTSDIR}/audio/libmp3-archive-perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= mp3lintsum.1 mp3lintskip.1 mp3lint.1
+MAN3= mp3lint-tools.3
+MAN5= mp3lintrc.5
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^DESTINSTALLSYSCONFDIR/ s|DESTDIR|PREFIX|' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>