aboutsummaryrefslogtreecommitdiff
path: root/audio/mp3plot
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-06-12 10:32:45 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-06-12 10:32:45 +0000
commit2fac553026acc295f30496e03e36b989c64820a4 (patch)
treeda7e4413224b5a4608bed8bfd2b8b0c5f22e8033 /audio/mp3plot
parent5ffabe9ffb95eb65d2e1c30b93b993e09dea15d1 (diff)
downloadports-2fac553026acc295f30496e03e36b989c64820a4.tar.gz
ports-2fac553026acc295f30496e03e36b989c64820a4.zip
Add port audio/mp3plot:
mp3plot prints out a plot of the bitrate distribution of a VBR MP3 file (it will also do it for CBR files although it isn't very meaningful). WWW: http://p.outlyer.net/mp3plot/ Author: Toni Corvera < outlyer at gmail dot com >
Notes
Notes: svn path=/head/; revision=193315
Diffstat (limited to 'audio/mp3plot')
-rw-r--r--audio/mp3plot/Makefile28
-rw-r--r--audio/mp3plot/distinfo3
-rw-r--r--audio/mp3plot/pkg-descr5
3 files changed, 36 insertions, 0 deletions
diff --git a/audio/mp3plot/Makefile b/audio/mp3plot/Makefile
new file mode 100644
index 000000000000..1c521ccb5edb
--- /dev/null
+++ b/audio/mp3plot/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: mp3plot
+# Date created: 12 June 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mp3plot
+DISTVERSION= 0.4.0a
+CATEGORIES= audio
+MASTER_SITES= http://p.outlyer.net/mp3plot/files/ CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Mp3 bitrate plot tool
+
+LIB_DEPENDS= boost_thread.3:${PORTSDIR}/devel/boost
+
+GNU_CONFIGURE= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+PLIST_FILES= bin/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e '/HAVE.*MAGICK=1/s|1|0|;/^#define HAVE.*MAGICK/s|1|0|;\
+ /test.*==/s|==|=|;s/-O2//' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/audio/mp3plot/distinfo b/audio/mp3plot/distinfo
new file mode 100644
index 000000000000..a746339dc233
--- /dev/null
+++ b/audio/mp3plot/distinfo
@@ -0,0 +1,3 @@
+MD5 (mp3plot-0.4.0a.tar.gz) = 5b1189a6e524fa9ffdf73c37505de4df
+SHA256 (mp3plot-0.4.0a.tar.gz) = 3c6e2fe90d399c300392ef81b714791591873f69508329cb957451d89c6eeddf
+SIZE (mp3plot-0.4.0a.tar.gz) = 137150
diff --git a/audio/mp3plot/pkg-descr b/audio/mp3plot/pkg-descr
new file mode 100644
index 000000000000..9384a3faba04
--- /dev/null
+++ b/audio/mp3plot/pkg-descr
@@ -0,0 +1,5 @@
+mp3plot prints out a plot of the bitrate distribution of a VBR MP3 file
+(it will also do it for CBR files although it isn't very meaningful).
+
+WWW: http://p.outlyer.net/mp3plot/
+Author: Toni Corvera < outlyer at gmail dot com >